aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/moregroupware
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
committermiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
commitb5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7 (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /deskutils/moregroupware
parent4c148339a17778393b116c6e7051a9bc484e786a (diff)
downloadfreebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.gz
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.zst
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Diffstat (limited to 'deskutils/moregroupware')
-rw-r--r--deskutils/moregroupware/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
index 3627cd77dbdf..67bbcfe6aef3 100644
--- a/deskutils/moregroupware/Makefile
+++ b/deskutils/moregroupware/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: deskutils/moregroupware
-# Date created: December 30th 2003
-# Whom: Rob Evers <rob@debank.tv>
-#
+# Created by: Rob Evers <rob@debank.tv>
# $FreeBSD$
-#
PORTNAME= moregroupware
PORTVERSION= 0.7.4
@@ -24,22 +20,22 @@ USE_PHP= curl \
WANT_PHP_MOD= yes
-OPTIONS= ADDONS "install additional workgroup features (addons)" off \
- POSTGRESQL "use PostgreSQL instead of MySQL" off
+OPTIONS_DEFINE= ADDONS PGSQL NLS
+ADDONS_DESC= install additional workgroup features (addons)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
.endif
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= ${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql74-server
.else
RUN_DEPENDS+= ${LOCALBASE}/bin/mysql:${PORTSDIR}/databases/mysql50-server
.endif
-.if defined (WITH_ADDONS)
+.if ${PORT_OPTIONS:MADDONS}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-addons-${PORTVERSION}${EXTRACT_SUFX}
PLIST_SUB+= ADDONS=""
@@ -57,4 +53,4 @@ do-install:
post-install:
${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>