aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/myitcrm
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-02-26 22:04:06 +0800
committerscheidell <scheidell@FreeBSD.org>2012-02-26 22:04:06 +0800
commitf133c89c250bd8cf086b5008d2bbc9046da9f29f (patch)
tree3b33c9616bf0dae7d71439227b61063e1ecfe30c /deskutils/myitcrm
parent92ffb71674c37b0a33746fa0410d0d632be37da6 (diff)
downloadfreebsd-ports-gnome-f133c89c250bd8cf086b5008d2bbc9046da9f29f.tar.gz
freebsd-ports-gnome-f133c89c250bd8cf086b5008d2bbc9046da9f29f.tar.zst
freebsd-ports-gnome-f133c89c250bd8cf086b5008d2bbc9046da9f29f.zip
- Update to 0.2.9.3
- Fix post-release bug which made billing sections not visible - Pass maintainership to submitter PR: ports/165478 Submitted by: Mel FLynn <rflynn@acsalaska.net> (maintainer) Approved by: gabor (mentor, implicit)
Diffstat (limited to 'deskutils/myitcrm')
-rw-r--r--deskutils/myitcrm/Makefile81
-rw-r--r--deskutils/myitcrm/distinfo4
-rw-r--r--deskutils/myitcrm/files/patch-bug263144
-rw-r--r--deskutils/myitcrm/files/pkg-message.in20
-rw-r--r--deskutils/myitcrm/pkg-plist97
5 files changed, 260 insertions, 86 deletions
diff --git a/deskutils/myitcrm/Makefile b/deskutils/myitcrm/Makefile
index 8ff975d5d26d..ab47b39933d4 100644
--- a/deskutils/myitcrm/Makefile
+++ b/deskutils/myitcrm/Makefile
@@ -6,44 +6,93 @@
#
PORTNAME= myitcrm
-PORTVERSION= 0.2.9.1
+PORTVERSION= 0.2.9.3
CATEGORIES= deskutils
MASTER_SITES= SF/myitcrm/
-DISTNAME= MyITCRM-${PORTVERSION}
+DISTNAME= MyITCRM1-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= MYIT CRM is a CRM project designed for Computer Servicing and Repairs
+MAINTAINER= rflynn@acsalaska.net
+COMMENT= MyIT CRM is a CRM project designed for Computer Servicing and Repairs
+
+LICENSE= GPLv3
USE_ZIP= yes
-USE_PHP+= mysql
-USE_MYSQL= yes
+USE_PHP= mysql session xml
NO_BUILD= yes
-WWWOWN= www
-WWWGRP= ${WWWOWN}
+WRKSRC= ${WRKDIR}/MyITCRM-${PORTVERSION}
-PKGMESSAGE= ${WRKDIR}/${PORTNAME}/pkg-message
SUB_FILES= pkg-message
PLIST_DIRSTRY= %%WWWDIR%%
+PATCH_STRIP= -p1
+WRITEABLE= conf.php log/access.log cache
+PORTEXAMPLES= htaccess.txt
+PORTDOCS= changelog.txt README.textile
+USE_DOS2UNIX= yes
-OPTIONS= APACHE "Use Apache webserver" on \
- LIGHTTPD "Use Lighttpd webserver" off
+OPTIONS= APACHE "Use Apache webserver" on \
+ PHPMOD "Use php module for Apache" off \
+ LIGHTTPD "Use Lighttpd webserver" off \
+ NGINX "Use Nginx" off
.include <bsd.port.options.mk>
-.if defined(WITH_APACHE)
-USE_APACHE= 22
+.if defined(WITH_PHPMOD)
+WANT_PHP_MOD= yes
+.else
+WANT_PHP_CGI= yes
+.endif
+
+.if !defined(WITHOUT_APACHE)
+USE_APACHE= 22+
.endif
.if defined(WITH_LIGHTTPD)
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif
+.if defined(WITH_NGINX)
+RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
+.endif
+
+# Set files to ignore.
+.for file in ${PORTEXAMPLES} ${PORTDOCS} LICENSE.txt
+WWW_IGNORE+= -not -name ${file}
+.endfor
+
+.if defined(MAINTAINER_MODE)
+trace-distfile: distclean
+ @cd ${.CURDIR} && make FETCH_ARGS=-vFpr makesum
+
+rm-install:
+ ${SU_CMD} '${RM} -rf ${WWWDIR}/install'
+
+.endif
do-install:
@${MKDIR} ${WWWDIR}
- @${CP} -r ${WRKDIR}/${PORTNAME}-${PORTVERSION}/* ${WWWDIR}
- @${TOUCH} ${WWWDIR}/conf.php
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR} '${WWW_IGNORE}'
+ @if [ ! -f ${WWWDIR}/conf.php ]; then \
+ ${CP} ${WWWDIR}/conf-default.php ${WWWDIR}/conf.php; \
+ fi
+.for ent in ${WRITEABLE}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${ent}
+ @${CHMOD} u+w ${WWWDIR}/${ent}
+.endfor
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in ${PORTEXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${ex} ${EXAMPLESDIR}
+.endfor
+.endif # NOPORTEXAMPLES
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif #NOPORTDOCS
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(MAINTAINER_MODE)
+ @${MAKE} -C ${.CURDIR} rm-install
+.endif
.include <bsd.port.mk>
diff --git a/deskutils/myitcrm/distinfo b/deskutils/myitcrm/distinfo
index 5308c53ee86b..1ad74e627f4c 100644
--- a/deskutils/myitcrm/distinfo
+++ b/deskutils/myitcrm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (MyITCRM-0.2.9.1.zip) = 877583b2c1de8a70a60478ece9b18db8b4571d284426916fdeddd153edc8dfb1
-SIZE (MyITCRM-0.2.9.1.zip) = 2035632
+SHA256 (MyITCRM1-0.2.9.3.zip) = 22560b9b5407cdc099fd775458dfb6bd34f0821dc5d57cd3a5e8e469a270a184
+SIZE (MyITCRM1-0.2.9.3.zip) = 2102844
diff --git a/deskutils/myitcrm/files/patch-bug263 b/deskutils/myitcrm/files/patch-bug263
new file mode 100644
index 000000000000..b0a1d2ade7f1
--- /dev/null
+++ b/deskutils/myitcrm/files/patch-bug263
@@ -0,0 +1,144 @@
+commit 8c0d263b2672df6727e1d0be3fecfdef3df8c1eb
+Author: unknown <Glen@.(none)>
+Date: Sun Feb 12 10:42:37 2012 +1100
+
+ FIXES: #263
+ Desc: Customers Address details not showing on HTML Invoices.
+
+diff --git a/templates/invoice/print_html.tpl b/templates/invoice/print_html.tpl
+index 2b79b32..eeeb2e1 100644
+--- a/templates/invoice/print_html.tpl
++++ b/templates/invoice/print_html.tpl
+@@ -7,15 +7,12 @@
+ <body>
+
+ <!-- BOF Top Row Section -->
+- <table width="700" height="125" border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
++ <table width="800px" height="125" border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <!-- COMPANY DETAILS -->
+- <td valign="top" align="left" width="35%">
++ <td valign="top" align="left" width="200px">
+ {foreach item=item from=$company}
+ <table border="0" cellpadding="0" cellspacing="0">
+- <!--<tr>
+- <td colspan="2"><b>{$item.COMPANY_NAME}</b></td>
+- </tr>-->
+ <tr>
+ <td valign="top"><b>{$translate_invoice_prn_address} :&nbsp;</b></td>
+ <td>{$item.COMPANY_ADDRESS|nl2br|regex_replace:"/[\r\t\n]/":" "}<br />{$item.COMPANY_CITY},<br />{$item.COMPANY_STATE},<br />{$item.COMPANY_ZIP}</td>
+@@ -37,21 +34,21 @@
+ </td>
+
+ <!-- LOGO and Company Name-->
+- <td valign="top" align="center" width="30%">
++ <td valign="top" align="center" width="300px">
+ <table border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+- <td width="100%">
+- <a><img src="images/logo.jpg" alt="" border="0"></a>
++ <td width="100%" align="center">
++ <img src="images/logo.jpg" height="100px" alt="" border="0">
+ </td>
+ </tr>
+ <tr>
+- <td style="text-align:center"><font size="+0"><b>{$item.COMPANY_NAME}</b></font></td>
++ <td style="text-align:center"><b>{$item.COMPANY_NAME}</b></td>
+ </tr>
+ </table>
+ </td>
+
+ <!-- Invoice details -->
+- <td valign="top" align="right" width="35%">
++ <td valign="top" align="right" width="200px">
+ <table border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td valign="top" width="90%" align="right">
+@@ -80,17 +77,17 @@
+ </table>
+ <!-- EOF Top Row Section - NB This table ends exactly where the envelope window starts-->
+ <br />
+-<!-- BOF Address Row
+- <table width="700" border="0" cellpadding="3" cellspacing="0" >
++<!-- BOF Address Row -->
++ <table width="800" border="0" cellpadding="3" cellspacing="0" >
+ <tr>
+ <td valign="top" width="10%" align="left"></td>
+ <td>
+- <!- - <font size="-1"><b>{$translate_invoice_prn_bill_to} :</b></font><br /> - - >
++ <p style="font:12px bold;">{$translate_invoice_prn_bill_to} :</p>
+ {foreach item=item from=$customer_details}
+- <font size="+0">{$item.CUSTOMER_DISPLAY_NAME}</font><br />
+- <font size="+0">{$item.CUSTOMER_ADDRESS|nl2br|regex_replace:"/[\r\t\n]/":" "}</font><br />
+- <font size="+0">{$item.CUSTOMER_CITY},</font><br />
+- <font size="+0">{$item.CUSTOMER_STATE} {$item.CUSTOMER_ZIP}</font>
++ {$item.CUSTOMER_DISPLAY_NAME}<br />
++ {$item.CUSTOMER_ADDRESS|nl2br|regex_replace:"/[\r\t\n]/":" "}<br />
++ {$item.CUSTOMER_CITY},<br />
++ {$item.CUSTOMER_STATE} {$item.CUSTOMER_ZIP}
+ {/foreach}
+ </td>
+ </tr>
+@@ -98,7 +95,8 @@
+ <!-- EOF Address Row -->
+
+ <!-- BOF Work Order Row -->
+- <table width="700" border="0" cellpadding="3" cellspacing="0" >
++{if $wo_description > NULL}
++ <table width="800" border="0" cellpadding="3" cellspacing="0" >
+ <tr>
+ <td><b>{$translate_invoice_prn_work_order}</b></td>
+ <td><b>{$translate_invoice_prn_work_order_resolution}</b></td>
+@@ -108,10 +106,11 @@
+ <td width="50%" valign="top" style="border-left: 1px solid;">{$wo_resolution}</td>
+ </tr>
+ </table>
++{/if}
+ <!-- EOF Work Order Row -->
+ <br />
+ <!-- BOF Invoice Details Row -->
+- <table width="700" border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse;">
++ <table width="800" border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td align="center" class="olotd5" ><font size="+2">{$translate_invoice_prn_invoice_details} {$item.CUSTOMER_DISPLAY_NAME}</font></td>
+ </tr>
+@@ -120,7 +119,7 @@
+ <br />
+ <!-- BOF Items Table Section -->
+ <!-- Labour Table -->
+- <table width="700" border="1" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
++ <table width="800" border="1" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td width="40" class="olohead"><b>{$translate_invoice_prn_qty}</b></td>
+ <td class="olohead"><b>{$translate_invoice_prn_labour_items}</b></td>
+@@ -143,7 +142,7 @@
+ <br />
+
+ <!-- Parts Table -->
+- <table width="700" border="1" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
++ <table width="800" border="1" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td width="40" class="olohead"><b>{$translate_invoice_prn_qty}</b></td>
+ <td class="olohead"><b>{$translate_invoice_prn_parts_items}</b></td>
+@@ -166,10 +165,10 @@
+ <!-- BOF Items Table Section -->
+ <br />
+ <!-- BOF Totals Box and Payments Section Row -->
+- <table width="700" border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse;">
++ <table width="800" border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td colspan="1" valign="TOP">
+- <table width="500" border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
++ <table width="600" border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td align="left" ><font size="-1"><b>{$translate_invoice_prn_payment_instructions}</b></font></td>
+ </tr>
+@@ -259,7 +258,7 @@
+ <br />
+ <br />
+ {if $thank_you > ''}
+-<table width="700" border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
++<table width="800" border="0" cellpadding="3" cellspacing="0" style="border-collapse: collapse;">
+ <tr>
+ <td align="center"><font size="-1">{$thank_you}</font></td>
+ </tr>
diff --git a/deskutils/myitcrm/files/pkg-message.in b/deskutils/myitcrm/files/pkg-message.in
index cdb206407418..a9ea9557a8fd 100644
--- a/deskutils/myitcrm/files/pkg-message.in
+++ b/deskutils/myitcrm/files/pkg-message.in
@@ -1,7 +1,7 @@
----------------------------------------------------------------------------------------------
-Installation has successfully completed!
----------------------------------------------------------------------------------------------
-MyITCRM is now installed in documentoroot: %%WWWDIR%%.
+----------------------------------------------------------------------------
+Post installation instructions:
+----------------------------------------------------------------------------
+MyITCRM is now installed in documentroot: %%WWWDIR%%.
1) Create user, MySQL database and set privileges:
@@ -17,12 +17,16 @@ Now you can try http://your-server/myitcrm/install and setup your database.
Full Path: %%WWWDIR%%
Site Name: http://your-server/myitcrm
-3) Finally remove installation folder:
+3) Finally move the installation folder or you will not be able to login:
-rm -rf %%WWWDIR%%/install
+mkdir -p $HOME/backup/myitcrm
+mv %%WWWDIR%%/install $HOME/backup/myitcrm
-NOTE: These may not be necessary but should be used as a guide only.
+If you need to reinstall MyITCRM, move the directory back and go back to
+step 2.
+
+Recommended php.ini settings:
- memory_limit=32M
- register_globals=off
- safe_mode=off
----------------------------------------------------------------------------------------------
+============================================================================
diff --git a/deskutils/myitcrm/pkg-plist b/deskutils/myitcrm/pkg-plist
index 5d55f3b384ae..5ce1ba84908c 100644
--- a/deskutils/myitcrm/pkg-plist
+++ b/deskutils/myitcrm/pkg-plist
@@ -1,8 +1,7 @@
-%%WWWDIR%%/LICENSE.txt
+@unexec if cmp -s %D/%%WWWDIR%%/conf.php %D/%%WWWDIR%%/conf-default.php; then rm -f %D/%%WWWDIR%%/conf.php; fi
%%WWWDIR%%/backup/.htaccess
%%WWWDIR%%/backup/bigdump.php
%%WWWDIR%%/cache/index.php
-%%WWWDIR%%/changelog.txt
%%WWWDIR%%/conf-default.php
%%WWWDIR%%/cron/.htaccess
%%WWWDIR%%/cron/backup.php
@@ -48,10 +47,11 @@
%%WWWDIR%%/images/icons/16x16/small_edit.gif
%%WWWDIR%%/images/icons/16x16/small_edit_employees.gif
%%WWWDIR%%/images/icons/16x16/small_new_customer.gif
+%%WWWDIR%%/images/icons/16x16/small_new_invoice_only.gif
%%WWWDIR%%/images/icons/16x16/small_new_work_order.gif
%%WWWDIR%%/images/icons/16x16/stop.gif
%%WWWDIR%%/images/icons/16x16/up.gif
-%%WWWDIR%%/images/icons/16x16/view+.gif
+%%WWWDIR%%/images/icons/16x16/view.gif
%%WWWDIR%%/images/icons/16x16/viewmag.gif
%%WWWDIR%%/images/icons/3floppy_mount.png
%%WWWDIR%%/images/icons/bookmark.png
@@ -133,6 +133,7 @@
%%WWWDIR%%/images/paymate/paymate_cc.gif
%%WWWDIR%%/images/paypal/Thumbs.db
%%WWWDIR%%/images/paypal/cc_paypal.gif
+%%WWWDIR%%/images/paypal/donate.gif
%%WWWDIR%%/images/paypal/pay_now.gif
%%WWWDIR%%/images/paypal/pay_now.png
%%WWWDIR%%/images/rate_upload.PNG
@@ -350,6 +351,18 @@
%%WWWDIR%%/include/SMARTY/plugins/shared.make_timestamp.php
%%WWWDIR%%/include/acl.php
%%WWWDIR%%/include/auth.php
+%%WWWDIR%%/include/dhtmlxcombo/dhtmlxcombo.css
+%%WWWDIR%%/include/dhtmlxcombo/dhtmlxcombo.js
+%%WWWDIR%%/include/dhtmlxcombo/dhtmlxcommon.js
+%%WWWDIR%%/include/dhtmlxcombo/ext/dhtmlxcombo_extra.js
+%%WWWDIR%%/include/dhtmlxcombo/ext/dhtmlxcombo_group.js
+%%WWWDIR%%/include/dhtmlxcombo/ext/dhtmlxcombo_whp.js
+%%WWWDIR%%/include/dhtmlxcombo/imgs/bg_selection.gif
+%%WWWDIR%%/include/dhtmlxcombo/imgs/blank.gif
+%%WWWDIR%%/include/dhtmlxcombo/imgs/combo_select.gif
+%%WWWDIR%%/include/dhtmlxcombo/imgs/combo_select_dhx_black.gif
+%%WWWDIR%%/include/dhtmlxcombo/imgs/combo_select_dhx_blue.gif
+%%WWWDIR%%/include/dhtmlxcombo/imgs/combo_select_dhx_skyblue.gif
%%WWWDIR%%/include/fpdf/font/courier.php
%%WWWDIR%%/include/fpdf/font/desktop.ini
%%WWWDIR%%/include/fpdf/font/helvetica.php
@@ -444,7 +457,6 @@
%%WWWDIR%%/include/jscalendar/lang/calendar-zh.js
%%WWWDIR%%/include/jscalendar/lang/cn_utf8.js
%%WWWDIR%%/include/jscalendar/menuarrow.gif
-%%WWWDIR%%/include/phpinfo.php
%%WWWDIR%%/include/session.php
%%WWWDIR%%/include/swift/lib/classes/Swift.php
%%WWWDIR%%/include/swift/lib/classes/Swift/Attachment.php
@@ -587,7 +599,6 @@
%%WWWDIR%%/include/swift/lib/swift_init.php
%%WWWDIR%%/include/swift/lib/swift_required.php
%%WWWDIR%%/include/swift/lib/swift_required_pear.php
-%%WWWDIR%%/include/tinymce/changelog.txt
%%WWWDIR%%/include/tinymce/jscripts/tiny_mce/langs/en.js
%%WWWDIR%%/include/tinymce/jscripts/tiny_mce/license.txt
%%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/advhr/css/advhr.css
@@ -846,38 +857,9 @@
%%WWWDIR%%/js/sdmenu.js
%%WWWDIR%%/js/submit.js
%%WWWDIR%%/js/tabs.js
-%%WWWDIR%%/language/asset/english.xml
-%%WWWDIR%%/language/billing/english.xml
-%%WWWDIR%%/language/billing/english_US.xml
-%%WWWDIR%%/language/control/english.xml
-%%WWWDIR%%/language/control/english_US.xml
-%%WWWDIR%%/language/core/english.xml
-%%WWWDIR%%/language/core/english_US.xml
-%%WWWDIR%%/language/core/french.xml
-%%WWWDIR%%/language/core/german.xml
-%%WWWDIR%%/language/customer/english.xml
-%%WWWDIR%%/language/customer/english_US.xml
-%%WWWDIR%%/language/customer/french.xml
-%%WWWDIR%%/language/customer/german.xml
-%%WWWDIR%%/language/customer/spanish.xml
-%%WWWDIR%%/language/employees/english.xml
-%%WWWDIR%%/language/employees/english_US.xml
%%WWWDIR%%/language/english.xml
%%WWWDIR%%/language/english_US.xml
-%%WWWDIR%%/language/error/english.xml
-%%WWWDIR%%/language/error/english_US.xml
%%WWWDIR%%/language/index.php
-%%WWWDIR%%/language/invoice/english.xml
-%%WWWDIR%%/language/invoice/english_US.xml
-%%WWWDIR%%/language/parts/english.xml
-%%WWWDIR%%/language/parts/english_US.xml
-%%WWWDIR%%/language/portuguese.xml
-%%WWWDIR%%/language/schedule/english.xml
-%%WWWDIR%%/language/schedule/english_US.xml
-%%WWWDIR%%/language/stats/english.xml
-%%WWWDIR%%/language/stats/english_US.xml
-%%WWWDIR%%/language/workorder/english.xml
-%%WWWDIR%%/language/workorder/english_US.xml
%%WWWDIR%%/log/access.log
%%WWWDIR%%/log/index.php
%%WWWDIR%%/login.php
@@ -936,7 +918,6 @@
%%WWWDIR%%/modules/core/include/display_work_orders.php
%%WWWDIR%%/modules/core/main.php
%%WWWDIR%%/modules/core/navagation.php
-%%WWWDIR%%/modules/core/tool_bar.php
%%WWWDIR%%/modules/core/translate.php
%%WWWDIR%%/modules/customer/customer_details.php
%%WWWDIR%%/modules/customer/delete.php
@@ -962,11 +943,11 @@
%%WWWDIR%%/modules/expense/new.php
%%WWWDIR%%/modules/expense/search.php
%%WWWDIR%%/modules/index.php
+%%WWWDIR%%/modules/invoice/delete.php
%%WWWDIR%%/modules/invoice/include.php
%%WWWDIR%%/modules/invoice/index.php
%%WWWDIR%%/modules/invoice/main.php
%%WWWDIR%%/modules/invoice/new.php
-%%WWWDIR%%/modules/invoice/pdf.php
%%WWWDIR%%/modules/invoice/print.php
%%WWWDIR%%/modules/invoice/view.php
%%WWWDIR%%/modules/invoice/view_paid.php
@@ -996,6 +977,7 @@
%%WWWDIR%%/modules/schedule/view.php
%%WWWDIR%%/modules/stats/hit_stats.php
%%WWWDIR%%/modules/stats/hit_stats_view.php
+%%WWWDIR%%/modules/stats/include.php
%%WWWDIR%%/modules/stats/index.php
%%WWWDIR%%/modules/stats/main.php
%%WWWDIR%%/modules/supplier/delete.php
@@ -1019,8 +1001,6 @@
%%WWWDIR%%/modules/workorder/print.php
%%WWWDIR%%/modules/workorder/view.php
%%WWWDIR%%/modules/workorder/view_closed.php
-%%WWWDIR%%/password.php
-%%WWWDIR%%/submit.php
%%WWWDIR%%/templates/asset/index.php
%%WWWDIR%%/templates/asset/view.tpl
%%WWWDIR%%/templates/billing/display_gift.tpl
@@ -1053,13 +1033,11 @@
%%WWWDIR%%/templates/core/password.tpl
%%WWWDIR%%/templates/core/submit.tpl
%%WWWDIR%%/templates/customer/customer_details.tpl
-%%WWWDIR%%/templates/customer/directions.tpl
-%%WWWDIR%%/templates/customer/edit.js
%%WWWDIR%%/templates/customer/edit.tpl
%%WWWDIR%%/templates/customer/email.tpl
%%WWWDIR%%/templates/customer/index.php
+%%WWWDIR%%/templates/customer/javascripts.js
%%WWWDIR%%/templates/customer/memo.tpl
-%%WWWDIR%%/templates/customer/new.js
%%WWWDIR%%/templates/customer/new.tpl
%%WWWDIR%%/templates/customer/search.tpl
%%WWWDIR%%/templates/employees/delete.tpl
@@ -1078,10 +1056,15 @@
%%WWWDIR%%/templates/expense/new.tpl
%%WWWDIR%%/templates/expense/search.tpl
%%WWWDIR%%/templates/index.php
+%%WWWDIR%%/templates/invoice/address-only-print_html.tpl
+%%WWWDIR%%/templates/invoice/delete.php
%%WWWDIR%%/templates/invoice/index.php
+%%WWWDIR%%/templates/invoice/javascripts.js
%%WWWDIR%%/templates/invoice/main.tpl
%%WWWDIR%%/templates/invoice/new.tpl
-%%WWWDIR%%/templates/invoice/print.tpl
+%%WWWDIR%%/templates/invoice/print_html.tpl
+%%WWWDIR%%/templates/invoice/print_html.tpl.orig
+%%WWWDIR%%/templates/invoice/print_pdf_tpl.php
%%WWWDIR%%/templates/invoice/view.tpl
%%WWWDIR%%/templates/invoice/view_paid.tpl
%%WWWDIR%%/templates/invoice/view_unpaid.tpl
@@ -1154,6 +1137,10 @@
%%WWWDIR%%/upgrade/0281_0290/sql.php
%%WWWDIR%%/upgrade/0290_0291/index.php
%%WWWDIR%%/upgrade/0290_0291/sql.php
+%%WWWDIR%%/upgrade/0291_0292/index.php
+%%WWWDIR%%/upgrade/0291_0292/sql.php
+%%WWWDIR%%/upgrade/0292_0293/index.php
+%%WWWDIR%%/upgrade/0292_0293/sql.php
%%WWWDIR%%/upgrade/index.html
%%WWWDIR%%/upgrade/inv.php
%%WWWDIR%%/upgrade/validate.js
@@ -1161,8 +1148,9 @@
%%WWWDIR%%/upload/index.php
%%WWWDIR%%/upload/rate_upload.csv
%%WWWDIR%%/version.php
-%%WWWDIR%%/conf.php
@dirrm %%WWWDIR%%/upload
+@dirrm %%WWWDIR%%/upgrade/0292_0293
+@dirrm %%WWWDIR%%/upgrade/0291_0292
@dirrm %%WWWDIR%%/upgrade/0290_0291
@dirrm %%WWWDIR%%/upgrade/0281_0290
@dirrm %%WWWDIR%%/upgrade
@@ -1199,19 +1187,7 @@
@dirrm %%WWWDIR%%/modules/billing
@dirrm %%WWWDIR%%/modules/asset
@dirrm %%WWWDIR%%/modules
-@dirrm %%WWWDIR%%/log
-@dirrm %%WWWDIR%%/language/workorder
-@dirrm %%WWWDIR%%/language/stats
-@dirrm %%WWWDIR%%/language/schedule
-@dirrm %%WWWDIR%%/language/parts
-@dirrm %%WWWDIR%%/language/invoice
-@dirrm %%WWWDIR%%/language/error
-@dirrm %%WWWDIR%%/language/employees
-@dirrm %%WWWDIR%%/language/customer
-@dirrm %%WWWDIR%%/language/core
-@dirrm %%WWWDIR%%/language/control
-@dirrm %%WWWDIR%%/language/billing
-@dirrm %%WWWDIR%%/language/asset
+@dirrmtry %%WWWDIR%%/log
@dirrm %%WWWDIR%%/language
@dirrm %%WWWDIR%%/js
@dirrm %%WWWDIR%%/install
@@ -1301,7 +1277,6 @@
@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/contextmenu
@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/bbcode
@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/autosave/langs
-@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/autosave/images
@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/autosave
@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/autoresize
@dirrm %%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/advlist
@@ -1354,6 +1329,9 @@
@dirrm %%WWWDIR%%/include/fpdf/font/makefont
@dirrm %%WWWDIR%%/include/fpdf/font
@dirrm %%WWWDIR%%/include/fpdf
+@dirrm %%WWWDIR%%/include/dhtmlxcombo/imgs
+@dirrm %%WWWDIR%%/include/dhtmlxcombo/ext
+@dirrm %%WWWDIR%%/include/dhtmlxcombo
@dirrm %%WWWDIR%%/include/SMARTY/plugins
@dirrm %%WWWDIR%%/include/SMARTY/internals
@dirrm %%WWWDIR%%/include/SMARTY
@@ -1379,7 +1357,6 @@
@dirrm %%WWWDIR%%/fonts
@dirrm %%WWWDIR%%/css
@dirrm %%WWWDIR%%/cron
-@dirrm %%WWWDIR%%/cache
+@dirrmtry %%WWWDIR%%/cache
@dirrm %%WWWDIR%%/backup
-@dirrmtry %%WWWDIR%%/
-@exec mkdir -p %D/%%WWWDIR%%/include/tinymce/jscripts/tiny_mce/plugins/autosave/images
+@exec if [ ! -f %D/%%WWWDIR%%/conf.php ]; then cp -p %D/%%WWWDIR%%/conf-default.php %D/%%WWWDIR%%/conf.php; fi