aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/nag
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-26 11:54:09 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-26 11:54:09 +0800
commit34e89ab8392566d3214ac1b9ecc2dd006abed7b9 (patch)
treed2b01dd75b75edffecca9a30a9fb09a047d33386 /deskutils/nag
parentd34b2b1ee3faf8c842017e914405d2828b3c49d7 (diff)
downloadfreebsd-ports-gnome-34e89ab8392566d3214ac1b9ecc2dd006abed7b9.tar.gz
freebsd-ports-gnome-34e89ab8392566d3214ac1b9ecc2dd006abed7b9.tar.zst
freebsd-ports-gnome-34e89ab8392566d3214ac1b9ecc2dd006abed7b9.zip
${PERL} -> ${REINPLACE_CMD}
PR: 39856 Submitted by: maintainer
Diffstat (limited to 'deskutils/nag')
-rw-r--r--deskutils/nag/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/deskutils/nag/Makefile b/deskutils/nag/Makefile
index 2f997563f112..cbbd623abdff 100644
--- a/deskutils/nag/Makefile
+++ b/deskutils/nag/Makefile
@@ -16,8 +16,11 @@ MAINTAINER= thierry@pompo.net
RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeNag
+
PLIST_SUB= HORDEDIR=${LHORDEDIR} NAGDIR=${LNAGDIR}
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -48,11 +51,10 @@ do-install:
@${CHOWN} -R www:www ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.nag ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
${HORDE_INC}/httpd.conf.nag
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeNag
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
+ @${RM} ${HORDE_INC}/httpd.conf.nag.beforeNag
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterNag
.if !defined(NOPORTDOCS)