aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/nautilus-actions/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-12-07 00:32:34 +0800
committerkwm <kwm@FreeBSD.org>2013-12-07 00:32:34 +0800
commitf34b1c2619cf8d1eac927b00a5ce9f67a8d2038f (patch)
treedc6ea8859743eaeb7c28e98d8c9040049102a02e /deskutils/nautilus-actions/Makefile
parent8d1030ac51739bcf309a83f76e1fd281c93d0c9a (diff)
downloadfreebsd-ports-gnome-f34b1c2619cf8d1eac927b00a5ce9f67a8d2038f.tar.gz
freebsd-ports-gnome-f34b1c2619cf8d1eac927b00a5ce9f67a8d2038f.tar.zst
freebsd-ports-gnome-f34b1c2619cf8d1eac927b00a5ce9f67a8d2038f.zip
Unbreak build.
Stageify, use new LIB_DEPEND syntax. switch from options framework for docs
Diffstat (limited to 'deskutils/nautilus-actions/Makefile')
-rw-r--r--deskutils/nautilus-actions/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/deskutils/nautilus-actions/Makefile b/deskutils/nautilus-actions/Makefile
index a60b79f28660..b4cc0e2a597a 100644
--- a/deskutils/nautilus-actions/Makefile
+++ b/deskutils/nautilus-actions/Makefile
@@ -11,9 +11,9 @@ MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Extension for Nautilus to configure programs to launch on files
-LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+LIB_DEPENDS= libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
INSTALLS_ICONS= yes
USE_BZIP2= yes
@@ -28,9 +28,11 @@ PORTDOCS= AUTHORS COPYING ChangeLog ChangeLog-2008 ChangeLog-2009 INSTALL \
MAINTAINERS NEWS README TODO export-format-id io-provider-id \
objects-hierarchy.odg
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
post-patch:
-.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|-Werror"|"|g' ${WRKSRC}/configure
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's| install-dist_pkgdocDATA||g' \
${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
.else
@@ -38,10 +40,12 @@ post-patch:
${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "powerpc"
BROKEN= Does not compile on powerpc
.endif
-.include <bsd.port.post.mk>
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/nautilus/extensions-2.0/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/nautilus-actions/*.so
+
+.include <bsd.port.mk>