aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/phpicalendar/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-02-11 09:22:19 +0800
committeredwin <edwin@FreeBSD.org>2006-02-11 09:22:19 +0800
commitabb72fa09bd36f1071ef039bd686f08cee1bba7c (patch)
tree98b32072908e1a6e2cc8728b9e110df722bf7e21 /deskutils/phpicalendar/Makefile
parent71777abf3390f3fb55034f8912d77dbd8b07fcc8 (diff)
downloadfreebsd-ports-gnome-abb72fa09bd36f1071ef039bd686f08cee1bba7c.tar.gz
freebsd-ports-gnome-abb72fa09bd36f1071ef039bd686f08cee1bba7c.tar.zst
freebsd-ports-gnome-abb72fa09bd36f1071ef039bd686f08cee1bba7c.zip
[PATCH] deskutils/phpicalendar: Show all files that are installed
[SECURITY UPDATE]: deskutils/phpicalendar PR: ports/92553,ports/93131 Submitted by: Renato Botelho <garga@freebsd.org>,Wesley Shields <wxs@csh.rit.edu> Security: http://phpicalendar.net/forums/viewtopic.php?t=396
Diffstat (limited to 'deskutils/phpicalendar/Makefile')
-rw-r--r--deskutils/phpicalendar/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/deskutils/phpicalendar/Makefile b/deskutils/phpicalendar/Makefile
index 065db7df1825..9548e16bea8e 100644
--- a/deskutils/phpicalendar/Makefile
+++ b/deskutils/phpicalendar/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= phpicalendar
-PORTVERSION= 2.1
+PORTVERSION= 2.21
CATEGORIES= deskutils www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,23 +19,28 @@ NO_BUILD= yes
PHPICALENDAR= www/phpicalendar
WWWDIR= ${PREFIX}/${PHPICALENDAR}
PLIST_SUB+= PHPICALENDAR=${PHPICALENDAR}
+USE_PHP= yes
+NO_WORKSUBDIR= yes
+SUB_FILES= pkg-message
+SUB_LIST= WWWDIR=${WWWDIR}
+PKGMESSAGE= ${WRKDIR}/pkg-message
do-install:
.if !exists(${WWWDIR})
${MKDIR} ${WWWDIR}
.endif
.for dir in admin calendars functions images includes languages rss templates
- @${CP} -R ${WRKSRC}/${dir} ${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/${dir}
+ @${CP} -Rv ${WRKDIR}/${dir} ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/${dir}
.endfor
.for f in index.php TIMEZONES error.php day.php preferences.php print.php search.php week.php month.php year.php README COPYING AUTHORS
- @${CP} ${WRKSRC}/${f} ${WWWDIR}
- @${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${f}
+ @${CP} -v ${WRKDIR}/${f} ${WWWDIR}
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${f}
.endfor
- @${CP} ${WRKSRC}/config.inc.php ${WWWDIR}/config.inc.php-default
- @${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/config.inc.php-default
+ @${CP} -v ${WRKDIR}/config.inc.php ${WWWDIR}/config.inc.php-default
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/config.inc.php-default
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>