aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/phpicalendar/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-05-26 05:58:32 +0800
committeredwin <edwin@FreeBSD.org>2006-05-26 05:58:32 +0800
commitf353e881871e6d623240d6b96fe9b424501713ac (patch)
treec5717dc807e999918f966045b38a4f22ea063563 /deskutils/phpicalendar/Makefile
parent8da8e7c4becb30a01b32fc19da840b47a1e9b497 (diff)
downloadfreebsd-ports-gnome-f353e881871e6d623240d6b96fe9b424501713ac.tar.gz
freebsd-ports-gnome-f353e881871e6d623240d6b96fe9b424501713ac.tar.zst
freebsd-ports-gnome-f353e881871e6d623240d6b96fe9b424501713ac.zip
update to 2.22
Noticed by: portscout (when will we get email notifications?)
Diffstat (limited to 'deskutils/phpicalendar/Makefile')
-rw-r--r--deskutils/phpicalendar/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/deskutils/phpicalendar/Makefile b/deskutils/phpicalendar/Makefile
index 9548e16bea8e..cc5fd65be5fc 100644
--- a/deskutils/phpicalendar/Makefile
+++ b/deskutils/phpicalendar/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= phpicalendar
-PORTVERSION= 2.21
+PORTVERSION= 2.22
CATEGORIES= deskutils www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,24 +20,28 @@ PHPICALENDAR= www/phpicalendar
WWWDIR= ${PREFIX}/${PHPICALENDAR}
PLIST_SUB+= PHPICALENDAR=${PHPICALENDAR}
USE_PHP= yes
-NO_WORKSUBDIR= yes
SUB_FILES= pkg-message
SUB_LIST= WWWDIR=${WWWDIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}/
+
+post-extract:
+ ${RM} -r ${WRKSRC}/templates/default/images/CVS
+ ${FIND} ${WRKDIR} -name .DS_Store -delete
do-install:
.if !exists(${WWWDIR})
${MKDIR} ${WWWDIR}
.endif
.for dir in admin calendars functions images includes languages rss templates
- @${CP} -Rv ${WRKDIR}/${dir} ${WWWDIR}
+ @${CP} -Rv ${WRKSRC}/${dir} ${WWWDIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/${dir}
.endfor
.for f in index.php TIMEZONES error.php day.php preferences.php print.php search.php week.php month.php year.php README COPYING AUTHORS
- @${CP} -v ${WRKDIR}/${f} ${WWWDIR}
+ @${CP} -v ${WRKSRC}/${f} ${WWWDIR}
${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${f}
.endfor
- @${CP} -v ${WRKDIR}/config.inc.php ${WWWDIR}/config.inc.php-default
+ @${CP} -v ${WRKSRC}/config.inc.php ${WWWDIR}/config.inc.php-default
${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/config.inc.php-default
post-install: