aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/phpicalendar
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-12 03:08:46 +0800
committerantoine <antoine@FreeBSD.org>2014-09-12 03:08:46 +0800
commit30056fc4bc9c407417cca0410c7889296ab76ae5 (patch)
tree81377d221c468f3bb68ea477fe74ea19f014c861 /deskutils/phpicalendar
parent8637a728fe0bb68e6ef58f688a7933340be97dff (diff)
downloadfreebsd-ports-gnome-30056fc4bc9c407417cca0410c7889296ab76ae5.tar.gz
freebsd-ports-gnome-30056fc4bc9c407417cca0410c7889296ab76ae5.tar.zst
freebsd-ports-gnome-30056fc4bc9c407417cca0410c7889296ab76ae5.zip
- Allow staging as a regular user
- Bump portrevision as files were not packaged with intended ownership
Diffstat (limited to 'deskutils/phpicalendar')
-rw-r--r--deskutils/phpicalendar/Makefile6
-rw-r--r--deskutils/phpicalendar/pkg-plist4
2 files changed, 6 insertions, 4 deletions
diff --git a/deskutils/phpicalendar/Makefile b/deskutils/phpicalendar/Makefile
index 893c005d1f26..852c0d957276 100644
--- a/deskutils/phpicalendar/Makefile
+++ b/deskutils/phpicalendar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phpicalendar
PORTVERSION= 2.24
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils www
MASTER_SITES= SF/${PORTNAME}/OldFiles
@@ -13,6 +13,7 @@ COMMENT= Webbased calendar with iCal support
USES= tar:tgz
NO_BUILD= yes
USE_PHP= session pcre
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
@@ -24,13 +25,10 @@ do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
.for dir in admin calendars functions images includes languages rss templates
@${CP} -Rv ${WRKSRC}/${dir} ${STAGEDIR}${WWWDIR}
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/${dir}
.endfor
.for f in index.php TIMEZONES error.php day.php preferences.php print.php search.php week.php month.php year.php README COPYING AUTHORS
@${CP} -v ${WRKSRC}/${f} ${STAGEDIR}${WWWDIR}
- ${CHOWN} ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/${f}
.endfor
@${CP} -v ${WRKSRC}/config.inc-dist.php ${STAGEDIR}${WWWDIR}/config.inc.php.sample
- ${CHOWN} ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/config.inc.php.sample
.include <bsd.port.mk>
diff --git a/deskutils/phpicalendar/pkg-plist b/deskutils/phpicalendar/pkg-plist
index cca0b86be90c..ed48576f0882 100644
--- a/deskutils/phpicalendar/pkg-plist
+++ b/deskutils/phpicalendar/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/AUTHORS
%%WWWDIR%%/COPYING
%%WWWDIR%%/README
@@ -393,3 +395,5 @@
@dirrm %%WWWDIR%%/calendars
@dirrm %%WWWDIR%%/admin
@dirrmtry %%WWWDIR%%
+@owner root
+@group wheel