aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/pinot
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 05:54:14 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 05:54:14 +0800
commit0e01bb75ed151d66335bab983694650ff66c1379 (patch)
treeab5ce506e32784d5c0f435c1e3d56915f38eba14 /deskutils/pinot
parenta4b79350eebbf824db93c259b72cb7883a1a395a (diff)
downloadfreebsd-ports-gnome-0e01bb75ed151d66335bab983694650ff66c1379.tar.gz
freebsd-ports-gnome-0e01bb75ed151d66335bab983694650ff66c1379.tar.zst
freebsd-ports-gnome-0e01bb75ed151d66335bab983694650ff66c1379.zip
Nuke NOPORTDOCS. Convert a couple WITH_foo's to OPTIONS.
Diffstat (limited to 'deskutils/pinot')
-rw-r--r--deskutils/pinot/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 5ff01389370d..056534cb368a 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -54,18 +54,13 @@ USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters
SHEBANG_LANG= bash
SHEBANG_FILES= scripts/bash/*.sh
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug=yes
-.endif
-
-.if defined(WITH_CHMLIB)
-CONFIGURE_ARGS+= --enable-chmlib=yes
-LIB_DEPENDS+= libchm.so:${PORTSDIR}/misc/chmlib
-PLIST_SUB+= CHMLIB=""
-.else
-CONFIGURE_ARGS+= --disable-chmlib
-PLIST_SUB+= CHMLIB="@comment "
-.endif
+OPTIONS_DEFINE= DEBUG CHMLIB DOCS
+OPTIONS_SUB= yes
+
+DEBUG_CONFIGURE_ENABLE= debug-yes
+
+CHMLIB_CONFIGURE_ENABLE= chmlib=yes
+CHMLIB_LIB_DEPENDS= libchm.so:${PORTSDIR}/misc/chmlib
INSTALLS_ICONS= yes
@@ -99,9 +94,7 @@ pre-configure:
post-install:
${TOUCH} ${STAGEDIR}${DATADIR}/stopwords/.empty_file
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>