aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/pinot
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-03 17:58:34 +0800
committerbapt <bapt@FreeBSD.org>2017-04-03 17:58:34 +0800
commite98e45f9ace3b642ea12949c4f434812c89f9335 (patch)
tree719a8dd0473ff60692babc42688eec3bb4fe2e7c /deskutils/pinot
parent37a7f1333f86f40b0a554419b031b892d5c7e5ad (diff)
downloadfreebsd-ports-gnome-e98e45f9ace3b642ea12949c4f434812c89f9335.tar.gz
freebsd-ports-gnome-e98e45f9ace3b642ea12949c4f434812c89f9335.tar.zst
freebsd-ports-gnome-e98e45f9ace3b642ea12949c4f434812c89f9335.zip
Fix build with -std=c++11
Diffstat (limited to 'deskutils/pinot')
-rw-r--r--deskutils/pinot/Makefile7
-rw-r--r--deskutils/pinot/files/patch-Tokenize_filters_GMimeMboxFilter.cc11
2 files changed, 14 insertions, 4 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index f00680c287c5..6d668c2e38ad 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -11,8 +11,6 @@ COMMENT= Personal search and metasearch for the Free Desktop
LICENSE= GPLv2
-BROKEN= depends on C++11 libs while not itself being C++11 compatible
-
BUILD_DEPENDS= desktop-file-install:devel/desktop-file-utils \
update-mime-database:misc/shared-mime-info
LIB_DEPENDS= libxapian.so:databases/xapian-core \
@@ -48,8 +46,9 @@ CONFIGURE_ENV= MKDIR_P="${MKDIR}" TEXTCAT_LIBS="-lexttextcat-2.0"
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lboost_system
-USES= autoreconf execinfo gettext libarchive libtool pkgconfig python \
- shebangfix sqlite:3 ssl
+USES= compiler:c++11-lang autoreconf execinfo gettext libarchive \
+ libtool pkgconfig python shebangfix sqlite:3 ssl
+USE_CXXSTD= c++11
USE_XORG= pixman
USE_GNOME= atkmm cairo cairomm glibmm gtk20 gtkmm24 libsigc++20 libxml2 pangomm
USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters
diff --git a/deskutils/pinot/files/patch-Tokenize_filters_GMimeMboxFilter.cc b/deskutils/pinot/files/patch-Tokenize_filters_GMimeMboxFilter.cc
new file mode 100644
index 000000000000..87e3f2039448
--- /dev/null
+++ b/deskutils/pinot/files/patch-Tokenize_filters_GMimeMboxFilter.cc
@@ -0,0 +1,11 @@
+--- Tokenize/filters/GMimeMboxFilter.cc.orig 2017-04-03 09:38:48 UTC
++++ Tokenize/filters/GMimeMboxFilter.cc
+@@ -301,7 +301,7 @@ bool GMimeMboxFilter::skip_to_document(const string &i
+ }
+
+ // ipath's format is "o=offset&l=part_levels"
+- if (sscanf(ipath.c_str(), "o="GMIME_OFFSET_MODIFIER"&l=[", &m_messageStart) != 1)
++ if (sscanf(ipath.c_str(), "o=" GMIME_OFFSET_MODIFIER "&l=[", &m_messageStart) != 1)
+ {
+ return false;
+ }