aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/pinot
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2013-12-01 23:36:26 +0800
committerthierry <thierry@FreeBSD.org>2013-12-01 23:36:26 +0800
commit22a983cec33c56cd1fa5b6ae13d34a4307d6b34a (patch)
tree0d8ba7eab179d1de9a4a7ebc188744f0b167ab95 /deskutils/pinot
parent31d7a0f3af9f3ab4bdc1de075bf2f64711aabc64 (diff)
downloadfreebsd-ports-gnome-22a983cec33c56cd1fa5b6ae13d34a4307d6b34a.tar.gz
freebsd-ports-gnome-22a983cec33c56cd1fa5b6ae13d34a4307d6b34a.tar.zst
freebsd-ports-gnome-22a983cec33c56cd1fa5b6ae13d34a4307d6b34a.zip
- Fix on -CURRENT
- Fix shebang - Stagify
Diffstat (limited to 'deskutils/pinot')
-rw-r--r--deskutils/pinot/Makefile58
-rw-r--r--deskutils/pinot/files/patch-Utils_TimeConverter.h10
-rw-r--r--deskutils/pinot/files/pkg-message.in13
-rw-r--r--deskutils/pinot/pkg-plist20
4 files changed, 45 insertions, 56 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index c7ea7a168056..f572aeffc07f 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinot
PORTVERSION= 1.06
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
#MASTER_SITES= http://colinf.chez.com/pinot/
@@ -15,18 +15,18 @@ COMMENT= Personal search and metasearch for the Free Desktop
LICENSE= GPLv2
BUILD_DEPENDS= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
-LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core \
- gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- exttextcat-2.0:${PORTSDIR}/textproc/libexttextcat \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- xml\\+\\+-2.6:${PORTSDIR}/textproc/libxml++26 \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- execinfo.1:${PORTSDIR}/devel/libexecinfo \
- exif.12:${PORTSDIR}/graphics/libexif \
- exiv2.12:${PORTSDIR}/graphics/exiv2 \
- gmime-2.4:${PORTSDIR}/mail/gmime24 \
- tag.1:${PORTSDIR}/audio/taglib \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core \
+ libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ libexttextcat-2.0.so:${PORTSDIR}/textproc/libexttextcat \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libxml\+\+-2.6.so:${PORTSDIR}/textproc/libxml++26 \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libexif.so:${PORTSDIR}/graphics/libexif \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libgmime-2.4.so:${PORTSDIR}/mail/gmime24 \
+ libtag.so:${PORTSDIR}/audio/taglib \
+ libcurl.so:${PORTSDIR}/ftp/curl
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info \
antiword:${PORTSDIR}/textproc/antiword \
xdg-open:${PORTSDIR}/devel/xdg-utils \
@@ -45,13 +45,14 @@ CONFIGURE_ARGS= --with-http=curl --with-ssl=${OPENSSLBASE} --enable-libarchive \
CONFIGURE_ENV= MKDIR_P="${MKDIR}"
CPPFLAGS+= -I${LOCALBASE}/include
-USE_DOS2UNIX= textcat32_conf.txt
USE_XORG= pixman
-USES= gettext pkgconfig
+USES= gettext pkgconfig shebangfix
USE_SQLITE= 3
USE_PYTHON= yes
USE_OPENSSL= yes
USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters
+SHEBANG_LANG= bash
+SHEBANG_FILES= scripts/bash/*.sh
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug=yes
@@ -59,7 +60,7 @@ CONFIGURE_ARGS+= --enable-debug=yes
.if defined(WITH_CHMLIB)
CONFIGURE_ARGS+= --enable-chmlib=yes
-LIB_DEPENDS+= chm:${PORTSDIR}/misc/chmlib
+LIB_DEPENDS+= libchm.so:${PORTSDIR}/misc/chmlib
PLIST_SUB+= CHMLIB=""
.else
CONFIGURE_ARGS+= --disable-chmlib
@@ -68,22 +69,12 @@ PLIST_SUB+= CHMLIB="@comment "
INSTALLS_ICONS= yes
-MAN1= pinot-dbus-daemon.1 pinot-index.1 pinot-label.1 pinot-search.1 pinot.1
-
-PORTDOCS= AUTHORS ChangeLog ChangeLog-dijon INSTALL NEWS README TODO
+DOCS= AUTHORS ChangeLog ChangeLog-dijon INSTALL NEWS README TODO
LM2FIX= textcat_conf.txt textcat3_conf.txt textcat31_conf.txt textcat32_conf.txt
SHR2FIX= Core/pinot-search.1 README
UL2FIX= Utils/xdgmime/xdgmime.c
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700041
-SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-.endif
-
post-extract:
# remove pre-generated messages catalogs
${FIND} ${WRKSRC}/po -name "*.gmo" -delete
@@ -107,15 +98,10 @@ pre-configure:
${WRKSRC}/*.desktop
post-install:
- ${TOUCH} ${DATADIR}/stopwords/.empty_file
+ ${TOUCH} ${STAGEDIR}${DATADIR}/stopwords/.empty_file
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-.if ${OSVERSION} < 700041
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/pinot/files/patch-Utils_TimeConverter.h b/deskutils/pinot/files/patch-Utils_TimeConverter.h
new file mode 100644
index 000000000000..a61af8b858c6
--- /dev/null
+++ b/deskutils/pinot/files/patch-Utils_TimeConverter.h
@@ -0,0 +1,10 @@
+--- Utils/TimeConverter.h.orig 2013-04-24 14:28:21.000000000 +0200
++++ Utils/TimeConverter.h 2013-12-01 15:39:50.000000000 +0100
+@@ -19,6 +19,7 @@
+ #ifndef _TIME_CONVERTER_H
+ #define _TIME_CONVERTER_H
+
++#include <time.h>
+ #include <string>
+
+ #include "Visibility.h"
diff --git a/deskutils/pinot/files/pkg-message.in b/deskutils/pinot/files/pkg-message.in
deleted file mode 100644
index 6baf21a23a51..000000000000
--- a/deskutils/pinot/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-=-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-=-=-
-Threading issues may cause the daemon to crash unexpectedly.
-A fix is to add the following lines to /etc/libmap.conf (which may not exist):
-
-[%%PREFIX%%/bin/pinot]
-libpthread.so.2 libc_r.so.6
-libpthread.so libc_r.so
-[%%PREFIX%%/bin/pinot-dbus-daemon]
-libpthread.so.2 libc_r.so.6
-libpthread.so libc_r.so
-
-Refer to the libmap.conf(5) man page for details.
-=-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-=-=-
diff --git a/deskutils/pinot/pkg-plist b/deskutils/pinot/pkg-plist
index 24704ec613f4..f78e46297b96 100644
--- a/deskutils/pinot/pkg-plist
+++ b/deskutils/pinot/pkg-plist
@@ -70,19 +70,12 @@ include/pinot/filters/HtmlFilter.h
include/pinot/filters/HtmlParser.h
include/pinot/filters/TextFilter.h
include/pinot/filters/XmlFilter.h
-include/pinot/xdgmime/xdgmime.c
include/pinot/xdgmime/xdgmime.h
-include/pinot/xdgmime/xdgmimealias.c
include/pinot/xdgmime/xdgmimealias.h
-include/pinot/xdgmime/xdgmimecache.c
include/pinot/xdgmime/xdgmimecache.h
-include/pinot/xdgmime/xdgmimeglob.c
include/pinot/xdgmime/xdgmimeglob.h
-include/pinot/xdgmime/xdgmimeint.c
include/pinot/xdgmime/xdgmimeint.h
-include/pinot/xdgmime/xdgmimemagic.c
include/pinot/xdgmime/xdgmimemagic.h
-include/pinot/xdgmime/xdgmimeparent.c
include/pinot/xdgmime/xdgmimeparent.h
lib/pinot/backends/libxapianbackend.so
lib/pinot/backends/libxapianbackend.so.1
@@ -112,9 +105,21 @@ lib/pinot/filters/libexiv2imagefilter.so
lib/pinot/filters/libexternalfilter.so
lib/pinot/filters/libmboxfilter.so
lib/pinot/filters/libtaglibfilter.so
+man/man1/pinot-dbus-daemon.1.gz
+man/man1/pinot-index.1.gz
+man/man1/pinot-label.1.gz
+man/man1/pinot-search.1.gz
+man/man1/pinot.1.gz
share/applications/pinot.desktop
share/applications/pinot-prefs.desktop
share/dbus-1/services/de.berlios.Pinot.service
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog-dijon
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
share/icons/hicolor/16x16/apps/pinot.png
share/icons/hicolor/22x22/apps/pinot.png
share/icons/hicolor/24x24/apps/pinot.png
@@ -159,6 +164,7 @@ share/locale/zh_TW/LC_MESSAGES/pinot.mo
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/pinot/filters
@dirrm lib/pinot/backends
@dirrm lib/pinot