aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/planner
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-02 04:32:55 +0800
committermarcus <marcus@FreeBSD.org>2003-04-02 04:32:55 +0800
commita1911bb09e715af3bcb060b641d67ec3b9ea201b (patch)
tree380c9017eefb2d6714818d3b11c3ff4d0106ba10 /deskutils/planner
parentbf580bfc7b741f3963ff718fbdfbc51c7160aaa2 (diff)
downloadfreebsd-ports-gnome-a1911bb09e715af3bcb060b641d67ec3b9ea201b.tar.gz
freebsd-ports-gnome-a1911bb09e715af3bcb060b641d67ec3b9ea201b.tar.zst
freebsd-ports-gnome-a1911bb09e715af3bcb060b641d67ec3b9ea201b.zip
Make sure to run ldconfig -m for each of the module directories at boot time.
This allows mrproject and its API to survive reboots. Reported by: olgeni Adapted from: databases/mysql323-client
Diffstat (limited to 'deskutils/planner')
-rw-r--r--deskutils/planner/Makefile5
-rw-r--r--deskutils/planner/files/mrproject.sh16
2 files changed, 21 insertions, 0 deletions
diff --git a/deskutils/planner/Makefile b/deskutils/planner/Makefile
index b54452970282..5f4f9af0abc0 100644
--- a/deskutils/planner/Makefile
+++ b/deskutils/planner/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mrproject
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ftp://ftp.codefactory.se/pub/software/mrproject/source/
@@ -30,4 +31,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+post-install:
+ @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/mrproject.sh > ${PREFIX}/etc/rc.d/000.mrproject.sh
+ @${CHMOD} 750 ${PREFIX}/etc/rc.d/000.mrproject.sh
+
.include <bsd.port.mk>
diff --git a/deskutils/planner/files/mrproject.sh b/deskutils/planner/files/mrproject.sh
new file mode 100644
index 000000000000..82e41f4d7b06
--- /dev/null
+++ b/deskutils/planner/files/mrproject.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ /sbin/ldconfig -m %%PREFIX%%/lib/mrproject
+ /sbin/ldconfig -m %%PREFIX%%/lib/mrproject/views
+ ;;
+ stop)
+ ;;
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 64
+ ;;
+esac