aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/recoll
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-26 02:01:08 +0800
committermakc <makc@FreeBSD.org>2013-11-26 02:01:08 +0800
commitd5a0b4e32561587ee79e625049d00dcda8e0ffe4 (patch)
tree678a6457d53f0a716f71f7ec2d3930f0adbe3a7f /deskutils/recoll
parente5d433bbd915367a15941a73c3079f8ad7a1b51f (diff)
downloadfreebsd-ports-gnome-d5a0b4e32561587ee79e625049d00dcda8e0ffe4.tar.gz
freebsd-ports-gnome-d5a0b4e32561587ee79e625049d00dcda8e0ffe4.tar.zst
freebsd-ports-gnome-d5a0b4e32561587ee79e625049d00dcda8e0ffe4.zip
- Pass QMAKE_ARGS to qmake
Approved by: portmgr (blanket approval)
Diffstat (limited to 'deskutils/recoll')
-rw-r--r--deskutils/recoll/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
index 73382d4a631a..9a6177bf7f42 100644
--- a/deskutils/recoll/Makefile
+++ b/deskutils/recoll/Makefile
@@ -46,8 +46,8 @@ PYDISTUTILS_EGGINFO= Recoll-1.0-py${PYTHON_VER}.egg-info
.endif
.if ${PORT_OPTIONS:MQT4}
-USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats \
- corelib gui xml webkit
+USE_QT4= moc_build qmake_build rcc_build uic_build iconengines_run \
+ imageformats_run corelib gui xml webkit
QT_NONSTANDARD= yes
CONFIGURE_ENV+= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}"
INSTALLS_ICONS= yes
@@ -71,8 +71,8 @@ post-patch:
post-configure:
.if ${PORT_OPTIONS:MQT4}
- @cd ${WRKSRC}/qtgui && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
+ @cd ${WRKSRC}/qtgui && ${SETENV} ${QMAKE_ENV} \
+ ${QMAKE} ${QMAKE_ARGS}
.endif
.include <bsd.port.mk>