aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/recoll
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-12-17 23:17:48 +0800
committerwxs <wxs@FreeBSD.org>2012-12-17 23:17:48 +0800
commitff1e785bdc08447a21ecceac26ffcfcaf2e705f4 (patch)
tree536a1f4eb57b40260d5e6607121322a4fd0d0a6e /deskutils/recoll
parent373261f2f4411307556055d96cfa0b050a4a2168 (diff)
downloadfreebsd-ports-gnome-ff1e785bdc08447a21ecceac26ffcfcaf2e705f4.tar.gz
freebsd-ports-gnome-ff1e785bdc08447a21ecceac26ffcfcaf2e705f4.tar.zst
freebsd-ports-gnome-ff1e785bdc08447a21ecceac26ffcfcaf2e705f4.zip
Fixup plist and USE_QT4 to be more accurate.
Submitted by: nemysis <nemysis@gmx.ch> (maintainer, private mail)
Diffstat (limited to 'deskutils/recoll')
-rw-r--r--deskutils/recoll/Makefile9
-rw-r--r--deskutils/recoll/pkg-plist6
2 files changed, 7 insertions, 8 deletions
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
index 51c921493054..e6c5bf45cc5b 100644
--- a/deskutils/recoll/Makefile
+++ b/deskutils/recoll/Makefile
@@ -25,7 +25,7 @@ MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= recollindex.1 recollq.1
+MAN1= recollindex.1
MAN5= recoll.conf.5
OPTIONS_DEFINE= QT4 ASPELL PYTHON X11MON
@@ -35,16 +35,17 @@ X11MON_DESC= X11 session monitoring support
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MQT4}
-USE_QT4= webkit moc_build qmake_build rcc_build uic_build
+USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats \
+ corelib gui xml webkit
QT_NONSTANDARD= yes
CONFIGURE_ENV+= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}"
+CONFIGURE_ARGS+=--enable-qtgui
INSTALLS_ICONS= yes
PLIST_SUB+= QT=""
-MAN1+= recoll.1
+MAN1+= recollq.1 recoll.1
.else
CONFIGURE_ARGS+=--disable-qtgui
PLIST_SUB+= QT="@comment "
-MAN1+= recollq.1
.endif
.if ${PORT_OPTIONS:MASPELL}
diff --git a/deskutils/recoll/pkg-plist b/deskutils/recoll/pkg-plist
index 4d29b85bd4ca..7e7c0e6b9286 100644
--- a/deskutils/recoll/pkg-plist
+++ b/deskutils/recoll/pkg-plist
@@ -1,7 +1,7 @@
%%QT%%bin/recoll
-bin/recollq
bin/recollindex
-%%PYTHON_SITELIBDIR%%/recoll.so
+%%QT%%bin/recollq
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/recoll.so
%%QT%%share/applications/recoll-searchgui.desktop
%%QT%%share/icons/hicolor/48x48/apps/recoll.png
%%QT%%share/pixmaps/recoll.png
@@ -111,5 +111,3 @@ bin/recollindex
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/applications
-@dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrmtry %%PYTHON_LIBDIR%%