aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/semantik
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
committerbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
commit11557d3b1ca381824ecc50f020623ed56d4ce36a (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /deskutils/semantik
parent1ed12c409b16770d2cb109c7a67bf65ef1a3f27b (diff)
downloadfreebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.gz
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.zst
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Diffstat (limited to 'deskutils/semantik')
-rw-r--r--deskutils/semantik/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index b16960d58861..55a538f14896 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -16,7 +16,8 @@ USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
USE_QT4= corelib gui linguist_build svg webkit xml \
moc_build qmake_build uic_build
-USES= pkgconfig python shebangfix tar:bzip2
+USES= pkgconfig python shebangfix tar:bzip2 waf
+QT_NONSTANDARD= yes
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS}" \
PATH="${KDE4_PREFIX}/bin:$$PATH" \
WAF_HOME="${WRKSRC}"
@@ -44,17 +45,7 @@ post-patch:
${WRKSRC}/wscript
.endif
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} waf configure --prefix=${PREFIX}
-
-do-build:
- @cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf build ${_MAKE_JOBS}
-
-do-install:
- @cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf install
+post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>