aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/taskwarrior
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2015-04-16 01:09:42 +0800
committerskreuzer <skreuzer@FreeBSD.org>2015-04-16 01:09:42 +0800
commit985fd10ab7c73fc6b7bd34be935e573ab5b818ac (patch)
treed267ccbffcc542b4de084d06ce71574489e32af2 /deskutils/taskwarrior
parentea9c7f49840b74306ae8ecceaf7041111f95b560 (diff)
downloadfreebsd-ports-gnome-985fd10ab7c73fc6b7bd34be935e573ab5b818ac.tar.gz
freebsd-ports-gnome-985fd10ab7c73fc6b7bd34be935e573ab5b818ac.tar.zst
freebsd-ports-gnome-985fd10ab7c73fc6b7bd34be935e573ab5b818ac.zip
Fix building on i386
PR: 199393 Submitted by: ppp15478@ribbon.or.jp
Diffstat (limited to 'deskutils/taskwarrior')
-rw-r--r--deskutils/taskwarrior/Makefile2
-rw-r--r--deskutils/taskwarrior/files/patch-src-Variant.h14
2 files changed, 14 insertions, 2 deletions
diff --git a/deskutils/taskwarrior/Makefile b/deskutils/taskwarrior/Makefile
index 9032d593509e..5a64402612d1 100644
--- a/deskutils/taskwarrior/Makefile
+++ b/deskutils/taskwarrior/Makefile
@@ -15,8 +15,6 @@ LICENSE= MIT
OPTIONS_DEFINE=GNUTLS
OPTIONS_DEFAULT=GNUTLS
-ONLY_FOR_ARCHS= amd64
-
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
GNUTLS_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_GnuTLS=TRUE
diff --git a/deskutils/taskwarrior/files/patch-src-Variant.h b/deskutils/taskwarrior/files/patch-src-Variant.h
new file mode 100644
index 000000000000..67e7fd987b01
--- /dev/null
+++ b/deskutils/taskwarrior/files/patch-src-Variant.h
@@ -0,0 +1,14 @@
+--- src/Variant.h 2015-03-16 08:02:55.000000000 +0900
++++ src/Variant.h 2015-04-12 08:39:14.000000000 +0900
+@@ -49,7 +49,11 @@
+ Variant (const double);
+ Variant (const std::string&);
+ Variant (const char*);
++#if defined(__FreeBSD__) && defined(__i386__)
++ Variant (const time_t, const enum type new_type);
++#else
+ Variant (const time_t, const enum type new_type = type_date);
++#endif
+ ~Variant ();
+
+ void source (const std::string&);