aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/treesheets/Makefile
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-07-10 01:35:30 +0800
committerultima <ultima@FreeBSD.org>2017-07-10 01:35:30 +0800
commit1c6ff99cfac439761b3c22a285f4b8e636e3c990 (patch)
treec84327984978b991a3137dc6cc1fb7b747fe7f23 /deskutils/treesheets/Makefile
parent4a54b0bcb79af77b62080b0ab4047726581de0d3 (diff)
downloadfreebsd-ports-gnome-1c6ff99cfac439761b3c22a285f4b8e636e3c990.tar.gz
freebsd-ports-gnome-1c6ff99cfac439761b3c22a285f4b8e636e3c990.tar.zst
freebsd-ports-gnome-1c6ff99cfac439761b3c22a285f4b8e636e3c990.zip
* Updated to 0.0.20170625
* Moved USES and USE_*(13.1.7) USES should start section then possible USE_*[1] [1] https://www.freebsd.org/doc/en/books/porters-handbook/porting-samplem.html#porting-samplem-order PR: 219647 Submitted by: lightside <lightside@gmx.com> (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11498
Diffstat (limited to 'deskutils/treesheets/Makefile')
-rw-r--r--deskutils/treesheets/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/deskutils/treesheets/Makefile b/deskutils/treesheets/Makefile
index 657937fd4769..ce5d93e1de4f 100644
--- a/deskutils/treesheets/Makefile
+++ b/deskutils/treesheets/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= treesheets
-PORTVERSION= 0.0.20161120
-PORTREVISION= 1
+PORTVERSION= 0.0.20170625
CATEGORIES= deskutils
MAINTAINER= lightside@gmx.com
@@ -12,23 +11,26 @@ COMMENT= Free form data organizer
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/ZLIB_LICENSE.txt
+USES= compiler:c++11-lib desktop-file-utils
+
USE_GITHUB= yes
GH_ACCOUNT= aardappel
-GH_TAGNAME= 7baabf3
+GH_TAGNAME= 8c8d5e0
+
+USE_WX= 3.0+
+INSTALLS_ICONS= yes
BUILD_WRKSRC= ${WRKSRC}/src
PACKAGE_VERSION= \"${PORTVERSION}\"
MAKE_ENV= PACKAGE_VERSION=${PACKAGE_VERSION:Q}
-USES= compiler:c++11-lib desktop-file-utils
-USE_WX= 3.0+
-
PORTDATA= images
PORTDOCS= docs *.html
PORTEXAMPLES= *
PLIST_FILES= bin/${PORTNAME} \
share/applications/treesheets.desktop \
+ share/icons/hicolor/scalable/apps/treesheets.svg \
share/pixmaps/treesheets.png
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -40,12 +42,17 @@ post-patch: .SILENT
${BUILD_WRKSRC}/myframe.h
${REINPLACE_CMD} -e 's|frame->GetPath(L"examples|(L"${EXAMPLESDIR}|' \
${BUILD_WRKSRC}/system.h
+ ${REINPLACE_CMD} -e 's|^\(Icon=\).*|\1${PORTNAME}|' \
+ ${WRKSRC}/TS/treesheets.desktop
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
(cd ${WRKSRC}/TS && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
${INSTALL_DATA} ${WRKSRC}/TS/treesheets.desktop \
${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${INSTALL_DATA} ${WRKSRC}/TS/images/treesheets.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
${INSTALL_DATA} ${WRKSRC}/TS/images/icon32.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png