aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/vym
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /deskutils/vym
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'deskutils/vym')
-rw-r--r--deskutils/vym/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/deskutils/vym/Makefile b/deskutils/vym/Makefile
index 84ac5b2a02cf..16e6e93e5e5f 100644
--- a/deskutils/vym/Makefile
+++ b/deskutils/vym/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/vym/Archive/${PORTVERSION}
MAINTAINER= lichray@gmail.com
COMMENT= VYM is a tool to generate and manipulate mind maps
-USES= qmake shebangfix tar:bzip2
+USES= qmake qt:4 shebangfix tar:bzip2
SHEBANG_FILES= scripts/makedist-vym scripts/vivym
-USE_QT4= uic_build moc_build qt3support_build \
+USE_QT= uic_build moc_build qt3support_build \
network xml dbus svg
QMAKE_ARGS= DATADIR=${DATADIR:C,/vym$,,} \
DOCDIR=${DOCSDIR}
@@ -28,7 +28,8 @@ DESKTOP_ENTRIES= "VYM" \
OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
-NLS_USE= QT4=linguist_build
+NLS_USES= qt:4
+NLS_USE= QT=linguist_build
.include <bsd.port.options.mk>