aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/x-tile/Makefile
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-08-31 19:43:08 +0800
committercrees <crees@FreeBSD.org>2011-08-31 19:43:08 +0800
commit8ae2264c7b67e1074ede68cbdc2cc3fd571e0b06 (patch)
tree27ec6e390b02555d6bce8d7e83cc6d6f6a99a71f /deskutils/x-tile/Makefile
parent4a05f930f7f9289ca94ce0226f13777872513daf (diff)
downloadfreebsd-ports-gnome-8ae2264c7b67e1074ede68cbdc2cc3fd571e0b06.tar.gz
freebsd-ports-gnome-8ae2264c7b67e1074ede68cbdc2cc3fd571e0b06.tar.zst
freebsd-ports-gnome-8ae2264c7b67e1074ede68cbdc2cc3fd571e0b06.zip
PR: ports/159605
Submitted by: Pedro Garcia Freitas <sawp@sawp.com.br> (maintainer), Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Diffstat (limited to 'deskutils/x-tile/Makefile')
-rw-r--r--deskutils/x-tile/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/deskutils/x-tile/Makefile b/deskutils/x-tile/Makefile
index 782a5d733585..a6f5d6355226 100644
--- a/deskutils/x-tile/Makefile
+++ b/deskutils/x-tile/Makefile
@@ -6,19 +6,34 @@
#
PORTNAME= x-tile
-PORTVERSION= 1.8.1
+PORTVERSION= 2.1
CATEGORIES= deskutils devel python
-MASTER_SITES= http://www.sawp.com.br/share/xtile/
+MASTER_SITES= http://www.giuspen.com/software/ \
+ http://www.sawp.com.br/share/xtile/
MAINTAINER= sawp@sawp.com.br
COMMENT= A GNOME applet to tile the opened windows
+LICENSE= GPLv2
+
USE_GNOME= pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-PYDISTUTILS_EGGINFO= X_Tile-${PYDISTUTILS_PKGVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
+PYDISTUTILS_PKGNAME= X_Tile
post-patch:
- @${REINPLACE_CMD} -i "" -e 's|: docfiles|: []|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/x-tile ${WRKSRC}/linux/x-tile.desktop \
+ ${WRKSRC}/modules/cons.py
+
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PYDISTUTILS_BUILD_TARGET= --without-gettext build
+PYDISTUTILS_INSTALL_TARGET= --without-gettext install
+PLIST_SUB+= NLS="@comment "
+.endif
.include <bsd.port.mk>