aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-01-10 01:39:28 +0800
committerkoobs <koobs@FreeBSD.org>2016-01-10 01:39:28 +0800
commitb46ed2bb4a2cd0c4e36d74d619563d0421824a35 (patch)
tree05badc9ea116997cf56b873b2a7c8ff65f342d9b /deskutils
parent35f6f95c98ad01fe66880e15d122118e834fc982 (diff)
downloadfreebsd-ports-gnome-b46ed2bb4a2cd0c4e36d74d619563d0421824a35.tar.gz
freebsd-ports-gnome-b46ed2bb4a2cd0c4e36d74d619563d0421824a35.tar.zst
freebsd-ports-gnome-b46ed2bb4a2cd0c4e36d74d619563d0421824a35.zip
deskutils/py-bugwarrior: Update to 1.3.0, Add OPTIONS
- Update PORTVERSION and distinfo checksum (1.3.0) - Add OPTIONS for Phabricator, Bugzilla, Trac and Jira - Remove unconditional dependencies accordingly - Switch to USES=python:-2.7 (:2 means depend on the python2 symlink) - Update test target, and remove a test that depends on pandoc. - Repatch setup.py to include a few missing tests_require that will be in the next version.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/py-bugwarrior/Makefile25
-rw-r--r--deskutils/py-bugwarrior/distinfo4
-rw-r--r--deskutils/py-bugwarrior/files/patch-setup.py17
3 files changed, 33 insertions, 13 deletions
diff --git a/deskutils/py-bugwarrior/Makefile b/deskutils/py-bugwarrior/Makefile
index 0ac01c279ec9..cd20e5fe763b 100644
--- a/deskutils/py-bugwarrior/Makefile
+++ b/deskutils/py-bugwarrior/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bugwarrior
-PORTVERSION= 1.1.4
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= deskutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,8 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twiggy>0:${PORTSDIR}/devel/py-twiggy \
${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}offtrac>0:${PORTSDIR}/devel/py-offtrac \
- ${PYTHON_PKGNAMEPREFIX}python-bugzilla>0:${PORTSDIR}/devel/py-python-bugzilla \
${PYTHON_PKGNAMEPREFIX}taskw>=0.8:${PORTSDIR}/deskutils/py-taskw \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
@@ -33,10 +30,26 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2 \
${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
-USES= python:2
+OPTIONS_DEFINE= BUGZILLA JIRA PHABRICATOR
+OPTIONS_DEFAULT= BUGZILLA PHABRICATOR
+
+BUGZILLA_DESC= Enable Bugzilla support
+BUGZILLA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-bugzilla>0:${PORTSDIR}/devel/py-python-bugzilla
+
+JIRA_DESC= Enabla Atlassian Jira support
+JIRA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jira>0:${PORTSDIR}/devel/py-jira
+
+PHABRICATOR_DESC= Enable Phabricator support
+PHABRICATOR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}phabricator>0:${PORTSDIR}/devel/py-phabricator
+
+TRAC_DESC= Enable Trac support
+TRAC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}offtrac>0:${PORTSDIR}/devel/py-offtrac
+
+USES= python:-2.7
USE_PYTHON= autoplist concurrent distutils
-regression-test: build
+do-test:
+ ${RM} ${WRKSRC}/tests/test_activecollab.py # Needs pandoc
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/deskutils/py-bugwarrior/distinfo b/deskutils/py-bugwarrior/distinfo
index 850876cc99b9..5ba4119aed92 100644
--- a/deskutils/py-bugwarrior/distinfo
+++ b/deskutils/py-bugwarrior/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bugwarrior-1.1.4.tar.gz) = 6bb687d702b1a91cdd13f067928bcf3018f615954132697fcc287f4182dd2acf
-SIZE (bugwarrior-1.1.4.tar.gz) = 81566
+SHA256 (bugwarrior-1.3.0.tar.gz) = d4d569be76e58965190208facede67b0c83d12ad2c59e8d23b70ea332fbbf19d
+SIZE (bugwarrior-1.3.0.tar.gz) = 85003
diff --git a/deskutils/py-bugwarrior/files/patch-setup.py b/deskutils/py-bugwarrior/files/patch-setup.py
index 3e8085265698..5100246e906c 100644
--- a/deskutils/py-bugwarrior/files/patch-setup.py
+++ b/deskutils/py-bugwarrior/files/patch-setup.py
@@ -1,10 +1,17 @@
---- setup.py.orig 2015-02-25 17:30:21 UTC
+--- setup.py.orig 2016-01-09 17:19:18 UTC
+++ setup.py
-@@ -52,6 +52,7 @@ setup(name='bugwarrior',
+@@ -46,11 +46,13 @@ setup(name='bugwarrior',
+ "pyxdg",
+ ],
+ tests_require=[
+- "Mock",
++ "mock",
+ "unittest2",
+ "nose",
"jira>=0.22",
"megaplan>=1.4",
++ "pypandoc",
++ "pyac",
],
-+ test_suite='nose.collector',
+ test_suite='nose.collector',
entry_points="""
- [console_scripts]
- bugwarrior-pull = bugwarrior:pull