aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-19 22:02:19 +0800
committermiwi <miwi@FreeBSD.org>2008-07-19 22:02:19 +0800
commit0b52e734413d97d24d9b5b42fd0af1a0533f5db8 (patch)
treedd13915a3e7707238a215d775718a241a76dab56 /deskutils
parent8a73faf6406bc83da53c5fc8e7994c62ba5c2d33 (diff)
downloadfreebsd-ports-gnome-0b52e734413d97d24d9b5b42fd0af1a0533f5db8.tar.gz
freebsd-ports-gnome-0b52e734413d97d24d9b5b42fd0af1a0533f5db8.tar.zst
freebsd-ports-gnome-0b52e734413d97d24d9b5b42fd0af1a0533f5db8.zip
This plugin is based on vformat.{c,h} which got adapted from evolution e-vcard
parser. vformat.{c,h} parsing and assembling of vObject-like formatting. The term vformat is often use to describe this format of vCard 2.1, vCard 3.0, vCalendar, iCalendar and vNote. WWW: http://www.opensync.org/ PR: ports/125663 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/libopensync-plugin-vformat-devel/Makefile31
-rw-r--r--deskutils/libopensync-plugin-vformat-devel/distinfo3
-rw-r--r--deskutils/libopensync-plugin-vformat-devel/pkg-descr6
-rw-r--r--deskutils/libopensync-plugin-vformat-devel/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index ca4c7c404ea6..a71de30a2f2f 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -129,6 +129,7 @@
SUBDIR += libopensync-plugin-evolution2
SUBDIR += libopensync-plugin-python
SUBDIR += libopensync-plugin-python-devel
+ SUBDIR += libopensync-plugin-vformat-devel
SUBDIR += lightning-xpi
SUBDIR += linux-sunbird
SUBDIR += ljcharm
diff --git a/deskutils/libopensync-plugin-vformat-devel/Makefile b/deskutils/libopensync-plugin-vformat-devel/Makefile
new file mode 100644
index 000000000000..59ab1ef0c0d9
--- /dev/null
+++ b/deskutils/libopensync-plugin-vformat-devel/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libopensync-plugin-vformat-devel
+# Date created: 16 June 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopensync-plugin-vformat
+PORTVERSION= 0.36
+CATEGORIES= deskutils
+MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Vformat plugin for the OpenSync framework
+
+LIB_DEPENDS= opensync.1:${PORTSDIR}/devel/libopensync
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
+CMAKE_ARGS+= -Wno-dev
+CFLAGS+= "-I${LOCALBASE}/include"
+
+pre-patch:
+ @${REINPLACE_CMD} -e "/FIND_PACKAGE( Check )/d" ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e "s|MESSAGE|# MESSAGE|" \
+ ${WRKSRC}/cmake/modules/MacroEnsureOutOfSourceBuild.cmake
+
+.include <bsd.port.mk>
diff --git a/deskutils/libopensync-plugin-vformat-devel/distinfo b/deskutils/libopensync-plugin-vformat-devel/distinfo
new file mode 100644
index 000000000000..2570a57998d8
--- /dev/null
+++ b/deskutils/libopensync-plugin-vformat-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (libopensync-plugin-vformat-0.36.tar.bz2) = f3d1efdc1e7142fc74364e92f2066ee0
+SHA256 (libopensync-plugin-vformat-0.36.tar.bz2) = 926e6125b4be2d206c6618f8e9445a465df44fe013f23ec339679af307b342c9
+SIZE (libopensync-plugin-vformat-0.36.tar.bz2) = 84642
diff --git a/deskutils/libopensync-plugin-vformat-devel/pkg-descr b/deskutils/libopensync-plugin-vformat-devel/pkg-descr
new file mode 100644
index 000000000000..8aa1c35b6bc5
--- /dev/null
+++ b/deskutils/libopensync-plugin-vformat-devel/pkg-descr
@@ -0,0 +1,6 @@
+This plugin is based on vformat.{c,h} which got adapted from evolution e-vcard
+parser. vformat.{c,h} parsing and assembling of vObject-like formatting. The
+term vformat is often use to describe this format of vCard 2.1, vCard 3.0,
+vCalendar, iCalendar and vNote.
+
+WWW: http://www.opensync.org/
diff --git a/deskutils/libopensync-plugin-vformat-devel/pkg-plist b/deskutils/libopensync-plugin-vformat-devel/pkg-plist
new file mode 100644
index 000000000000..a7c63d6e1e0b
--- /dev/null
+++ b/deskutils/libopensync-plugin-vformat-devel/pkg-plist
@@ -0,0 +1,8 @@
+bin/vconvert
+lib/opensync-1.0/formats/vformat-xmlformat.so
+lib/opensync-1.0/formats/vcard.so
+lib/opensync-1.0/formats/vevent.so
+lib/opensync-1.0/formats/vtodo.so
+lib/opensync-1.0/formats/vjournal.so
+lib/opensync-1.0/formats/vnote.so
+@dirrmtry lib/opensync-1.0/formats