aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2012-05-29 22:34:47 +0800
committerehaupt <ehaupt@FreeBSD.org>2012-05-29 22:34:47 +0800
commit2487227847bc0b25e5f70730eb63c7fcc921f7f0 (patch)
tree85b1df8c13f1995e518f5696b4decb7bf37a6846 /deskutils
parentc4c5a1d595533bae3b6c332d26c494e7a390c31b (diff)
downloadfreebsd-ports-gnome-2487227847bc0b25e5f70730eb63c7fcc921f7f0.tar.gz
freebsd-ports-gnome-2487227847bc0b25e5f70730eb63c7fcc921f7f0.tar.zst
freebsd-ports-gnome-2487227847bc0b25e5f70730eb63c7fcc921f7f0.zip
Provide a patch to chase a libnotify api change.
PR: 168355 (based on) Submitted by: Ben Grimm <freebsd@bengrimm.net>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xfce4-notification-daemon/Makefile2
-rw-r--r--deskutils/xfce4-notification-daemon/files/patch-src__settings__main.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/deskutils/xfce4-notification-daemon/Makefile b/deskutils/xfce4-notification-daemon/Makefile
index f336fbadbe36..52813bac3334 100644
--- a/deskutils/xfce4-notification-daemon/Makefile
+++ b/deskutils/xfce4-notification-daemon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= notification-daemon
PORTVERSION= 0.3.7
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= deskutils xfce
MASTER_SITES= CRITICAL/
PKGNAMEPREFIX= xfce4-
diff --git a/deskutils/xfce4-notification-daemon/files/patch-src__settings__main.c b/deskutils/xfce4-notification-daemon/files/patch-src__settings__main.c
new file mode 100644
index 000000000000..f41eba162033
--- /dev/null
+++ b/deskutils/xfce4-notification-daemon/files/patch-src__settings__main.c
@@ -0,0 +1,12 @@
+--- ./src/settings/main.c.orig 2012-05-29 15:07:41.000000000 +0200
++++ ./src/settings/main.c 2012-05-29 15:08:08.000000000 +0200
+@@ -187,8 +187,7 @@
+ /* create new preview notification */
+ preview = notify_notification_new (_("Preview notification"),
+ _("Lorem Ipsum is simply dummy text of the printing and typesetting industry."),
+- "notification-settings",
+- NULL);
++ "notification-settings");
+
+ notify_notification_set_urgency (preview, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_category(preview, "preview");