aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /deskutils
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/cairo-dock-plugins/Makefile4
-rw-r--r--deskutils/global-menu/Makefile3
-rw-r--r--deskutils/google-gadgets/Makefile4
-rw-r--r--deskutils/lightning-thunderbird/Makefile4
-rw-r--r--deskutils/notify-osd/Makefile3
-rw-r--r--deskutils/notify-osd/files/patch-tests_test-synchronous.c21
-rw-r--r--deskutils/notify-osd/files/patch-tests_test-withlib.c113
-rw-r--r--deskutils/osmo/Makefile2
-rw-r--r--deskutils/osmo/files/patch-src__check_events.c48
-rw-r--r--deskutils/rubrica/Makefile4
-rw-r--r--deskutils/rubrica/files/patch-src_app.c12
-rw-r--r--deskutils/steadyflow/Makefile3
-rw-r--r--deskutils/xfce4-notifyd/Makefile3
-rw-r--r--deskutils/xneur/Makefile3
14 files changed, 213 insertions, 14 deletions
diff --git a/deskutils/cairo-dock-plugins/Makefile b/deskutils/cairo-dock-plugins/Makefile
index 2a8269051062..6d2155659d4a 100644
--- a/deskutils/cairo-dock-plugins/Makefile
+++ b/deskutils/cairo-dock-plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cairo-dock-plugins
DISTVERSION= 2.3.0~3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= http://launchpadlibrarian.net/73753265/
@@ -71,7 +71,7 @@ PLIST_SUB+= TERMINAL="@comment "
.endif
.if defined(WITH_WEBLETS)
-LIB_DEPENDS+= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS+= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
CMAKE_ARGS+= -Denable_weblets:STRING=yes
PLIST_SUB+= WEBLETS=""
.else
diff --git a/deskutils/global-menu/Makefile b/deskutils/global-menu/Makefile
index 01e7d2545c44..b3fb780c96b2 100644
--- a/deskutils/global-menu/Makefile
+++ b/deskutils/global-menu/Makefile
@@ -7,13 +7,14 @@
PORTNAME= gnome-globalmenu
PORTVERSION= 0.7.10
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://gnome2-globalmenu.googlecode.com/files/
MAINTAINER= gustau.perez@gmail.com
COMMENT= Global menu for gnome
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
USE_GNOME= gnomepanel gnomedesktop
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index aca38cba12a9..3d806f8e1793 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -7,7 +7,7 @@
PORTNAME= google-gadgets
PORTVERSION= 0.11.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -58,7 +58,7 @@ QT_COMPONENTS= webkit opengl gui corelib script network moc_build
.if defined(WITH_GTKWEBKIT)
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
-LIB_DEPENDS+= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS+= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
.endif
.if defined(WITH_MOZILLA)
diff --git a/deskutils/lightning-thunderbird/Makefile b/deskutils/lightning-thunderbird/Makefile
index d6c275e41786..b791d2c038d3 100644
--- a/deskutils/lightning-thunderbird/Makefile
+++ b/deskutils/lightning-thunderbird/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lightning
DISTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= calendar/${PORTNAME}/releases/${DISTVERSION}b2/source
@@ -65,7 +65,7 @@ EXTRA_PATCHES= ${FILESDIR}/liboggplay_oss
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
post-patch:
diff --git a/deskutils/notify-osd/Makefile b/deskutils/notify-osd/Makefile
index 00a418882c3e..3d7957bd830b 100644
--- a/deskutils/notify-osd/Makefile
+++ b/deskutils/notify-osd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= notify-osd
PORTVERSION= 0.9.29
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://launchpadlibrarian.net/43419242/ \
CRITICAL
@@ -15,7 +16,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= On-screen-display notification agent using libnotify
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
GNU_CONFIGURE= yes
diff --git a/deskutils/notify-osd/files/patch-tests_test-synchronous.c b/deskutils/notify-osd/files/patch-tests_test-synchronous.c
new file mode 100644
index 000000000000..bf7bac0a995a
--- /dev/null
+++ b/deskutils/notify-osd/files/patch-tests_test-synchronous.c
@@ -0,0 +1,21 @@
+--- tests/test-synchronous.c.orig 2011-08-16 13:55:36.000000000 +0200
++++ tests/test-synchronous.c 2011-08-16 13:56:05.000000000 +0200
+@@ -38,7 +38,7 @@ send_normal (const gchar *message)
+ NotifyNotification *n;
+ n = notify_notification_new ("Test notification",
+ g_strdup (message),
+- "", NULL);
++ "");
+ notify_notification_show (n, NULL);
+ g_object_unref(G_OBJECT(n));
+ }
+@@ -53,8 +53,7 @@ send_synchronous (const char *type,
+ if (n == NULL)
+ n = notify_notification_new (" ",
+ "",
+- g_strdup (icon),
+- NULL);
++ g_strdup (icon));
+ else
+ notify_notification_update (n,
+ " ",
diff --git a/deskutils/notify-osd/files/patch-tests_test-withlib.c b/deskutils/notify-osd/files/patch-tests_test-withlib.c
new file mode 100644
index 000000000000..1b4230fddc60
--- /dev/null
+++ b/deskutils/notify-osd/files/patch-tests_test-withlib.c
@@ -0,0 +1,113 @@
+--- tests/test-withlib.c.orig 2011-08-16 13:52:38.000000000 +0200
++++ tests/test-withlib.c 2011-08-16 13:54:51.000000000 +0200
+@@ -94,7 +94,7 @@ test_withlib_show_notification (void)
+
+ n = notify_notification_new ("Test",
+ "You should see a normal notification",
+- "", NULL);
++ "");
+ notify_notification_show (n, NULL);
+ sleep (3);
+
+@@ -109,7 +109,7 @@ test_withlib_update_notification (void)
+
+ n = notify_notification_new ("Test",
+ "New notification",
+- "", NULL);
++ "");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+ sleep (1);
+@@ -135,7 +135,7 @@ test_withlib_pass_icon_data (void)
+
+ n = notify_notification_new ("Image Test",
+ "You should see an image",
+- "", NULL);
++ "");
+ g_print ("iconpath: %s\n", SRCDIR"/icons/avatar.png");
+ pixbuf = gdk_pixbuf_new_from_file_at_scale (SRCDIR"/icons/avatar.png",
+ 64, 64, TRUE, NULL);
+@@ -157,22 +157,22 @@ test_withlib_priority (void)
+
+ n1 = notify_notification_new ("Dummy Notification",
+ "This is a test notification",
+- "", NULL);
++ "");
+ notify_notification_show (n1, NULL);
+ n2 = notify_notification_new ("Normal Notification",
+ "You should see this *after* the urgent notification.",
+- "", NULL);
++ "");
+ notify_notification_set_urgency (n2, NOTIFY_URGENCY_LOW);
+ notify_notification_show (n2, NULL);
+ n3 = notify_notification_new ("Synchronous Notification",
+ "You should immediately see this notification.",
+- "", NULL);
++ "");
+ notify_notification_set_hint_string (n3, "synchronous", "test");
+ notify_notification_set_urgency (n3, NOTIFY_URGENCY_NORMAL);
+ notify_notification_show (n3, NULL);
+ n4 = notify_notification_new ("Urgent Notification",
+ "You should see a dialog box, and after, a normal notification.",
+- "", NULL);
++ "");
+ notify_notification_set_urgency (n4, NOTIFY_URGENCY_CRITICAL);
+ notify_notification_show (n4, NULL);
+
+@@ -207,7 +207,7 @@ test_withlib_actions (void)
+
+ n1 = notify_notification_new ("Notification with an action",
+ "You should see that in a dialog box. Click the 'Action' button for the test to succeed.",
+- "", NULL);
++ "");
+ notify_notification_add_action (n1,
+ "action",
+ "Action",
+@@ -231,7 +231,7 @@ test_withlib_close_notification (void)
+
+ n = notify_notification_new ("Test Title",
+ "This notification will be closed prematurely...",
+- "", NULL);
++ "");
+ notify_notification_show (n, NULL);
+
+ loop = g_main_loop_new(NULL, FALSE);
+@@ -256,8 +256,7 @@ test_withlib_append_hint (void)
+ /* init notification, supply first line of body-text */
+ n = notify_notification_new ("Test (append-hint)",
+ "The quick brown fox jumps over the lazy dog.",
+- SRCDIR"/icons/avatar.png",
+- NULL);
++ SRCDIR"/icons/avatar.png");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+ sleep (1);
+@@ -296,8 +295,7 @@ test_withlib_icon_only_hint (void)
+ /* init notification, supply first line of body-text */
+ n = notify_notification_new (" ", /* needs this to be non-NULL */
+ NULL,
+- "notification-audio-play",
+- NULL);
++ "notification-audio-play");
+ notify_notification_set_hint_string (n, "icon-only", "allowed");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+@@ -314,8 +312,7 @@ test_withlib_swallow_markup (void)
+
+ n = notify_notification_new ("Swallow markup test",
+ "This text is hopefully neither <b>bold</b>, <i>italic</i> nor <u>underlined</u>.\n\nA little math-notation:\n\n\ta &gt; b &lt; c = 0",
+- SRCDIR"/icons/avatar.png",
+- NULL);
++ SRCDIR"/icons/avatar.png");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+ sleep (2);
+@@ -341,7 +338,7 @@ test_withlib_throttle (void)
+
+ // create dummy notification
+ snprintf (buf, 19, "Test #%.2d", i);
+- n = notify_notification_new (buf, buf, "", NULL);
++ n = notify_notification_new (buf, buf, "");
+
+ // inject it into the queue
+ res = notify_notification_show (n, &error);
diff --git a/deskutils/osmo/Makefile b/deskutils/osmo/Makefile
index 7108fbef4019..06acdbc4b4c5 100644
--- a/deskutils/osmo/Makefile
+++ b/deskutils/osmo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= osmo
PORTVERSION= 0.2.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}/
diff --git a/deskutils/osmo/files/patch-src__check_events.c b/deskutils/osmo/files/patch-src__check_events.c
new file mode 100644
index 000000000000..24f53e87349d
--- /dev/null
+++ b/deskutils/osmo/files/patch-src__check_events.c
@@ -0,0 +1,48 @@
+--- src/check_events.c.orig 2011-08-12 15:17:59.000000000 +0200
++++ src/check_events.c 2011-08-12 15:20:36.000000000 +0200
+@@ -454,9 +454,9 @@
+ a->date = 0;
+
+ if (textdesc != NULL)
+- a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING, NULL);
++ a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING);
+ else
+- a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING, NULL);
++ a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING);
+
+ g_free (textdesc);
+ g_free (text);
+@@ -483,9 +483,7 @@
+ #endif /* HAVE_LIBNOTIFY */
+
+ if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
+-#ifdef HAVE_LIBNOTIFY
+- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
+-#endif /* HAVE_LIBNOTIFY */
++
+ gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
+
+ if (config.blink_on_events) {
+@@ -532,9 +530,9 @@
+ a->time = -1;
+ a->date = 0;
+ if (textdesc != NULL)
+- a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO, NULL);
++ a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO);
+ else
+- a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO, NULL);
++ a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO);
+
+ notify_notification_set_timeout (a->notify, NOTIFY_EXPIRES_NEVER);
+ notify_notification_set_urgency (a->notify, NOTIFY_URGENCY_NORMAL);
+@@ -545,9 +543,7 @@
+ #endif /* HAVE_LIBNOTIFY */
+
+ if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
+-#ifdef HAVE_LIBNOTIFY
+- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
+-#endif /* HAVE_LIBNOTIFY */
++
+ gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
+
+ if (config.blink_on_events) {
diff --git a/deskutils/rubrica/Makefile b/deskutils/rubrica/Makefile
index 7ba0b320e75e..7e08ef38d55a 100644
--- a/deskutils/rubrica/Makefile
+++ b/deskutils/rubrica/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rubrica
PORTVERSION= 2.0.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils gnome
MASTER_SITES= BERLIOS
DISTNAME= ${PORTNAME}2-${PORTVERSION}
@@ -18,7 +18,7 @@ COMMENT= An addressbook for the GNOME 2 desktop
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_BZIP2= yes
diff --git a/deskutils/rubrica/files/patch-src_app.c b/deskutils/rubrica/files/patch-src_app.c
new file mode 100644
index 000000000000..f40a1a0c509f
--- /dev/null
+++ b/deskutils/rubrica/files/patch-src_app.c
@@ -0,0 +1,12 @@
+--- src/app.c.orig 2011-08-12 15:55:03.000000000 +0200
++++ src/app.c 2011-08-12 15:55:26.000000000 +0200
+@@ -1269,8 +1269,7 @@ rubrica_app_init(RubricaApp* self)
+ self->priv->cutted = NULL;
+ self->priv->notify = notify_notification_new("Rubrica Addressbook",
+ NULL,
+- "info",
+- NULL);
++ "info");
+ self->priv->show_card = TRUE;
+
+ g_object_set(self->priv->notebook, "homogeneous", FALSE, NULL);
diff --git a/deskutils/steadyflow/Makefile b/deskutils/steadyflow/Makefile
index 649a835ff9f9..d9ea6511bf18 100644
--- a/deskutils/steadyflow/Makefile
+++ b/deskutils/steadyflow/Makefile
@@ -7,6 +7,7 @@
PORTNAME= steadyflow
PORTVERSION= 0.1.7
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/ \
https://launchpadlibrarian.net/72208624/
@@ -16,7 +17,7 @@ COMMENT= Simple download manager
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gee.2:${PORTSDIR}/devel/libgee \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index c89ab632eb09..4a02523125a2 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-notifyd
PORTVERSION= 0.2.2
+PORTREVISION= 1
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
@@ -18,7 +19,7 @@ COMMENT= Visually-appealing notification daemon for Xfce
LICENSE= GPLv3
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
diff --git a/deskutils/xneur/Makefile b/deskutils/xneur/Makefile
index 056e4a21e064..c25d8cf2459b 100644
--- a/deskutils/xneur/Makefile
+++ b/deskutils/xneur/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xneur
PORTVERSION= 0.13.0
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://dists.xneur.ru/release-${DISTVERSION}/tgz/ \
http://mirror.amdmi3.ru/distfiles/
@@ -14,7 +15,7 @@ MASTER_SITES= http://dists.xneur.ru/release-${DISTVERSION}/tgz/ \
MAINTAINER= admin@lissyara.su
COMMENT= Auto keyboard switcher
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes