aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /deskutils
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/deskbar-applet/Makefile8
-rw-r--r--deskutils/drivel/Makefile1
-rw-r--r--deskutils/ecru/Makefile1
-rw-r--r--deskutils/glabels/Makefile2
-rw-r--r--deskutils/gnome-utils/Makefile14
-rw-r--r--deskutils/gxneur/Makefile1
-rw-r--r--deskutils/pal/Makefile1
-rw-r--r--deskutils/parcellite/Makefile4
-rw-r--r--deskutils/planner/Makefile2
-rw-r--r--deskutils/steadyflow/Makefile4
-rw-r--r--deskutils/superswitcher/Makefile2
-rw-r--r--deskutils/xpad-current/Makefile4
12 files changed, 33 insertions, 11 deletions
diff --git a/deskutils/deskbar-applet/Makefile b/deskutils/deskbar-applet/Makefile
index f996320ddf26..fa8125a3bb94 100644
--- a/deskutils/deskbar-applet/Makefile
+++ b/deskutils/deskbar-applet/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: deskbar-applet
-# Date created: 2005-07-13
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/deskutils/deskbar-applet/Makefile,v 1.116 2010/09/27 19:36:13 kwm Exp $
-#
PORTNAME= deskbar-applet
PORTVERSION= 2.32.0
@@ -56,5 +52,7 @@ post-patch:
s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/deskbar/handlers/mozilla.py \
${WRKSRC}/deskbar/core/Utils.py
+ @${REINPLACE_CMD} -e 's|<glib/g.*\.h>|<glib.h>|g' \
+ ${WRKSRC}/deskbar/handlers/evolution/evolution.[ch]
.include <bsd.port.post.mk>
diff --git a/deskutils/drivel/Makefile b/deskutils/drivel/Makefile
index 993718b6a364..63cd29f4aad5 100644
--- a/deskutils/drivel/Makefile
+++ b/deskutils/drivel/Makefile
@@ -31,6 +31,7 @@ USE_AUTOTOOLS= libtool
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
MAKE_JOBS_SAFE= yes
+CONFIGURE_ARGS= --disable-error-on-warning
GCONF_SCHEMAS= drivel.schemas
diff --git a/deskutils/ecru/Makefile b/deskutils/ecru/Makefile
index 49f5fc87e5c4..956f7af831a0 100644
--- a/deskutils/ecru/Makefile
+++ b/deskutils/ecru/Makefile
@@ -22,6 +22,7 @@ USE_PYTHON_BUILD= yes
USE_BZIP2= yes
MANCOMPRESSED= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
MAN1= ecru-config.1 ecru-delete.1 ecru-edit.1 \
ecru-info.1 ecru-list.1 ecru-post.1
diff --git a/deskutils/glabels/Makefile b/deskutils/glabels/Makefile
index 05b45765eedb..1d0d6a0f238b 100644
--- a/deskutils/glabels/Makefile
+++ b/deskutils/glabels/Makefile
@@ -24,7 +24,7 @@ USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -DGLIB_COMPILATION
LDFLAGS+= -L${LOCALBASE}/lib
MAN1= glabels.1
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index dc7e82ab5dc6..bdca54a65620 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/deskutils/gnome-utils/Makefile,v 1.150 2010/09/28 08:41:46 kwm Exp $
+# $MCom: ports/deskutils/gnome-utils/Makefile,v 1.159 2012/09/01 23:02:09 mezz Exp $
#
PORTNAME= gnome-utils
PORTVERSION= 2.32.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
@@ -20,11 +20,14 @@ COMMENT= GNOME 2 support utilities
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop \
canberra-gtk.0:${PORTSDIR}/audio/libcanberra
+CONFLICTS= baobob-3.[0-9]* gnome-dictionary-3.[0-9]* \
+ gnome-font-viewer-3.[0-9]* gnome-screenshot-3.[0-9]* \
+ gnome-search-tool-3.[0-9]* gnome-system-log-3.[0-9]*
+
USE_BZIP2= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
-GNOME_DESKTOP_VERSION=2
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel ltverhack
@@ -42,5 +45,10 @@ GCONF_SCHEMAS= gnome-dictionary.schemas gnome-screenshot.schemas \
post-patch:
@${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
${WRKSRC}/gsearchtool/libgnomeui-deprecated/Makefile.in
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/gnome-dictionary/libgdict/Makefile.in \
+ ${WRKSRC}/gsearchtool/Makefile.in \
+ ${WRKSRC}/gsearchtool/libgnomeui-deprecated/Makefile.in \
+ ${WRKSRC}/libeggsmclient/Makefile.in
.include <bsd.port.mk>
diff --git a/deskutils/gxneur/Makefile b/deskutils/gxneur/Makefile
index 8ca9bb668cc4..c668c1210526 100644
--- a/deskutils/gxneur/Makefile
+++ b/deskutils/gxneur/Makefile
@@ -38,6 +38,7 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${REINPLACE_CMD} -e '/all_modifiers/d' ${WRKSRC}/src/misc.c
+ @${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/configure
post-install:
@-update-desktop-database
diff --git a/deskutils/pal/Makefile b/deskutils/pal/Makefile
index df6fcfbe986e..5c7525566983 100644
--- a/deskutils/pal/Makefile
+++ b/deskutils/pal/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= h.skuhra@gmail.com
COMMENT= A calendar application
USE_GNOME= glib20
+USE_PKGCONFIG= build
USE_GETTEXT= yes
USE_GMAKE= yes
ALL_TARGET=
diff --git a/deskutils/parcellite/Makefile b/deskutils/parcellite/Makefile
index c4963bd82adc..c9831f400920 100644
--- a/deskutils/parcellite/Makefile
+++ b/deskutils/parcellite/Makefile
@@ -26,4 +26,8 @@ PLIST_SUB+= NLS="@comment "
MAN1= parcellite.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g'\
+ ${WRKSRC}/src/keybinder.h
+
.include <bsd.port.mk>
diff --git a/deskutils/planner/Makefile b/deskutils/planner/Makefile
index e4d6b2145043..705ecd202172 100644
--- a/deskutils/planner/Makefile
+++ b/deskutils/planner/Makefile
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
--disable-python \
--disable-python-plugin
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -DGLIB_COMPILATION
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= planner.schemas
diff --git a/deskutils/steadyflow/Makefile b/deskutils/steadyflow/Makefile
index df629c291b0c..bdad3391900a 100644
--- a/deskutils/steadyflow/Makefile
+++ b/deskutils/steadyflow/Makefile
@@ -13,8 +13,10 @@ COMMENT= Simple download manager
LICENSE= GPLv3
+BROKEN= Doesn't build with vala 0.18
+
LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- gee:${PORTSDIR}/devel/libgee \
+ gee:${PORTSDIR}/devel/libgee06 \
notify:${PORTSDIR}/devel/libnotify \
unique-1:${PORTSDIR}/x11-toolkits/unique
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
diff --git a/deskutils/superswitcher/Makefile b/deskutils/superswitcher/Makefile
index d18e8d18c43f..3dc02e0fa021 100644
--- a/deskutils/superswitcher/Makefile
+++ b/deskutils/superswitcher/Makefile
@@ -34,5 +34,7 @@ post-patch:
's/x11//g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/_DISABLE_DEPRECATED/d' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/dbus-object.h ${WRKSRC}/src/forward_declarations.h
.include <bsd.port.mk>
diff --git a/deskutils/xpad-current/Makefile b/deskutils/xpad-current/Makefile
index f11b8c0042cc..5d6f2999773e 100644
--- a/deskutils/xpad-current/Makefile
+++ b/deskutils/xpad-current/Makefile
@@ -30,4 +30,8 @@ USE_GETTEXT= yes
MAN1= xpad.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/glist.h|glib.h|g' \
+ ${WRKSRC}/src/xpad-undo.c
+
.include <bsd.port.mk>