aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-09 02:16:15 +0800
committerpav <pav@FreeBSD.org>2006-01-09 02:16:15 +0800
commit8e480d628c9f5c8d7a9dc5bac54f2338fdd6066c (patch)
tree0082597fe118ed57234eb14531b127ba9f923fe6 /deskutils
parentd6f1defe9af6b1425f70ba45a828d589f039a555 (diff)
downloadfreebsd-ports-gnome-8e480d628c9f5c8d7a9dc5bac54f2338fdd6066c.tar.gz
freebsd-ports-gnome-8e480d628c9f5c8d7a9dc5bac54f2338fdd6066c.tar.zst
freebsd-ports-gnome-8e480d628c9f5c8d7a9dc5bac54f2338fdd6066c.zip
- Update to 0.14.0
PR: ports/91512 Submitted by: Tobias Roth <ports@fsck.ch> (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/treeline/Makefile44
-rw-r--r--deskutils/treeline/distinfo8
-rw-r--r--deskutils/treeline/pkg-plist18
3 files changed, 46 insertions, 24 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index 1fc300d71e4a..8710f0fc6b28 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= treeline
-PORTVERSION= 0.12.0
+PORTVERSION= 0.14.0
CATEGORIES= deskutils python
MASTER_SITES= http://www.bellz.org/treeline/ \
http://depot.fsck.ch/mirror/distfiles/
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@fsck.ch
COMMENT= TreeLine is a structured information storage program
@@ -17,6 +18,18 @@ COMMENT= TreeLine is a structured information storage program
BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS= ${BUILD_DEPENDS}
+OPTIONS= ASPELL "install with aspell support" off \
+ ISPELL "install with ispell support" off \
+ PYXML "use pythons py-xml instead of textproc/expat2" on \
+ HTTPLOAD "install httpLoad plugin" off
+
+WRKSRC= ${WRKDIR}/TreeLine
+USE_QT_VER= 3
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_ASPELL)
BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
.endif
@@ -25,30 +38,23 @@ BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.if defined(WITH_PYXML)
-BUILD_DEPENDS+= ${PYXML}
-.else
+.if defined(WITHOUT_PYXML)
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
.endif
-WRKSRC= ${WRKDIR}/TreeLine
-USE_QT_VER= 3
-USE_PYTHON= 2.3+
-NO_BUILD= yes
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
- @${ECHO_MSG} "WITH_ASPELL=yes install with aspell support"
- @${ECHO_MSG} " or"
- @${ECHO_MSG} "WITH_ISPELL=yes install with ispell support"
- @${ECHO_MSG} "WITH_PYXML=yes use textproc/py-xml instead of"
- @${ECHO_MSG} " textproc/expat2"
- @${ECHO_MSG} ""
+.if defined(WITH_HTTPLOAD)
+DISTFILES+= httpload.py
+PLIST_SUB+= HTTPLOAD=""
+.else
+PLIST_SUB+= HTTPLOAD="@comment "
+.endif
do-install:
@cd ${WRKSRC} && ${PYTHON_CMD} install.py \
-p ${PREFIX} -d ${DOCSDIR} -i ${DATADIR}/icons -x
+.if defined(WITH_HTTPLOAD)
+ @${INSTALL_DATA} ${DISTDIR}/httpload.py ${PREFIX}/lib/${PORTNAME}/plugins/
+.endif
post-install:
${RM} ${DOCSDIR}/INSTALL ${DOCSDIR}/LICENSE
@@ -57,4 +63,4 @@ post-install:
${RMDIR} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/treeline/distinfo b/deskutils/treeline/distinfo
index 38e162ce2d45..c5cf537237b4 100644
--- a/deskutils/treeline/distinfo
+++ b/deskutils/treeline/distinfo
@@ -1,2 +1,6 @@
-MD5 (treeline-0.12.0.tar.gz) = 0e9772ca310d59ff0d94967ac9baad87
-SIZE (treeline-0.12.0.tar.gz) = 234805
+MD5 (treeline-0.14.0.tar.gz) = d7aca37173f54e7abd92c5cc4e8a9630
+SHA256 (treeline-0.14.0.tar.gz) = 4f183e3299e40d76bfce9bd0dd2a0663e544b1b7bfce51e3936711453556ffb2
+SIZE (treeline-0.14.0.tar.gz) = 329562
+MD5 (httpload.py) = 9680667db5496366c9fc040edab44618
+SHA256 (httpload.py) = f3da52451a415d4f445ba9179f54ddf73175bdc583d892f70ed0db4b6e897922
+SIZE (httpload.py) = 1735
diff --git a/deskutils/treeline/pkg-plist b/deskutils/treeline/pkg-plist
index d51d4ce7e4a9..e916006c69c8 100644
--- a/deskutils/treeline/pkg-plist
+++ b/deskutils/treeline/pkg-plist
@@ -1,6 +1,8 @@
bin/treeline
lib/treeline/cmdline.py
lib/treeline/cmdline.pyc
+lib/treeline/conditional.py
+lib/treeline/conditional.pyc
lib/treeline/fieldformat.py
lib/treeline/fieldformat.pyc
lib/treeline/genboolean.py
@@ -17,6 +19,8 @@ lib/treeline/helpview.py
lib/treeline/helpview.pyc
lib/treeline/icondict.py
lib/treeline/icondict.pyc
+lib/treeline/immoduletr.py
+lib/treeline/immoduletr.pyc
lib/treeline/nodeformat.py
lib/treeline/nodeformat.pyc
lib/treeline/numbering.py
@@ -69,6 +73,7 @@ lib/treeline/treexmlparse.py
lib/treeline/treexmlparse.pyc
lib/treeline/undo.py
lib/treeline/undo.pyc
+%%HTTPLOAD%%lib/treeline/plugins/httpload.py
%%DATADIR%%/icons/anchor.png
%%DATADIR%%/icons/arrow_1.png
%%DATADIR%%/icons/arrow_2.png
@@ -126,9 +131,9 @@ lib/treeline/undo.pyc
%%DATADIR%%/icons/hand.png
%%DATADIR%%/icons/heart.png
%%DATADIR%%/icons/helpback.png
+%%DATADIR%%/icons/helpcontents.png
%%DATADIR%%/icons/helpforward.png
%%DATADIR%%/icons/helphome.png
-%%DATADIR%%/icons/helpreadme.png
%%DATADIR%%/icons/home.png
%%DATADIR%%/icons/lock_1.png
%%DATADIR%%/icons/lock_2.png
@@ -177,14 +182,21 @@ lib/treeline/undo.pyc
%%DATADIR%%/icons/x_1.png
%%DATADIR%%/icons/x_2.png
%%DATADIR%%/icons/x_3.png
+%%PORTDOCS%%%%DOCSDIR%%/condition_dlg.png
+%%PORTDOCS%%%%DOCSDIR%%/config_dlg.png
+%%PORTDOCS%%%%DOCSDIR%%/field_dlg.png
%%PORTDOCS%%%%DOCSDIR%%/README.html
%%PORTDOCS%%%%DOCSDIR%%/readme.trl
-%%PORTDOCS%%%%DOCSDIR%%/sample_basic.trl
+%%PORTDOCS%%%%DOCSDIR%%/sample_basic_booklist.trl
+%%PORTDOCS%%%%DOCSDIR%%/sample_basic_contacts.trl
+%%PORTDOCS%%%%DOCSDIR%%/sample_basic_longtext.trl
%%PORTDOCS%%%%DOCSDIR%%/sample_bookmarks.trl
%%PORTDOCS%%%%DOCSDIR%%/sample_char_format.trl
%%PORTDOCS%%%%DOCSDIR%%/sample_color_items.trl
+%%PORTDOCS%%%%DOCSDIR%%/sample_conditional_todo.trl
%%PORTDOCS%%%%DOCSDIR%%/sample_intern_links.trl
-%%PORTDOCS%%%%DOCSDIR%%/sample_table.trl
+%%PORTDOCS%%%%DOCSDIR%%/sample_other_fields.trl
+%%PORTDOCS%%%%DOCSDIR%%/sample_table_booklist.trl
@dirrm lib/treeline/plugins
@dirrm lib/treeline
@dirrm %%DATADIR%%/icons