aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-02 00:59:20 +0800
committerbapt <bapt@FreeBSD.org>2012-06-02 00:59:20 +0800
commitd11c41d1ad3012decf213f15c52bcac9c1b58ccb (patch)
treee28089e70f941c688810dcf42b54dd8b8bf6ed55 /deskutils
parenta3fd2744caf5940808c561315a2f854d6a243196 (diff)
downloadfreebsd-ports-gnome-d11c41d1ad3012decf213f15c52bcac9c1b58ccb.tar.gz
freebsd-ports-gnome-d11c41d1ad3012decf213f15c52bcac9c1b58ccb.tar.zst
freebsd-ports-gnome-d11c41d1ad3012decf213f15c52bcac9c1b58ccb.zip
Convert to new options framework
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/drivel/Makefile14
-rw-r--r--deskutils/griffith/Makefile17
-rw-r--r--deskutils/kdepim3/Makefile19
3 files changed, 27 insertions, 23 deletions
diff --git a/deskutils/drivel/Makefile b/deskutils/drivel/Makefile
index c3824db3d541..993718b6a364 100644
--- a/deskutils/drivel/Makefile
+++ b/deskutils/drivel/Makefile
@@ -16,7 +16,9 @@ COMMENT= Blog editor for GNOME
LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup
-OPTIONS= GTKSPELL "Enable GtkSpell support" On
+OPTIONS_DEFINE= GTKSPELL
+OPTIONS_DEFAULT= GTKSPELL
+GTKSPELL_DESC= Enable GtkSpell support
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
@@ -35,12 +37,12 @@ GCONF_SCHEMAS= drivel.schemas
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GTKSPELL)
-CONFIGURE_ARGS+= --without-gtkspell
-.else
+.if ${PORT_OPTIONS:MGTKSPELL}
LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+.else
+CONFIGURE_ARGS+= --without-gtkspell
.endif
post-patch:
@@ -48,4 +50,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|make -C|$$(MAKE) -C|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/-ldl/s|^|#|g' ${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index a9bac2e94b45..ebb02fcc8cba 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -21,10 +21,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3
${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging \
${PYXML}
-OPTIONS= LXML "Enable lxml support" off \
- REPORTLAB2 "Enable ReportLab2 support" off \
- CHARDET "Enable chardet support" off \
- PYGNOMEEXTRAS "Enable python-gnome-extras support" off
+OPTIONS_DEFINE= LXML REPORTLAB2 CHARDET PYGNOMEEXTRAS
+LXML_DESC= Enable lxml support
+REPORTLAB2_DESC= Enable ReportLab2 support
+CHARDET_DESC= Enable chardet support
+PYGNOMEEXTRAS_DESC= Enable python-gnome-extras support
USE_XZ= yes
USE_GNOME= pygtk2
@@ -38,21 +39,21 @@ MAN1= ${PORTNAME}.1
.include <bsd.port.options.mk>
-.if defined(WITH_LXML)
+.if ${PORT_OPTIONS:MLXML}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml
.endif
-.if defined(WITH_REPORTLAB2)
+.if ${PORT_OPTIONS:MREPORTLAB2}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab2>=2:${PORTSDIR}/print/py-reportlab2
.else
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab>=1.19:${PORTSDIR}/print/py-reportlab
.endif
-.if defined(WITH_CHARDET)
+.if ${PORT_OPTIONS:MCHARDET}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}chardet>=0:${PORTSDIR}/textproc/py-chardet
.endif
-.if defined(WITH_PYGNOMEEXTRAS)
+.if ${PORT_OPTIONS:MPYGNOMEEXTRAS}
USE_GNOME+= pygnomeextras
.endif
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 097f437842af..7dda5939af21 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -37,13 +37,14 @@ CONFIGURE_ARGS= --with-gpg=${LOCALBASE}/bin/gpg \
--with-gpgsm=${LOCALBASE}/bin/gpgsm \
--with-ssl-dir=${OPENSSLBASE}
-OPTIONS= GNOKII "KAdressbook import/export for Nokia phones" off \
- KITCHENSYNC "PIM synchronization utility" off
+OPTIONS_DEFINE= GNOKII KITCHENSYNC
+GNOKII_DESC= KAdressbook import/export for Nokia phones
+KITCHENSYNC_DESC= PIM synchronization utility
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_KITCHENSYNC)
+.if ${PORT_OPTIONS:MKITCHENSYNC}
LIB_DEPENDS+= opensync.0:${PORTSDIR}/devel/libopensync022
PLIST_SUB+= KITCHENSYNC=""
.else
@@ -52,15 +53,15 @@ DO_NOT_COMPILE+=kitchensync
.endif
.if exists(${LOCALBASE}/bin/gnokii)
-. if !defined(WITH_GNOKII)
+. if empty(PORT_OPTIONS:MGNOKII)
GNOKII_OVERRIDE=yes
-WITH_GNOKII= yes
+PORT_OPTIONS+= GNOKII
. endif
.endif
-.if defined(WITH_GNOKII)
+.if ${PORT_OPTIONS:MGNOKII)
LIB_DEPENDS+= gnokii:${PORTSDIR}/comms/gnokii
-.endif # defined ($(WITH_GNOKII))
+.endif
.if defined(DO_NOT_COMPILE)
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
@@ -76,4 +77,4 @@ pre-everything::
@${ECHO_MSG}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>