aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-10-11 23:28:12 +0800
committermiwi <miwi@FreeBSD.org>2008-10-11 23:28:12 +0800
commite3b9f7a3c4058c2388f5a41325677a46cb8a1b46 (patch)
treefbbaaf8d2bc2a6cbd6b63f26aaf60b343422c2ac /deskutils
parent8b382a81577ed2783d19454caabbedb085f72c35 (diff)
downloadfreebsd-ports-gnome-e3b9f7a3c4058c2388f5a41325677a46cb8a1b46.tar.gz
freebsd-ports-gnome-e3b9f7a3c4058c2388f5a41325677a46cb8a1b46.tar.zst
freebsd-ports-gnome-e3b9f7a3c4058c2388f5a41325677a46cb8a1b46.zip
This plugin allows applications using OpenSync to synchronise to and from
Mozilla Calendar / Sunbird. WWW: http://www.opensync.org/ PR: ports/127973 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/libopensync-plugin-sunbird/Makefile33
-rw-r--r--deskutils/libopensync-plugin-sunbird/distinfo3
-rw-r--r--deskutils/libopensync-plugin-sunbird/pkg-descr4
-rw-r--r--deskutils/libopensync-plugin-sunbird/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index ba315eaadb39..0ed2b2a6f11b 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -135,6 +135,7 @@
SUBDIR += libopensync-plugin-evolution2-devel
SUBDIR += libopensync-plugin-python
SUBDIR += libopensync-plugin-python-devel
+ SUBDIR += libopensync-plugin-sunbird
SUBDIR += libopensync-plugin-synce
SUBDIR += libopensync-plugin-synce-devel
SUBDIR += libopensync-plugin-vformat-devel
diff --git a/deskutils/libopensync-plugin-sunbird/Makefile b/deskutils/libopensync-plugin-sunbird/Makefile
new file mode 100644
index 000000000000..32618519a5e9
--- /dev/null
+++ b/deskutils/libopensync-plugin-sunbird/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libopensync-plugin-sunbird
+# Date created: 07 October 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopensync-plugin-sunbird
+PORTVERSION= 0.22
+CATEGORIES= deskutils
+MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Sunbird plugin for the OpenSync framework
+
+LIB_DEPENDS= opensync.0:${PORTSDIR}/devel/libopensync022 \
+ neon.28:${PORTSDIR}/www/neon28
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 libxml2
+
+PORTDOCS= AUTHORS COPYING ChangeLog README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} -p ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/libopensync-plugin-sunbird/distinfo b/deskutils/libopensync-plugin-sunbird/distinfo
new file mode 100644
index 000000000000..19f9e1c1d890
--- /dev/null
+++ b/deskutils/libopensync-plugin-sunbird/distinfo
@@ -0,0 +1,3 @@
+MD5 (libopensync-plugin-sunbird-0.22.tar.bz2) = c23d0cc6c128831c8a129d0b21aa4fe9
+SHA256 (libopensync-plugin-sunbird-0.22.tar.bz2) = 84beabde5440d4cd397f86f4092d9dd57d5a0a278623468a4a86004a1a920414
+SIZE (libopensync-plugin-sunbird-0.22.tar.bz2) = 252354
diff --git a/deskutils/libopensync-plugin-sunbird/pkg-descr b/deskutils/libopensync-plugin-sunbird/pkg-descr
new file mode 100644
index 000000000000..ba2ea2606b86
--- /dev/null
+++ b/deskutils/libopensync-plugin-sunbird/pkg-descr
@@ -0,0 +1,4 @@
+This plugin allows applications using OpenSync to synchronise to and from
+Mozilla Calendar / Sunbird.
+
+WWW: http://www.opensync.org/
diff --git a/deskutils/libopensync-plugin-sunbird/pkg-plist b/deskutils/libopensync-plugin-sunbird/pkg-plist
new file mode 100644
index 000000000000..2d6f5cea5e98
--- /dev/null
+++ b/deskutils/libopensync-plugin-sunbird/pkg-plist
@@ -0,0 +1,7 @@
+lib/opensync/plugins/sunbird_sync.so
+lib/opensync/plugins/sunbird_sync.la
+share/opensync/defaults/sunbird-sync
+@dirrmtry lib/opensync/plugins
+@dirrmtry lib/opensync
+@dirrmtry share/opensync/defaults
+@dirrmtry share/opensync