aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-06 13:40:13 +0800
committerrafan <rafan@FreeBSD.org>2006-08-06 13:40:13 +0800
commitf7749ef7564ac0cfb494fdd93a9a697c1fa1bee4 (patch)
tree0fa2eaae131da5f3e7535be4f4b0cb5da376d61c /deskutils
parentd05efdcf3e371adf7151b8df15dce6eef1218362 (diff)
downloadfreebsd-ports-gnome-f7749ef7564ac0cfb494fdd93a9a697c1fa1bee4.tar.gz
freebsd-ports-gnome-f7749ef7564ac0cfb494fdd93a9a697c1fa1bee4.tar.zst
freebsd-ports-gnome-f7749ef7564ac0cfb494fdd93a9a697c1fa1bee4.zip
- Add readline as dependency when it was already installed. The program
will be linked against it anyway, not against a system one. - Define USE_GETTEXT to make portlint happy - Define INSTALLS_ICONS to update icon cache PR: ports/101444 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/genius/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 39299faa252d..f266eac21319 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -19,6 +19,7 @@ COMMENT= Arbitrary precision calculator for Gnome Desktop Environment
LIB_DEPENDS= mpfr.1:${PORTSDIR}/math/mpfr
USE_X_PREFIX= yes
+USE_GETTEXT= yes
USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview intlhack \
libgnomeui vte
USE_GMAKE= yes
@@ -28,12 +29,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-extra-gcc-optimization
INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
.if ${OSVERSION} < 500018
BROKEN= Does not compile on 4.x
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
.include <bsd.port.post.mk>