aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-05-17 17:47:51 +0800
committerkwm <kwm@FreeBSD.org>2017-05-17 17:47:51 +0800
commit93ec89cd549a65ab1835438bc148d38edc227a2b (patch)
tree0c3d015cb4c79d675a8f16bcc7b621d816ffecfc /deskutils
parent68fe5457784e624d51bc848895d0d69b38d70c02 (diff)
downloadfreebsd-ports-gnome-93ec89cd549a65ab1835438bc148d38edc227a2b.tar.gz
freebsd-ports-gnome-93ec89cd549a65ab1835438bc148d38edc227a2b.tar.zst
freebsd-ports-gnome-93ec89cd549a65ab1835438bc148d38edc227a2b.zip
Unbreak by adding patch to fix the build with newer evolution-data-server.
While here list missing indirect dependancies. Obtained from: upstream
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/california/Makefile7
-rw-r--r--deskutils/california/files/patch-backing_eds_calendar-source.vala43
2 files changed, 47 insertions, 3 deletions
diff --git a/deskutils/california/Makefile b/deskutils/california/Makefile
index 62c282c78043..31516e47f6ef 100644
--- a/deskutils/california/Makefile
+++ b/deskutils/california/Makefile
@@ -10,20 +10,21 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Calendar client for GNOME 3
-IGNORE= Not compatible with evolution-data-server 3.16.0
-
BUILD_DEPENDS= itstool:textproc/itstool \
xdg-open:devel/xdg-utils
LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3 \
libsoup-2.4.so:devel/libsoup \
libgee-0.8.so:devel/libgee \
libgdata.so:devel/libgdata \
+ libical.so:devel/libical \
+ libsecret-1.so:security/libsecret \
+ libjson-glib-1.0.so:devel/json-glib \
libgoa-1.0.so:net/gnome-online-accounts
RUN_DEPENDS= xdg-open:devel/xdg-utils
USES= desktop-file-utils gettext gmake libtool pathfix \
pkgconfig tar:xz
-USE_GNOME= evolutiondataserver3 glib20 gnomedocutils gnomeprefix \
+USE_GNOME= cairo evolutiondataserver3 glib20 gnomedocutils gnomeprefix \
gtk30 intlhack introspection
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/deskutils/california/files/patch-backing_eds_calendar-source.vala b/deskutils/california/files/patch-backing_eds_calendar-source.vala
new file mode 100644
index 000000000000..1c4408d44545
--- /dev/null
+++ b/deskutils/california/files/patch-backing_eds_calendar-source.vala
@@ -0,0 +1,43 @@
+From 4b61966a93e7be65ed35e8a509e2b7538b136c3c Mon Sep 17 00:00:00 2001
+From: Adam Dingle <adam@medovina.org>
+Date: Thu, 24 Mar 2016 12:35:04 -0400
+Subject: Fix build with newer evolution-data-server: bug 743961
+
+Thanks to Milan Crha <mcrha@redhat.com> for this fix.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=743961
+---
+ configure.ac | 2 +-
+ src/backing/eds/backing-eds-calendar-source.vala | 2 +-
+ vapi/libecal-1.2.vapi | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/backing/eds/backing-eds-calendar-source.vala b/src/backing/eds/backing-eds-calendar-source.vala
+index 7e30e08..da88db4 100644
+--- src/backing/eds/backing-eds-calendar-source.vala
++++ src/backing/eds/backing-eds-calendar-source.vala
+@@ -256,7 +256,7 @@ internal class EdsCalendarSource : CalendarSource {
+
+ // Invoked by EdsStore prior to making it available outside of unit
+ internal async void open_async(Cancellable? cancellable) throws Error {
+- client = (E.CalClient) yield E.CalClient.connect(eds_source, E.CalClientSourceType.EVENTS,
++ client = (E.CalClient) yield E.CalClient.connect(eds_source, E.CalClientSourceType.EVENTS, 1,
+ cancellable);
+
+ client.bind_property("readonly", this, PROP_READONLY, BindingFlags.SYNC_CREATE);
+diff --git a/vapi/libecal-1.2.vapi b/vapi/libecal-1.2.vapi
+index 6ead3ec..46fd711 100644
+--- vapi/libecal-1.2.vapi
++++ vapi/libecal-1.2.vapi
+@@ -23,7 +23,7 @@ namespace E {
+ public bool check_save_schedules ();
+ public static bool check_timezones (iCal.icalcomponent comp, GLib.List comps, GLib.Callback tzlookup, void* ecalclient, GLib.Cancellable cancellable) throws GLib.Error;
+ [CCode (finish_name = "e_cal_client_connect_finish")]
+- public static async unowned E.Client connect (E.Source source, E.CalClientSourceType source_type, GLib.Cancellable cancellable) throws GLib.Error;
++ public static async unowned E.Client connect (E.Source source, E.CalClientSourceType source_type, uint32 wait_for_connected_seconds, GLib.Cancellable cancellable) throws GLib.Error;
+ public static unowned E.Client connect_sync (E.Source source, E.CalClientSourceType source_type, GLib.Cancellable cancellable) throws GLib.Error;
+ [CCode (finish_name = "e_cal_client_create_object_finish")]
+ public async void create_object (iCal.icalcomponent icalcomp, GLib.Cancellable? cancellable, out string out_uid) throws GLib.Error;
+--
+cgit v0.12
+