aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-05 20:17:08 +0800
committerwill <will@FreeBSD.org>2001-03-05 20:17:08 +0800
commit37b062ed62665ace31e4373b458cc75681213764 (patch)
treeb8f38166d53aef4457fc65f9d36d8ee0e550e5ce /deskutils
parenta60ff5681296acc284a5fdc038a18ac26c9daef4 (diff)
downloadfreebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.tar.gz
freebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.tar.zst
freebsd-ports-gnome-37b062ed62665ace31e4373b458cc75681213764.zip
Attempt to fix conflicts with a local getopt.h (specifically, the fix is
for libgnugetopt's getopt.h). Not tested, but should work.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kcharselect/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 6387bd1efbd7..1833fce21603 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes