aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-14 00:05:48 +0800
committerantoine <antoine@FreeBSD.org>2017-12-14 00:05:48 +0800
commit8baa14e264b4d93309c75c29a7eae5101304b37d (patch)
tree327fdff56dc4779407a7a80f5e68d09784124ee9 /deskutils
parent096d959851db69121a0ae6f42a205c8471a38abf (diff)
downloadfreebsd-ports-gnome-8baa14e264b4d93309c75c29a7eae5101304b37d.tar.gz
freebsd-ports-gnome-8baa14e264b4d93309c75c29a7eae5101304b37d.tar.zst
freebsd-ports-gnome-8baa14e264b4d93309c75c29a7eae5101304b37d.zip
- Those ports fail to build with python3
- Add some explicit FLAVOR to dependencies where needed - For totem, the pylint command is needed, not the pylint module
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnome-documents/Makefile4
-rw-r--r--deskutils/spice-gtk/Makefile3
2 files changed, 4 insertions, 3 deletions
diff --git a/deskutils/gnome-documents/Makefile b/deskutils/gnome-documents/Makefile
index 2c73575ebcc8..82ac70ee2aff 100644
--- a/deskutils/gnome-documents/Makefile
+++ b/deskutils/gnome-documents/Makefile
@@ -25,14 +25,14 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libgjs.so:lang/gjs \
libtracker-sparql-1.0.so:sysutils/tracker \
libzapojit-0.0.so:net/libzapojit
-RUN_DEPENDS= py2?-dbus>0:devel/py-dbus \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
unoconv:textproc/unoconv
PORTSCOUT= limitw:1,even
USES= compiler:c++11-lib gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+ pkgconfig python:2.7 tar:xz
USE_GNOME= gnomedesktop3 gtk30 intlhack \
introspection:build librsvg2 libxml2
GNU_CONFIGURE= yes
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index 7de50c6a148d..34985f8ff973 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -19,13 +19,14 @@ USES= autoreconf cpe gmake jpeg libtool pkgconfig tar:bzip2 \
CPE_VENDOR= redhat
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol \
- ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing@${PY_FLAVOR}
RUN_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol
.if defined(SPICE_SLAVE)
PORTREVISION= 1
CATEGORIES+= python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+USES:= ${USES:Npython} python:2.7
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
CONFIGURE_ARGS+= --with-python