aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-05-26 07:24:31 +0800
committerbeech <beech@FreeBSD.org>2011-05-26 07:24:31 +0800
commitaf280615a186c80d7fbfb10d7bab82e450f6fbaf (patch)
tree64e6b4c92d4e897874af3e56ce80a63be9c3e38e /deskutils
parent44ea0c0aedf0cd8863c1aa8b76930ac3d5834a92 (diff)
downloadfreebsd-ports-gnome-af280615a186c80d7fbfb10d7bab82e450f6fbaf.tar.gz
freebsd-ports-gnome-af280615a186c80d7fbfb10d7bab82e450f6fbaf.tar.zst
freebsd-ports-gnome-af280615a186c80d7fbfb10d7bab82e450f6fbaf.zip
- New port horde4-alarm-1.0.1
- This package provides an interface to deal with reminders, alarms and notifications through a standardized API. The following notification methods are available at the moment: standard Horde notifications, popups, emails, sms.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/horde4-alarm/Makefile43
-rw-r--r--deskutils/horde4-alarm/distinfo2
-rw-r--r--deskutils/horde4-alarm/files/pkg-message.in7
-rw-r--r--deskutils/horde4-alarm/pkg-descr6
-rw-r--r--deskutils/horde4-alarm/pkg-plist13
6 files changed, 72 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 05ebc28dbaf6..b7dea1e88b1d 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -118,6 +118,7 @@
SUBDIR += horde-kronolith
SUBDIR += horde-mnemo
SUBDIR += horde-nag
+ SUBDIR += horde4-alarm
SUBDIR += horde4-itip
SUBDIR += horde4-kronolith
SUBDIR += hot-babe
diff --git a/deskutils/horde4-alarm/Makefile b/deskutils/horde4-alarm/Makefile
new file mode 100644
index 000000000000..1075b22ebe5e
--- /dev/null
+++ b/deskutils/horde4-alarm/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: horde4-alarm
+# Date created: Wed May 24, 2011
+# Whom: Beech Rintoul (<beech@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= alarm
+PORTVERSION= 1.0.1
+DISTVERSIONPREFIX=
+DISTVERSIONSUFFIX=
+CATEGORIES= deskutils www
+MASTER_SITES= http://pear.horde.org/get/ \
+ LOCAL/beech
+PKGNAMEPREFIX= horde4-
+DISTNAME= Horde_Alarm-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Horde interface to deal with reminders, alarms and notifications
+
+USE_HORDE= base
+USE_GETTEXT= yes
+ALARMDIR= Alarm
+HORDIR= ${HORBAS}${ALARMDIR:S|^|/|:S|/horde||}
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/config && ${TOUCH} ${WRKSRC}/config/placeholder.dist
+
+do-install:
+ @${INSTALL} -d ${HORDIR}/
+ @${CP} ${WRKSRC}/lib/Horde/Alarm.php ${HORBAS}/
+ @${CP} -Rp ${WRKSRC}/lib/Horde/Alarm/ ${HORDIR}/
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
+
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
+.include <bsd.port.mk>
diff --git a/deskutils/horde4-alarm/distinfo b/deskutils/horde4-alarm/distinfo
new file mode 100644
index 000000000000..acf0c6e552fe
--- /dev/null
+++ b/deskutils/horde4-alarm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde_Alarm-1.0.1.tgz) = 341b5f6d920b90d4d030366e6c4c0e1c86280216a3039135a0a2c6de8713129e
+SIZE (Horde_Alarm-1.0.1.tgz) = 22845
diff --git a/deskutils/horde4-alarm/files/pkg-message.in b/deskutils/horde4-alarm/files/pkg-message.in
new file mode 100644
index 000000000000..411ae74495b3
--- /dev/null
+++ b/deskutils/horde4-alarm/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+Alarm has been installed in %%HORDIR%%/.
+
+Horde must be configured and the tables created; if not, see
+`pkg_info -Dx horde-base'.
+
+************************************************************************
diff --git a/deskutils/horde4-alarm/pkg-descr b/deskutils/horde4-alarm/pkg-descr
new file mode 100644
index 000000000000..9d4153282f34
--- /dev/null
+++ b/deskutils/horde4-alarm/pkg-descr
@@ -0,0 +1,6 @@
+Horde Alarm. This package provides an interface to deal with reminders, alarms
+and notifications through a standardized API. The following notification
+methods are available at the moment:
+standard Horde notifications, popups, emails, sms.
+
+WWW: http://www.horde.org
diff --git a/deskutils/horde4-alarm/pkg-plist b/deskutils/horde4-alarm/pkg-plist
new file mode 100644
index 000000000000..b4d4b7933502
--- /dev/null
+++ b/deskutils/horde4-alarm/pkg-plist
@@ -0,0 +1,13 @@
+%%HORBAS%%/Alarm.php
+%%HORDIR%%/Exception.php
+%%HORDIR%%/Handler.php
+%%HORDIR%%/Handler/Desktop.php
+%%HORDIR%%/Handler/Mail.php
+%%HORDIR%%/Handler/Notify.php
+%%HORDIR%%/Null.php
+%%HORDIR%%/Object.php
+%%HORDIR%%/Sql.php
+%%HORDIR%%/Translation.php
+@dirrm %%HORDIR%%/Handler
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%