aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-08-28 14:58:22 +0800
committermarcus <marcus@FreeBSD.org>2005-08-28 14:58:22 +0800
commitc5a2181ede4e47dc4d5322a5460301d542604ae4 (patch)
tree247706e429018cd2aceae699a44bd2da8ac2688f /deskutils
parent52a48984a7145eb2e730f439c29a77758f3f3683 (diff)
downloadfreebsd-ports-gnome-c5a2181ede4e47dc4d5322a5460301d542604ae4.tar.gz
freebsd-ports-gnome-c5a2181ede4e47dc4d5322a5460301d542604ae4.tar.zst
freebsd-ports-gnome-c5a2181ede4e47dc4d5322a5460301d542604ae4.zip
Add notification-daemon, a framework for notifying the user of application
events using passive pop-up windows. PR: 84721 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/notification-daemon/Makefile24
-rw-r--r--deskutils/notification-daemon/distinfo2
-rw-r--r--deskutils/notification-daemon/pkg-descr9
-rw-r--r--deskutils/notification-daemon/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index f422342c3383..a2cad302c2c4 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -114,6 +114,7 @@
SUBDIR += narval
SUBDIR += nautilus-sendto
SUBDIR += notebook
+ SUBDIR += notification-daemon
SUBDIR += offix-trash
SUBDIR += pal
SUBDIR += phpgroupware
diff --git a/deskutils/notification-daemon/Makefile b/deskutils/notification-daemon/Makefile
new file mode 100644
index 000000000000..f5312e0667fe
--- /dev/null
+++ b/deskutils/notification-daemon/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: notification-daemon
+# Date created: 2005-08-06
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= notification-daemon
+PORTVERSION= 0.2.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://www.galago.info/files/releases/source/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Send small notifications to your desktop
+
+LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus \
+ notify.0:${PORTSDIR}/devel/libnotify
+
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gtk20
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+CONFIGURE_ARGS= --with-dbus-services=${PREFIX}/share/dbus-1/services
+
+.include <bsd.port.mk>
diff --git a/deskutils/notification-daemon/distinfo b/deskutils/notification-daemon/distinfo
new file mode 100644
index 000000000000..313c1cd32770
--- /dev/null
+++ b/deskutils/notification-daemon/distinfo
@@ -0,0 +1,2 @@
+MD5 (notification-daemon-0.2.1.tar.gz) = 7aa30632a180777c6a75e987bb411b5e
+SIZE (notification-daemon-0.2.1.tar.gz) = 161451
diff --git a/deskutils/notification-daemon/pkg-descr b/deskutils/notification-daemon/pkg-descr
new file mode 100644
index 000000000000..037c6ed16e2f
--- /dev/null
+++ b/deskutils/notification-daemon/pkg-descr
@@ -0,0 +1,9 @@
+The Desktop Notifications framework provides a standard way of doing passive
+pop-up notifications on the desktop. These are designed to notify the
+user of something without interrupting their work with a dialog box that they
+must close. Passive popups can automatically disappear after a short period
+of time.
+
+This port contains the daemon.
+
+WWW: http://www.galago.info/specs/notification/index.php
diff --git a/deskutils/notification-daemon/pkg-plist b/deskutils/notification-daemon/pkg-plist
new file mode 100644
index 000000000000..f311ef1b99e0
--- /dev/null
+++ b/deskutils/notification-daemon/pkg-plist
@@ -0,0 +1,2 @@
+etc/dbus-1/system.d/notification-daemon.conf
+libexec/notification-daemon