aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-10-03 22:03:29 +0800
committermat <mat@FreeBSD.org>2013-10-03 22:03:29 +0800
commit087dc430fabe9618c62f29f576c95ee4ef4119be (patch)
tree936f685fba763a893230a5bc496656d47bc9821f /deskutils
parent2107a8a73750eaa8f739d305c5cd8a428476df4e (diff)
downloadfreebsd-ports-gnome-087dc430fabe9618c62f29f576c95ee4ef4119be.tar.gz
freebsd-ports-gnome-087dc430fabe9618c62f29f576c95ee4ef4119be.tar.zst
freebsd-ports-gnome-087dc430fabe9618c62f29f576c95ee4ef4119be.zip
Add mirall 1.4.0, the ownCloud Desktop Syncing Client.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/mirall/Makefile40
-rw-r--r--deskutils/mirall/distinfo2
-rw-r--r--deskutils/mirall/files/patch-src__CMakeLists.txt11
-rw-r--r--deskutils/mirall/files/patch-src__mirall__utility.cpp11
-rw-r--r--deskutils/mirall/pkg-descr4
-rw-r--r--deskutils/mirall/pkg-plist56
7 files changed, 125 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index d9b07fa3e86f..e9db81476c5c 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -144,6 +144,7 @@
SUBDIR += mdh
SUBDIR += mencal
SUBDIR += menumaker
+ SUBDIR += mirall
SUBDIR += moregroupware
SUBDIR += mrundlg
SUBDIR += msynctool
diff --git a/deskutils/mirall/Makefile b/deskutils/mirall/Makefile
new file mode 100644
index 000000000000..aa2debef7772
--- /dev/null
+++ b/deskutils/mirall/Makefile
@@ -0,0 +1,40 @@
+# Created by: Mathieu Arnold
+# $FreeBSD$
+
+PORTNAME= mirall
+PORTVERSION= 1.4.0
+CATEGORIES= deskutils
+MASTER_SITES= http://download.owncloud.com/download/
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= The ownCloud Desktop Syncing Client
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libocsync.so:${PORTSDIR}/net/owncloud-csync \
+ libinotify.so:${PORTSDIR}/devel/libinotify \
+ libqtkeychain.so:${PORTSDIR}/security/qtkeychain
+
+USES= cmake:outsource pkgconfig gmake
+USE_BZIP2=
+USE_QT4= corelib dbus gui linguist moc network qmake qtestlib rcc uic webkit xml
+CMAKE_ENV= CSYNC_DIR=${LOCALBASE}
+CMAKE_ARGS= -DCSYNC_INCLUDE_PATH:STRING=${LOCALBASE}/include/ocsync/
+USE_GCC= 4.6+
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+
+# It seems to be able to generate docs, but, it's not working.
+#
+# OPTIONS_DEFINE= DOCS
+# OPTIONS_DEFAULT=
+#
+# DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+#
+# .include <bsd.port.options.mk>
+#
+# .if ${PORT_OPTIONS:MDOCS}
+# USE_TEX= latex:build
+# .endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/mirall/distinfo b/deskutils/mirall/distinfo
new file mode 100644
index 000000000000..c73400810f6a
--- /dev/null
+++ b/deskutils/mirall/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mirall-1.4.0.tar.bz2) = 8efd1d779c7c21cd50860aa74bffefad536df5637da4a59648ea39ce6b0a3737
+SIZE (mirall-1.4.0.tar.bz2) = 1252568
diff --git a/deskutils/mirall/files/patch-src__CMakeLists.txt b/deskutils/mirall/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..00927c3d7697
--- /dev/null
+++ b/deskutils/mirall/files/patch-src__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./src/CMakeLists.txt.orig 2013-09-04 11:09:12.000000000 +0200
++++ ./src/CMakeLists.txt 2013-09-18 15:09:30.000000000 +0200
+@@ -140,7 +140,7 @@
+ list(APPEND libsync_LINK_TARGETS
+ ${QT_LIBRARIES}
+ ${CSYNC_LIBRARY}
+- dl
++ inotify
+ )
+
+ if(QTKEYCHAIN_FOUND)
diff --git a/deskutils/mirall/files/patch-src__mirall__utility.cpp b/deskutils/mirall/files/patch-src__mirall__utility.cpp
new file mode 100644
index 000000000000..28454d4c0717
--- /dev/null
+++ b/deskutils/mirall/files/patch-src__mirall__utility.cpp
@@ -0,0 +1,11 @@
+--- ./src/mirall/utility.cpp.orig 2013-09-04 11:09:12.000000000 +0200
++++ ./src/mirall/utility.cpp 2013-09-18 15:01:54.000000000 +0200
+@@ -313,7 +313,7 @@
+
+ qint64 Utility::freeDiskSpace(const QString &path, bool *ok)
+ {
+-#ifdef Q_OS_MAC
++#if defined(Q_OS_MAC) || defined(Q_OS_FREEBSD)
+ struct statvfs stat;
+ statvfs(path.toUtf8().data(), &stat);
+ return (qint64) stat.f_bavail * stat.f_frsize;
diff --git a/deskutils/mirall/pkg-descr b/deskutils/mirall/pkg-descr
new file mode 100644
index 000000000000..069d9f2f9ab6
--- /dev/null
+++ b/deskutils/mirall/pkg-descr
@@ -0,0 +1,4 @@
+Mirall is a tool to synchronize files from ownCloud Server with your computer.
+It uses OCSync as its syncing backend.
+
+WWW: https://github.com/owncloud/mirall
diff --git a/deskutils/mirall/pkg-plist b/deskutils/mirall/pkg-plist
new file mode 100644
index 000000000000..11bd447e4122
--- /dev/null
+++ b/deskutils/mirall/pkg-plist
@@ -0,0 +1,56 @@
+bin/owncloud
+etc/ownCloud/sync-exclude.lst
+lib/libowncloudsync.so
+lib/libowncloudsync.so.0
+lib/libowncloudsync.so.1.4.0
+share/applications/owncloud.desktop
+share/icons/hicolor/128x128/apps/owncloud.png
+share/icons/hicolor/22x22/apps/owncloud.png
+share/icons/hicolor/32x32/apps/owncloud.png
+share/icons/hicolor/48x48/apps/owncloud.png
+share/icons/hicolor/64x64/apps/owncloud.png
+share/owncloud/i18n/mirall_TW.qm
+share/owncloud/i18n/mirall_ca.qm
+share/owncloud/i18n/mirall_cs.qm
+share/owncloud/i18n/mirall_de.qm
+share/owncloud/i18n/mirall_el.qm
+share/owncloud/i18n/mirall_en.qm
+share/owncloud/i18n/mirall_es.qm
+share/owncloud/i18n/mirall_es_AR.qm
+share/owncloud/i18n/mirall_et.qm
+share/owncloud/i18n/mirall_eu.qm
+share/owncloud/i18n/mirall_fa.qm
+share/owncloud/i18n/mirall_fi.qm
+share/owncloud/i18n/mirall_fr.qm
+share/owncloud/i18n/mirall_gl.qm
+share/owncloud/i18n/mirall_hu.qm
+share/owncloud/i18n/mirall_it.qm
+share/owncloud/i18n/mirall_ja.qm
+share/owncloud/i18n/mirall_nl.qm
+share/owncloud/i18n/mirall_pl.qm
+share/owncloud/i18n/mirall_pt.qm
+share/owncloud/i18n/mirall_pt_BR.qm
+share/owncloud/i18n/mirall_ru.qm
+share/owncloud/i18n/mirall_sk.qm
+share/owncloud/i18n/mirall_sl.qm
+share/owncloud/i18n/mirall_sv.qm
+share/owncloud/i18n/mirall_th.qm
+share/owncloud/i18n/mirall_uk.qm
+share/owncloud/i18n/mirall_zh_CN.qm
+share/owncloud/i18n/mirall_zh_TW.qm
+@dirrm share/owncloud/i18n
+@dirrm share/owncloud
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications
+@dirrm etc/ownCloud