aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
commit0a710f368469e3e4eae0e43e8df218c8a9983268 (patch)
treef1130d11cb235986af009fc8b05aa63a6548dcdd /deskutils
parentba25a6ecc79a73710fb284c6682d27fad65d1d0e (diff)
downloadfreebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.gz
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.zst
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.zip
- Update The Glorious Glasgow Haskell Compiler to version 7.4.1
Please note that port revision for all the Haskell ports without version changes are also bumped. Other per-port updates are coming soon (in separate commits)! In addition to that, separate -docs ports are no longer needed so they are now removed. Thanks ashish@ for the assistance. Obtained from: FreeBSD Haskell
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/checkrdf/Makefile2
-rw-r--r--deskutils/checkrdf/files/patch-CheckRDF.hs31
-rw-r--r--deskutils/checkrdf/files/patch-Main.hs12
3 files changed, 35 insertions, 10 deletions
diff --git a/deskutils/checkrdf/Makefile b/deskutils/checkrdf/Makefile
index 996bd2341119..2e189857f287 100644
--- a/deskutils/checkrdf/Makefile
+++ b/deskutils/checkrdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= checkrdf
PORTVERSION= 39.4444
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils
MASTER_SITES= SF
diff --git a/deskutils/checkrdf/files/patch-CheckRDF.hs b/deskutils/checkrdf/files/patch-CheckRDF.hs
index 5383389034d5..d60481a3afdd 100644
--- a/deskutils/checkrdf/files/patch-CheckRDF.hs
+++ b/deskutils/checkrdf/files/patch-CheckRDF.hs
@@ -1,10 +1,23 @@
---- CheckRDF.hs.orig 2007-03-02 19:13:07.000000000 +0100
-+++ CheckRDF.hs 2009-01-26 18:28:22.000000000 +0100
-@@ -24,9 +24,12 @@
- import Directory ( doesFileExist, getPermissions, readable, removeFile )
- import List ( partition, intersperse, groupBy, sortBy)
- import Time (getClockTime,toCalendarTime,calendarTimeToString)
-+import Char (toLower)
+--- ./CheckRDF.hs.orig 2007-03-02 19:13:07.000000000 +0100
++++ ./CheckRDF.hs 2012-05-13 13:10:24.395459549 +0200
+@@ -18,15 +18,20 @@
+
+ import RDFConfig
+
+-import System (getArgs, exitWith, ExitCode(..),system,getEnv)
+-import IO ( catch, openFile, IOMode(..), hIsEOF, hGetLine
++import System.Environment (getArgs, getEnv)
++import System.Process (system)
++import System.Exit (exitWith, ExitCode(..))
++import System.IO ( openFile, IOMode(..), hIsEOF, hGetLine
+ , hPutStr, hClose, hFlush, stdin, Handle, hPutStrLn, hGetContents)
+-import Directory ( doesFileExist, getPermissions, readable, removeFile )
+-import List ( partition, intersperse, groupBy, sortBy)
+-import Time (getClockTime,toCalendarTime,calendarTimeToString)
++import System.Directory ( doesFileExist, getPermissions, readable, removeFile )
++import Data.List ( partition, intersperse, groupBy, sortBy)
++import System.Time (getClockTime,toCalendarTime,calendarTimeToString)
++import Data.Char (toLower)
import Text.XML.HaXml.Types
import Text.XML.HaXml.Parse (xmlParse)
@@ -13,7 +26,7 @@
import Text.XML.HaXml.Xtract.Parse (parseXtract)
import Text.PrettyPrint.HughesPJ (render, vcat)
import Text.XML.HaXml.Pretty (content)
-@@ -52,15 +55,15 @@
+@@ -52,15 +57,15 @@
mkNewRDF :: RDFConfig -> FilePath -> String -> RDF
mkNewRDF config filename contents =
let elem = getElem $ xmlParse filename contents
@@ -35,7 +48,7 @@
)
$ map show [0..len1-1])
else []
-@@ -69,7 +72,7 @@
+@@ -69,7 +74,7 @@
,clink = cl
,citems = rdfitems
}
diff --git a/deskutils/checkrdf/files/patch-Main.hs b/deskutils/checkrdf/files/patch-Main.hs
new file mode 100644
index 000000000000..f1206d55510a
--- /dev/null
+++ b/deskutils/checkrdf/files/patch-Main.hs
@@ -0,0 +1,12 @@
+--- ./Main.hs.orig 2005-05-29 21:27:39.000000000 +0200
++++ ./Main.hs 2012-05-12 19:33:06.000000000 +0200
+@@ -19,7 +19,8 @@
+
+ import CheckRDF
+ import RDFConfig
+-import System (getArgs, exitWith, ExitCode(..),getEnv)
++import System.Environment (getArgs, getEnv)
++import System.Exit (exitWith, ExitCode(..))
+
+ main :: IO ()
+ main = do files <- getArgs