aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-27 20:47:21 +0800
committermakc <makc@FreeBSD.org>2013-02-27 20:47:21 +0800
commit3877366fa17f20a5cfbb30f03c42c0e71063aa14 (patch)
treeb4ff53488218144513fb3116f92804359caf5175 /deskutils
parent21908ddf3878afc85bbee3c9eb850831b4ddada5 (diff)
downloadfreebsd-ports-gnome-3877366fa17f20a5cfbb30f03c42c0e71063aa14.tar.gz
freebsd-ports-gnome-3877366fa17f20a5cfbb30f03c42c0e71063aa14.tar.zst
freebsd-ports-gnome-3877366fa17f20a5cfbb30f03c42c0e71063aa14.zip
Add upstream patch to fix Kalarm segfault.
PR: ports/176046 Submitted by: Anish Mistry <amistry@unitedware.com>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kdepim44/Makefile2
-rw-r--r--deskutils/kdepim44/files/patch-kalarm__lib__spinbox2.cpp23
2 files changed, 24 insertions, 1 deletions
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 5916204a20ae..50229238a2dc 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdepim
PORTVERSION= 4.4.11.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/kdepim-${PORTVERSION}/src
diff --git a/deskutils/kdepim44/files/patch-kalarm__lib__spinbox2.cpp b/deskutils/kdepim44/files/patch-kalarm__lib__spinbox2.cpp
new file mode 100644
index 000000000000..67b74b04819a
--- /dev/null
+++ b/deskutils/kdepim44/files/patch-kalarm__lib__spinbox2.cpp
@@ -0,0 +1,23 @@
+--- kalarm/lib/spinbox2.cpp
++++ kalarm/lib/spinbox2.cpp
+@@ -28,7 +28,7 @@
+ #include <QMouseEvent>
+ #include <QStyleOptionSpinBox>
+ #include <QGraphicsPixmapItem>
+-#include <QPaintEngine>
++#include <QPainter>
+ #include <QTimer>
+ #include <QFrame>
+ #include <QBrush>
+@@ -588,8 +588,9 @@ void SpinMirror::setFrame()
+ p = grabWidget(mMainSpinbox, QRect(x, 0, 1, height()));
+ // Blot out edit field stuff from the middle of the slice
+ QPixmap dot = grabWidget(mMainSpinbox, QRect(x, editOffsetY, 1, 1));
+- QPaintEngine* pe = p.paintEngine();
+- pe->drawTiledPixmap(QRectF(0, editOffsetY, 1, height() - 2*editOffsetY), dot, QPointF(0, 0));
++ QPainter painter(&p);
++ painter.drawTiledPixmap(0, editOffsetY, 1, height() - 2*editOffsetY, dot, 0, 0);
++ painter.end();
+ // Horizontally fill the mirror widget with the vertical slice
+ p = p.scaled(size());
+ // Grab the left hand border of the main spinbox, and draw it into the mirror widget.