aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /deskutils
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/ksmoothdock/Makefile10
-rw-r--r--deskutils/treeline/Makefile15
2 files changed, 7 insertions, 18 deletions
diff --git a/deskutils/ksmoothdock/Makefile b/deskutils/ksmoothdock/Makefile
index cb55210d45d1..0107df06a48f 100644
--- a/deskutils/ksmoothdock/Makefile
+++ b/deskutils/ksmoothdock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ksmoothdock
-# Date created: 24 May 2004
-# Whom: Arjan van Leeuwen <avleeuwen@piwebs.com>
-#
+# Created by: Arjan van Leeuwen <avleeuwen@piwebs.com>
# $FreeBSD$
-#
PORTNAME= ksmoothdock
PORTVERSION= 4.5
@@ -13,12 +9,12 @@ MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}_automake-1.9
MAINTAINER= pawel@FreeBSD.org
-COMMENT= A dock program for KDE with smooth zooming
+COMMENT= Dock program for KDE with smooth zooming
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_KDELIBS_VER=3
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= autoconf:env automake:env libtool
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index f8c3b4a1a643..f6c55034ac14 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -39,16 +39,12 @@ ISPELL_DESC= Install with ispell support
PYXML_DESC= Use pythons py-xml instead of textproc/expat2
OPTIONS_DEFAULT= ASPELL PYXML
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASPELL}
-BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
-.endif
+ASPELL_BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+ISPELL_BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-.if ${PORT_OPTIONS:MISPELL}
-BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
-.endif
+.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MPYXML}
LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
@@ -56,9 +52,6 @@ LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
.if ${PORT_OPTIONS:MHTTPLOAD}
DISTFILES+= httpload2.py:plugins
-PLIST_SUB+= HTTPLOAD=""
-.else
-PLIST_SUB+= HTTPLOAD="@comment "
.endif
do-install: