aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
commit4f3e737e3339df65a7737d86948a5c8dacedae60 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /deskutils
parent38d22f91997e71dd03618ec2d16c51e19e000cd9 (diff)
downloadfreebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.gz
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.zst
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/conduit/Makefile16
-rw-r--r--deskutils/nautilus-sendto/Makefile27
-rw-r--r--deskutils/planner/Makefile27
3 files changed, 30 insertions, 40 deletions
diff --git a/deskutils/conduit/Makefile b/deskutils/conduit/Makefile
index 77bb3e9a54f6..170d5e80c0f8 100644
--- a/deskutils/conduit/Makefile
+++ b/deskutils/conduit/Makefile
@@ -1,6 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/deskutils/conduit/Makefile,v 1.7 2008/03/18 14:53:42 ahze Exp $
+
PORTNAME= conduit
PORTVERSION= 0.3.17
PORTREVISION= 6
@@ -32,17 +33,20 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_GNOME= pygnome2 gnomeprefix
-OPTIONS= NAUTILUS "Enable Nautilus Plugin" On \
- EOG "Enable Eye-Of-Gnome Plugin" On
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= NAUTILUS EOG
+OPTIONS_DEFAULT=NAUTILUS EOG
+NAUTILUS_DESC= Build Nautilus Plugin
+EOG_DESC= Build Eye-Of-Gnome Plugin
+
+.include <bsd.port.options.mk>
-.if defined(WITH_NAUTILUS)
+.if ${PORT_OPTIONS:MNAUTILUS}
USE_GNOME+= nautilus2
CONFIGURE_ARGS+= --enable-nautilus-extension
.endif
-.if defined(WITH_EOG)
+.if ${PORT_OPTIONS:MEOG}
BUILD_DEPENDS+= eog:${PORTSDIR}/graphics/eog
RUN_DEPENDS+= eog:${PORTSDIR}/graphics/eog
CONFIGURE_ARGS+= --enable-eog-plugin
@@ -55,4 +59,4 @@ post-patch:
-e 's|/usr/bin/python|${LOCALBASE}/bin/python|' \
-e 's|/usr/lib/firefox*|${LOCALBASE}/lib/firefox|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/nautilus-sendto/Makefile b/deskutils/nautilus-sendto/Makefile
index 88cccc7dc605..93b695c59e78 100644
--- a/deskutils/nautilus-sendto/Makefile
+++ b/deskutils/nautilus-sendto/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: nautilus-sendto
-# Date created: 2004-12-03
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/deskutils/nautilus-sendto/Makefile,v 1.30 2010/09/30 06:21:18 kwm Exp $
@@ -19,37 +16,37 @@ GLIB_SCHEMAS= org.gnome.Nautilus.Sendto.gschema.xml
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= intlhack gnomeprefix nautilus2 gnomehack \
- evolutiondataserver
-GNOME_DESKTOP_VERSION=2
+USES= pathfix
+USE_GNOME= intlhack gnomeprefix nautilus2 gnomehack evolutiondataserver
USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-plugins="${SENDTO_PLUGINS}"
-OPTIONS= PIDGIN "Build pidgin sendto plugin" off \
- UPNP "Build upnp sendto plugin" off
+OPTIONS_DEFINE= PIDGIN UPNP
+PIDGIN_DESC= Build pidgin sendto plugin
+UPNP_DESC= Build upnp sendto plugin
# check configure script for allowed_plugins="..." for new plugins
SENDTO_PLUGINS= evolution gajim nautilus-burn removable-devices
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PIDGIN)
+.if ${PORT_OPTIONS:MPIDGIN}
SENDTO_PLUGINS:=${SENDTO_PLUGINS} pidgin
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS+= pidgin:${PORTSDIR}/net-im/pidgin
PLIST_SUB+= PIDGIN=""
.else
PLIST_SUB+= PIDGIN="@comment "
.endif
-.if defined(WITH_UPNP)
+.if ${PORT_OPTIONS:MUPNP}
SENDTO_PLUGINS:=${SENDTO_PLUGINS} upnp
-LIB_DEPENDS+= gupnp-1.0:${PORTSDIR}/net/gupnp
+LIB_DEPENDS+= gupnp-1:${PORTSDIR}/net/gupnp
PLIST_SUB+= UPNP=""
.else
PLIST_SUB+= UPNP="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/planner/Makefile b/deskutils/planner/Makefile
index 705ecd202172..cb5c7be70e6c 100644
--- a/deskutils/planner/Makefile
+++ b/deskutils/planner/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: Planner
-# Date created: 15 July 2001
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
# $MCom: ports-stable/deskutils/planner/Makefile,v 1.4 2009/04/16 00:34:24 kwm Exp $
-#
PORTNAME= planner
PORTVERSION= 0.14.6
@@ -18,7 +14,8 @@ COMMENT= Project management application for GNOME 2
USE_XZ= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libgnomeprintui \
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack libgnomeui libgnomeprintui \
libgsf desktopfileutils
WANT_GNOME= yes
USE_GETTEXT= yes
@@ -36,13 +33,13 @@ GCONF_SCHEMAS= planner.schemas
MAN1= planner.1
-OPTIONS= GDA "Enable database support (though libgda)" off
+OPTIONS_DEFINE= GDA
+GDA_DESC= Enable database support (though libgda)
# EVO "Enable evolution data server support" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-
-.if defined(WITH_GDA)
+.if ${PORT_OPTIONS:MGDA}
USE_GNOME+= libgda3
CONFIGURE_ARGS+=--with-database=gda3
PLIST_SUB+= GDA=""
@@ -50,15 +47,7 @@ PLIST_SUB+= GDA=""
PLIST_SUB+= GDA="@comment "
.endif
-#.if defined(WITH_EVO)
-#USE_GNOME+= evolutiondataserver
-#CONFIGURE_ARGS+=--enable-eds --enable-eds-backend
-#PLIST_SUB+= EVO=""
-#.else
-PLIST_SUB+= EVO="@comment "
-#.endif
-
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>