aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 15:14:15 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 15:14:15 +0800
commit64d70ac4ccbe0791111277d48c0e6835936c12e3 (patch)
tree45086237042ed02ea3c39e08708e946fc3f4da18 /deskutils
parent8e7a63fec8f6eb66e5f5779b598c7cd8ff20902a (diff)
downloadfreebsd-ports-gnome-64d70ac4ccbe0791111277d48c0e6835936c12e3.tar.gz
freebsd-ports-gnome-64d70ac4ccbe0791111277d48c0e6835936c12e3.tar.zst
freebsd-ports-gnome-64d70ac4ccbe0791111277d48c0e6835936c12e3.zip
Convert deskutils to USES=pkgconfig
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/deforaos-todo/Makefile2
-rw-r--r--deskutils/ecru/Makefile8
-rw-r--r--deskutils/growl-for-linux/Makefile3
-rw-r--r--deskutils/kdepim3/Makefile3
-rw-r--r--deskutils/libstreamanalyzer/Makefile2
-rw-r--r--deskutils/msynctool-devel/Makefile3
-rw-r--r--deskutils/orage/Makefile2
-rw-r--r--deskutils/pal/Makefile7
-rw-r--r--deskutils/steadyflow/Makefile4
-rw-r--r--deskutils/strigidaemon/Makefile2
-rw-r--r--deskutils/xfce4-generic-slider/Makefile2
-rw-r--r--deskutils/xfce4-notifyd/Makefile2
-rw-r--r--deskutils/xfce4-tumbler/Makefile3
13 files changed, 16 insertions, 27 deletions
diff --git a/deskutils/deforaos-todo/Makefile b/deskutils/deforaos-todo/Makefile
index 16ae531129f5..015c0ed1fd25 100644
--- a/deskutils/deforaos-todo/Makefile
+++ b/deskutils/deforaos-todo/Makefile
@@ -16,8 +16,8 @@ LICENSE= GPLv3
LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
Desktop:${PORTSDIR}/x11/deforaos-libdesktop
+USES= pkgconfig
USE_GNOME= gtk20 desktopfileutils
-USE_PKGCONFIG= build
USE_GETTEXT= yes
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
diff --git a/deskutils/ecru/Makefile b/deskutils/ecru/Makefile
index 956f7af831a0..af2f3fba9e72 100644
--- a/deskutils/ecru/Makefile
+++ b/deskutils/ecru/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ecru
-# Date created: 2008-12-13
-# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
-#
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ecru
PORTVERSION= 0.1.0
@@ -18,11 +14,11 @@ LIB_DEPENDS= xmlrpc.3:${PORTSDIR}/net/xmlrpc-c \
config++.10:${PORTSDIR}/devel/libconfig \
glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+USES= pkgconfig
USE_PYTHON_BUILD= yes
USE_BZIP2= yes
MANCOMPRESSED= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
MAN1= ecru-config.1 ecru-delete.1 ecru-edit.1 \
ecru-info.1 ecru-list.1 ecru-post.1
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 64a439b7bdb2..bcffc8d8c8d3 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -23,6 +23,8 @@ OPTIONS_DEFINE= LIBNOTIFY
OPTIONS_DEFAULT= LIBNOTIFY
LIBNOTIFY_DESC= Use notify-osd for libnotify display plugin
+USES= pkgconfig
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLIBNOTIFY}
@@ -37,7 +39,6 @@ USE_GITHUB= yes
USE_GNOME= desktopfileutils gtk20
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_PKGCONFIG= build
USE_SQLITE= 3
WITH_OPENSSL_PORT= yes
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index f33b06f0f8fc..7cea1bfdba5f 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -26,11 +26,10 @@ PREFIX= ${KDE_PREFIX}
_NO_KDE_FINAL= yes
USE_BZIP2= yes
-USES= bison
+USES= bison pkgconfig
USE_OPENSSL= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-gpg=${LOCALBASE}/bin/gpg \
diff --git a/deskutils/libstreamanalyzer/Makefile b/deskutils/libstreamanalyzer/Makefile
index 63a4969688c3..83fa63b630a8 100644
--- a/deskutils/libstreamanalyzer/Makefile
+++ b/deskutils/libstreamanalyzer/Makefile
@@ -13,9 +13,9 @@ LIB_DEPENDS= avcodec${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFI
exiv2:${PORTSDIR}/graphics/exiv2 \
streams:${PORTSDIR}/deskutils/libstreams
+USES= pkgconfig
USE_ICONV= yes
USE_GNOME= libxml2
-USE_PKGCONFIG= build
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/deskutils/msynctool-devel/Makefile b/deskutils/msynctool-devel/Makefile
index 65df8af2a68e..e8ddc0629f7d 100644
--- a/deskutils/msynctool-devel/Makefile
+++ b/deskutils/msynctool-devel/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= opensync.1:${PORTSDIR}/devel/libopensync
CONFLICTS= msynctool-0.2*
USE_BZIP2= yes
-USES= cmake:outsource
-USE_PKGCONFIG= build
+USES= cmake:outsource pkgconfig
PLIST_FILES= bin/${PORTNAME}
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index 2923eb629434..f52bfab30fb5 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -15,11 +15,11 @@ LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+USES= pkgconfig
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20 intltool intlhack desktopfileutils
-USE_PKGCONFIG= build
USE_XFCE= configenv libmenu panel
USE_XORG= xext xrender xinerama xi xrandr xcursor xcomposite xdamage x11 \
xfixes
diff --git a/deskutils/pal/Makefile b/deskutils/pal/Makefile
index 5c7525566983..3568132f12db 100644
--- a/deskutils/pal/Makefile
+++ b/deskutils/pal/Makefile
@@ -1,7 +1,4 @@
-# Ports collection makefile for: pal
-# Date created: Mar 16, 2004
-# Whom: Herbert J. Skuhra <h.skuhra@gmail.com>
-#
+# Created by: Herbert J. Skuhra <h.skuhra@gmail.com>
# $FreeBSD$
PORTNAME= pal
@@ -14,8 +11,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= h.skuhra@gmail.com
COMMENT= A calendar application
+USES= pkgconfig
USE_GNOME= glib20
-USE_PKGCONFIG= build
USE_GETTEXT= yes
USE_GMAKE= yes
ALL_TARGET=
diff --git a/deskutils/steadyflow/Makefile b/deskutils/steadyflow/Makefile
index 799a5fe72913..abf749766499 100644
--- a/deskutils/steadyflow/Makefile
+++ b/deskutils/steadyflow/Makefile
@@ -1,5 +1,4 @@
# $FreeBSD$
-#
PORTNAME= steadyflow
PORTVERSION= 0.2.0
@@ -20,12 +19,11 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
USE_XZ= yes
-USES= cmake
+USES= cmake pkgconfig
GLIB_SCHEMAS= net.launchpad.steadyflow.gschema.xml
USE_GNOME= desktopfileutils glib20 gtk30
USE_GETTEXT= yes
INSTALLS_ICONS= yes
-USE_PKGCONFIG= build
CMAKE_ARGS= -DCOMPILE_GSETTINGS_ON_INSTALL:BOOL=ON \
-DWANT_AYATANA:BOOL=OFF
diff --git a/deskutils/strigidaemon/Makefile b/deskutils/strigidaemon/Makefile
index 59f46397e365..ea5c4af93052 100644
--- a/deskutils/strigidaemon/Makefile
+++ b/deskutils/strigidaemon/Makefile
@@ -12,9 +12,9 @@ LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
streams:${PORTSDIR}/deskutils/libstreams \
streamanalyzer:${PORTSDIR}/deskutils/libstreamanalyzer
+USES= pkgconfig
USE_FAM= yes
USE_GNOME= libxml2
-USE_PKGCONFIG= build
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/deskutils/xfce4-generic-slider/Makefile b/deskutils/xfce4-generic-slider/Makefile
index fb1e18f79df7..e42a15c01c21 100644
--- a/deskutils/xfce4-generic-slider/Makefile
+++ b/deskutils/xfce4-generic-slider/Makefile
@@ -12,8 +12,8 @@ COMMENT= Slider plugin to adjust and/or monitor any numeric variable
LICENSE= GPLv3
+USES= pkgconfig
USE_XFCE= panel libutil libgui
-USE_PKGCONFIG= build
CFLAGS+= `pkg-config --cflags libxfce4panel-1.0 libxfcegui4-1.0`
LDFLAGS+= `pkg-config --libs libxfce4panel-1.0 libxfcegui4-1.0`
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 4995cd2ff49e..91012a5ce094 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -16,12 +16,12 @@ LICENSE= GPLv3
LIB_DEPENDS= dbus-glib:${PORTSDIR}/devel/dbus-glib \
notify:${PORTSDIR}/devel/libnotify
+USES= pkgconfig
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk20 intltool intlhack desktopfileutils
-USE_PKGCONFIG= build
USE_XFCE= configenv libmenu libutil xfconf
INSTALLS_ICONS= yes
USE_XORG= x11
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
index fde4c5d90445..12f6d8fb6087 100644
--- a/deskutils/xfce4-tumbler/Makefile
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -1,6 +1,5 @@
# Created by: Olivier Duchateau
# $FreeBSD$
-#
PORTNAME= tumbler
PORTVERSION= 0.1.27
@@ -17,13 +16,13 @@ COMMENT= Thumbnail service for Xfce desktop
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv
-USE_PKGCONFIG= build
CONFIGURE_ARGS= --enable-xdg-cache \
--disable-gtk-doc-html