aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-31 03:32:23 +0800
committerantoine <antoine@FreeBSD.org>2014-01-31 03:32:23 +0800
commit6720e3b4a3214e7461e325bdea8afd90fe9999ea (patch)
tree14fd17b4581a52219d77f5271dc2ed6f049f1a14 /deskutils
parent64c2236e4bb23db66fa694f713d56558fd6be07d (diff)
downloadfreebsd-ports-gnome-6720e3b4a3214e7461e325bdea8afd90fe9999ea.tar.gz
freebsd-ports-gnome-6720e3b4a3214e7461e325bdea8afd90fe9999ea.tar.zst
freebsd-ports-gnome-6720e3b4a3214e7461e325bdea8afd90fe9999ea.zip
Stage support
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/jlj/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/deskutils/jlj/Makefile b/deskutils/jlj/Makefile
index f71f2daf34f1..abbc40df75e2 100644
--- a/deskutils/jlj/Makefile
+++ b/deskutils/jlj/Makefile
@@ -20,25 +20,18 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/jlj share/examples/jlj/dot.livejournal.rc
PLIST_DIRS= share/examples/jlj
+PORTDOCS= README
SHEBANG_FILES= jlj.pl
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= README
-.endif
+OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/jlj.pl ${PREFIX}/bin/jlj
- @${MKDIR} ${PREFIX}/share/examples/jlj
+ ${INSTALL_SCRIPT} ${WRKSRC}/jlj.pl ${STAGEDIR}${PREFIX}/bin/jlj
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/examples/jlj
${INSTALL_DATA} ${WRKSRC}/.livejournal.rc \
- ${PREFIX}/share/examples/jlj/dot.livejournal.rc
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.JLJ ${DOCSDIR}/README
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/share/examples/jlj/dot.livejournal.rc
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.JLJ ${STAGEDIR}${DOCSDIR}/README
.include <bsd.port.mk>