aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-05 07:50:21 +0800
committeradamw <adamw@FreeBSD.org>2014-07-05 07:50:21 +0800
commit83b6461b4a49f57c18448b6f4d2599df9cc409a8 (patch)
treefa278c53f03c0a6e901fd427226acd9c7d4f6f9c /deskutils
parent8006a19dca0f037c25d11a68d33df3f3917bf2c1 (diff)
downloadfreebsd-ports-gnome-83b6461b4a49f57c18448b6f4d2599df9cc409a8.tar.gz
freebsd-ports-gnome-83b6461b4a49f57c18448b6f4d2599df9cc409a8.tar.zst
freebsd-ports-gnome-83b6461b4a49f57c18448b6f4d2599df9cc409a8.zip
Remove NOPORTDOCS and NOPORTEXAMPLES from unstaged ports. Stage a couple while
we're here. Remove any other references to NOPORT*. Approved by: portmgr (blanket for modernization)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/fengoffice/Makefile21
-rw-r--r--deskutils/org-mode.el/Makefile4
2 files changed, 11 insertions, 14 deletions
diff --git a/deskutils/fengoffice/Makefile b/deskutils/fengoffice/Makefile
index e8ac8761d32c..88baf8b357be 100644
--- a/deskutils/fengoffice/Makefile
+++ b/deskutils/fengoffice/Makefile
@@ -24,7 +24,8 @@ EXTRACT_AFTER_ARGS= -d ${WRKSRC}
FENGOFFICE_DIR= www/${PORTNAME}
FENGOFFICE_WWWDIR= ${PREFIX}/${FENGOFFICE_DIR}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
pre-extract:
@${MKDIR} ${WRKDIR}/${PORTNAME}
@@ -39,19 +40,15 @@ pre-install:
${FIND} . -type f | ${SORT} | ${SED} -e 's|^|www/fengoffice/|' -e 's|\./||g' >> ${PLIST} && \
${FIND} . -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm www/fengoffice|' -e 's|\.||g' >> ${PLIST}
-. if !defined(NOPORTDOCS)
- @${ECHO_CMD} "%%PORTDOCS%%%%DOCSDIR%%/README" >> ${PLIST}
- @${ECHO_CMD} "%%PORTDOCS%%@dirrm %%DOCSDIR%%" >> ${PLIST}
-. endif
+ @${ECHO_CMD} "%%PORTDOCS%%%%DOCSDIR%%/README" >> ${PLIST}
+ @${ECHO_CMD} "%%PORTDOCS%%@dirrm %%DOCSDIR%%" >> ${PLIST}
do-install:
- @${MKDIR} ${FENGOFFICE_WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${FENGOFFICE_WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${FENGOFFICE_WWWDIR}
-.if !defined (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-docs/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${FENGOFFICE_WWWDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${FENGOFFICE_WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${FENGOFFICE_WWWDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-docs/README ${STAGEDIR}${DOCSDIR}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/deskutils/org-mode.el/Makefile b/deskutils/org-mode.el/Makefile
index a544fe10e0c1..7a0e706675d8 100644
--- a/deskutils/org-mode.el/Makefile
+++ b/deskutils/org-mode.el/Makefile
@@ -88,6 +88,8 @@ CONTRIBS= \
scripts/staticmathjax/README.org \
scripts/staticmathjax/README.txt \
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -i .pv 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/Makefile
@@ -107,10 +109,8 @@ post-install:
.for i in ${CONTRIBS}
${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${DOCSDIR}/contrib/$$(dirname ${i})
.endfor
-.if !defined(NOPORTDOCS)
.for i in org.pdf orgcard.pdf orgguide.pdf
${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>