aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
committermiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
commitb5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7 (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /deskutils
parent4c148339a17778393b116c6e7051a9bc484e786a (diff)
downloadfreebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.gz
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.zst
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/cairo-dock-plugins/Makefile35
-rw-r--r--deskutils/gdesklets/Makefile8
-rw-r--r--deskutils/global-menu/Makefile13
-rw-r--r--deskutils/moregroupware/Makefile20
-rw-r--r--deskutils/wyrd/Makefile16
5 files changed, 41 insertions, 51 deletions
diff --git a/deskutils/cairo-dock-plugins/Makefile b/deskutils/cairo-dock-plugins/Makefile
index 07180bcb482f..f520c64d058f 100644
--- a/deskutils/cairo-dock-plugins/Makefile
+++ b/deskutils/cairo-dock-plugins/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cairo-dock-plugins
-# Date created: 2010-03-19
-# Whom: Ivan Klymenko <fidaj@ukr.net>
-#
+# Created by: Ivan Klymenko <fidaj@ukr.net>
# $FreeBSD$
-#
PORTNAME= cairo-dock-plugins
DISTVERSION= 2.3.0~3
@@ -36,19 +32,24 @@ USE_GCC= 4.6+
MAKE_JOBS_SAFE= YES
PLIST_SUB+= PYVER="${PYTHON_VERSION:S/thon//}"
-OPTIONS= GMENU "Common Applications menu" On \
- KEYBOARD_INDICATOR "Control the keyboard layout" Off \
- TERMINAL "Add a terminal to your dock" On \
- WEBLETS "To show an interactive web page" On \
- XFCE_INTEGRATION "For XFCE environnement" Off \
- ALSA_MIXER "For ALSA compatibility utils" Off
+
+
+OPTIONS_DEFINE= GMENU KEYBOARD_INDICATOR TERMINAL WEBLETS \
+ XFCE_INTEGRATION ALSA_MIXER
+OPTIONS_DEFAULT= GMENU TERMINAL WEBLETS
+GMENU_DESC= Common Applications menu
+KEYBOARD_INDICATOR_DESC= Control the keyboard layout
+TERMINAL_DESC= Add a terminal to your dock
+WEBLETS_DESC= To show an interactive web page
+XFCE_INTEGRATION_DESC= For XFCE environnement
+ALSA_MIXER_DESC= For ALSA compatibility utils
.include <bsd.port.options.mk>
post-patch:
@${CP} -R ${WRKDIR}/${ICONS_PACKAGE}/* ${WRKSRC}
-.if defined(WITH_GMENU)
+.if ${PORT_OPTIONS:MGMENU}
LIB_DEPENDS+= gnome-menu.2:${PORTSDIR}/x11/gnome-menus
CMAKE_ARGS+= -Denable_gmenu:STRING=yes
PLIST_SUB+= GMENU=""
@@ -57,7 +58,7 @@ CMAKE_ARGS+= -Denable_gmenu:STRING=no
PLIST_SUB+= GMENU="@comment "
.endif
-.if defined(WITH_KEYBOARD_INDICATOR)
+.if ${PORT_OPTIONS:MKEYBOARD_INDICATOR}
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif \
xklavier.12:${PORTSDIR}/x11/libxklavier
CMAKE_ARGS+= -Denable_keyboard_indicator:STRING=yes
@@ -67,7 +68,7 @@ CMAKE_ARGS+= -Denable_keyboard_indicator:STRING=no
PLIST_SUB+= KEYBOARD_INDICATOR="@comment "
.endif
-.if defined(WITH_TERMINAL)
+.if ${PORT_OPTIONS:MTERMINAL}
LIB_DEPENDS+= vte.9:${PORTSDIR}/x11-toolkits/vte
CMAKE_ARGS+= -Denable_terminal:STRING=yes
PLIST_SUB+= TERMINAL=""
@@ -76,7 +77,7 @@ CMAKE_ARGS+= -Denable_terminal:STRING=no
PLIST_SUB+= TERMINAL="@comment "
.endif
-.if defined(WITH_WEBLETS)
+.if ${PORT_OPTIONS:MWEBLETS}
LIB_DEPENDS+= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
CMAKE_ARGS+= -Denable_weblets:STRING=yes
PLIST_SUB+= WEBLETS=""
@@ -85,7 +86,7 @@ CMAKE_ARGS+= -Denable_weblets:STRING=no
PLIST_SUB+= WEBLETS="@comment "
.endif
-.if defined(WITH_XFCE_INTEGRATION)
+.if ${PORT_OPTIONS:MXFCE_INTEGRATION}
LIB_DEPENDS+= thunar-vfs-1.5:${PORTSDIR}/x11-fm/thunar \
exif.12:${PORTSDIR}/graphics/libexif
CMAKE_ARGS+= -Denable_xfce_integration:STRING=yes
@@ -95,7 +96,7 @@ CMAKE_ARGS+= -Denable_xfce_integration:STRING=no
PLIST_SUB+= XFCE_INTEGRATION="@comment "
.endif
-.if defined(WITH_ALSA_MIXER)
+.if ${PORT_OPTIONS:MALSA_MIXER}
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
CMAKE_ARGS+= -Denable_alsa_mixer:STRING=yes
diff --git a/deskutils/gdesklets/Makefile b/deskutils/gdesklets/Makefile
index 63715bcf440f..50e6a4b9f51e 100644
--- a/deskutils/gdesklets/Makefile
+++ b/deskutils/gdesklets/Makefile
@@ -15,7 +15,7 @@ USE_BZIP2= yes
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop
-OPTIONS= GDBM "install py-gdbm instead py-bsddb for config storage" off
+OPTIONS_DEFINE= GDBM
WRKSRC= ${WRKDIR}/gDesklets-${PORTVERSION}
@@ -31,9 +31,9 @@ MAN1= ${PORTNAME}.1
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MGDBM}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gdbm>0:${PORTSDIR}/databases/py-gdbm
.else
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb
@@ -47,4 +47,4 @@ post-install:
@-update-mime-database ${PREFIX}/share/mime
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/global-menu/Makefile b/deskutils/global-menu/Makefile
index ccecea2510ec..1eb20290e4d2 100644
--- a/deskutils/global-menu/Makefile
+++ b/deskutils/global-menu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnome-globalmenu
-# Date created: 27 February 2009
-# Whom: Gustavo Perez
-#
+# Created by: Gustavo Perez
# $FreeBSD$
-#
PORTNAME= gnome-globalmenu
PORTVERSION= 0.7.10
@@ -27,11 +23,12 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= XFCE4_PANEL "Xfce panel applet" Off
+OPTIONS_DEFINE= XFCE4_PANEL NLS
+XFCE4_PANEL_DESC= Xfce panel applet
.include <bsd.port.options.mk>
-.if defined(WITHOUT_XFCE4_PANEL)
+.if ${PORT_OPTIONS:MXFCE4_PANEL}
CONFIGURE_ARGS+= --without-xfce4-panel
PLIST_SUB+= XFCE4_PANEL="@comment "
.else
@@ -40,7 +37,7 @@ CONFIGURE_ARGS+= --with-xfce4-panel
PLIST_SUB+= XFCE4_PANEL=""
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
index 3627cd77dbdf..67bbcfe6aef3 100644
--- a/deskutils/moregroupware/Makefile
+++ b/deskutils/moregroupware/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: deskutils/moregroupware
-# Date created: December 30th 2003
-# Whom: Rob Evers <rob@debank.tv>
-#
+# Created by: Rob Evers <rob@debank.tv>
# $FreeBSD$
-#
PORTNAME= moregroupware
PORTVERSION= 0.7.4
@@ -24,22 +20,22 @@ USE_PHP= curl \
WANT_PHP_MOD= yes
-OPTIONS= ADDONS "install additional workgroup features (addons)" off \
- POSTGRESQL "use PostgreSQL instead of MySQL" off
+OPTIONS_DEFINE= ADDONS PGSQL NLS
+ADDONS_DESC= install additional workgroup features (addons)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
.endif
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= ${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql74-server
.else
RUN_DEPENDS+= ${LOCALBASE}/bin/mysql:${PORTSDIR}/databases/mysql50-server
.endif
-.if defined (WITH_ADDONS)
+.if ${PORT_OPTIONS:MADDONS}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-addons-${PORTVERSION}${EXTRACT_SUFX}
PLIST_SUB+= ADDONS=""
@@ -57,4 +53,4 @@ do-install:
post-install:
${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/wyrd/Makefile b/deskutils/wyrd/Makefile
index 53653d62fbac..81d014b0ba81 100644
--- a/deskutils/wyrd/Makefile
+++ b/deskutils/wyrd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wyrd
-# Date created: Apr 5 2006
-# Whom: Russell A. Jackson <raj@csub.edu>
-#
+# Created by: Russell A. Jackson <raj@csub.edu>
# $FreeBSD$
-#
PORTNAME= wyrd
PORTVERSION= 1.4.5
@@ -18,7 +14,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/remind:${PORTSDIR}/deskutils/remind
LICENSE= GPLv2
-OPTIONS= UTF8 "Enable UTF-8 support" off
+OPTIONS_DEFINE= UTF8
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -27,9 +23,9 @@ USE_NCURSES= yes
MAN1= wyrd.1
MAN5= wyrdrc.5
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_UTF8)
+.if ${PORT_OPTIONS:MUTF8}
CONFIGURE_ARGS+=--enable-utf8
.else
CONFIGURE_ARGS+=--disable-utf8
@@ -41,10 +37,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/wyrd.1 ${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/wyrdrc.5 ${MAN5PREFIX}/man/man5
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/manual.pdf ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>