aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-09 06:11:00 +0800
committerpav <pav@FreeBSD.org>2004-11-09 06:11:00 +0800
commitb73d28b74d07f803347df5b93e8fa7ba504a1152 (patch)
treee6dff4062cab3193af8063a121cc865914e40b00 /deskutils
parent1449aff8be4cc5efcdfe0ca733ba881c679c8be9 (diff)
downloadfreebsd-ports-gnome-b73d28b74d07f803347df5b93e8fa7ba504a1152.tar.gz
freebsd-ports-gnome-b73d28b74d07f803347df5b93e8fa7ba504a1152.tar.zst
freebsd-ports-gnome-b73d28b74d07f803347df5b93e8fa7ba504a1152.zip
- replace gtk-config with ${GTK_CONFIG} and gdk-pixbuf-config
with ${GDK_PIXBUF_CONFIG} - install the manpage PR: ports/73676 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer) Requested by: Jean-Baptiste Quenot
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/hot-babe/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/deskutils/hot-babe/Makefile b/deskutils/hot-babe/Makefile
index e4dc679a3fd3..7d2426fe6abe 100644
--- a/deskutils/hot-babe/Makefile
+++ b/deskutils/hot-babe/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hot-babe
PORTVERSION= 0.1.4
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://dindinx.net/hotbabe/downloads/
@@ -17,6 +18,9 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
MAKE_ARGS+= PREFIX="${PREFIX}" CC="${CC}"
USE_GNOME= gdkpixbuf
+USE_REINPLACE= yes
+
+MAN1= hot-babe.1
pre-everything::
@${ECHO_MSG}
@@ -24,4 +28,11 @@ pre-everything::
@${ECHO_MSG} "You might hit Ctrl-C to abort."
@${ECHO_MSG}
+post-patch:
+ @${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g;s|gdk-pixbuf-config|${GDK_PIXBUF_CONFIG}|g' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/hot-babe.1 ${PREFIX}/man/man1
+
.include <bsd.port.mk>