aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-12-18 05:19:58 +0800
committermarcus <marcus@FreeBSD.org>2003-12-18 05:19:58 +0800
commitd9f0ecbacb6baa4707c8c91d55ffc082a9dd5e5d (patch)
tree5aa97d5f9c4881c6366d59316de48933ecb2ad35 /deskutils
parent1b84c80a355cd718e1a6980844ce60b09952b5e1 (diff)
downloadfreebsd-ports-gnome-d9f0ecbacb6baa4707c8c91d55ffc082a9dd5e5d.tar.gz
freebsd-ports-gnome-d9f0ecbacb6baa4707c8c91d55ffc082a9dd5e5d.tar.zst
freebsd-ports-gnome-d9f0ecbacb6baa4707c8c91d55ffc082a9dd5e5d.zip
Add gdesklets-psi_displaypackage, the PSI Display module for gDesklets that
ties in all of the PSI backend Sensors (e.g. CPU monitor, disk monitor, mail check, TODO list, etc.). PR: 59831 Submitted by: Franz Klammer <klammer@webonaut.com>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gdesklets-psi_displaypackage/Makefile49
-rw-r--r--deskutils/gdesklets-psi_displaypackage/distinfo1
-rw-r--r--deskutils/gdesklets-psi_displaypackage/files/patch-fortune.display11
-rw-r--r--deskutils/gdesklets-psi_displaypackage/files/patch-info.display13
-rw-r--r--deskutils/gdesklets-psi_displaypackage/pkg-descr5
-rw-r--r--deskutils/gdesklets-psi_displaypackage/pkg-message14
-rw-r--r--deskutils/gdesklets-psi_displaypackage/pkg-plist18
8 files changed, 112 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index d6418246e96f..2ca7d20fae4c 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -18,6 +18,7 @@
SUBDIR += gdeskcal
SUBDIR += gdeskcal-skins
SUBDIR += gdesklets
+ SUBDIR += gdesklets-psi_displaypackage
SUBDIR += gdesklets-psi_themes
SUBDIR += gdesklets-recentlyused
SUBDIR += gdesklets-sensor-psi_externalinterval
diff --git a/deskutils/gdesklets-psi_displaypackage/Makefile b/deskutils/gdesklets-psi_displaypackage/Makefile
new file mode 100644
index 000000000000..66b347df183d
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: gdesklets-psi_displaypackage
+# Date created: 21 September 2003
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= displaypackage
+PORTVERSION= 0.2
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-psi_
+DISTNAME= PsiDisplayPackage-${DISTVERSION}
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= The Psi Display Package
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets \
+ ${DATADIR}/Sensors/CPU/__init__.py:${PORTSDIR}/sysutils/gdesklets-sensor-psi_cpu \
+ ${DATADIR}/Sensors/Disk/__init__.py:${PORTSDIR}/sysutils/gdesklets-sensor-psi_disk \
+ ${DATADIR}/Sensors/ExternalInterval/__init__.py:${PORTSDIR}/deskutils/gdesklets-sensor-psi_externalinterval \
+ ${DATADIR}/Sensors/Memo/__init__.py:${PORTSDIR}/deskutils/gdesklets-sensor-psi_memo \
+ ${DATADIR}/Sensors/MemoOver/__init__.py:${PORTSDIR}/deskutils/gdesklets-sensor-psi_memoover \
+ ${DATADIR}/Sensors/Memory/__init__.py:${PORTSDIR}/sysutils/gdesklets-sensor-psi_memory \
+ ${DATADIR}/Sensors/Network/__init__.py:${PORTSDIR}/net/gdesklets-sensor-psi_network \
+ ${DATADIR}/Sensors/Ping/__init__.py:${PORTSDIR}/net/gdesklets-sensor-psi_ping \
+ ${DATADIR}/Sensors/popmail/__init__.py:${PORTSDIR}/mail/gdesklets-sensor-psi_popmail \
+ ${DATADIR}/Sensors/Theme/__init__.py:${PORTSDIR}/deskutils/gdesklets-sensor-psi_theme \
+ ${DATADIR}/Sensors/VariableBorder/__init__.py:${PORTSDIR}/deskutils/gdesklets-sensor-psi_variableborder \
+ ${DATADIR}/Sensors/IconButton/__init__.py:${PORTSDIR}/deskutils/gdesklets-sensor-psi_iconbutton
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+
+DISTVERSION= 20031028
+NAME= psi-displays
+DATADIR= ${PREFIX}/share/gnome/gdesklets
+WRKSRC= ${WRKDIR}/${NAME}-v${PORTVERSION}
+NO_BUILD= yes
+
+do-install:
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+ @${MKDIR} ${DATADIR}/Displays/${NAME}
+ @${INSTALL_DATA} ${WRKSRC}/*.display ${DATADIR}/Displays/${NAME}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/deskutils/gdesklets-psi_displaypackage/distinfo b/deskutils/gdesklets-psi_displaypackage/distinfo
new file mode 100644
index 000000000000..60378cb17c0e
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/distinfo
@@ -0,0 +1 @@
+MD5 (PsiDisplayPackage-20031028.tar.bz2) = ebde2a0b8130ddb161e8a1c0f06f0dc6
diff --git a/deskutils/gdesklets-psi_displaypackage/files/patch-fortune.display b/deskutils/gdesklets-psi_displaypackage/files/patch-fortune.display
new file mode 100644
index 000000000000..18e9eba5e7ab
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/files/patch-fortune.display
@@ -0,0 +1,11 @@
+--- fortune.display.orig Fri Nov 21 22:11:34 2003
++++ fortune.display Fri Nov 21 22:11:43 2003
+@@ -6,7 +6,7 @@
+ version="0.2.1"
+ description="Themable fortune (needs the Theme,FontSelector,ExternalInterval sensors)"/>
+
+- <sensor id="fortune" module="ExternalInterval,fortune|fmt -w 35|iconv -t=UTF-8,Fortune refresh,60000"/>
++ <sensor id="fortune" module="ExternalInterval,fortune|fmt -w 35|iconv -t UTF-8,Fortune refresh,60000"/>
+ <sensor id="FS" module="FontSelector,1,Sans 8,white"/>
+ <sensor id="THbg" module="Theme,Psi-Disp-Themes,backgrounds"/>
+ <sensor id="THb" module="Theme,Psi-Disp-Themes,borders"/>
diff --git a/deskutils/gdesklets-psi_displaypackage/files/patch-info.display b/deskutils/gdesklets-psi_displaypackage/files/patch-info.display
new file mode 100644
index 000000000000..dccae242c755
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/files/patch-info.display
@@ -0,0 +1,13 @@
+--- info.display.orig Fri Oct 24 12:31:48 2003
++++ info.display Fri Nov 21 23:35:34 2003
+@@ -6,8 +6,8 @@
+ version="0.2.1"
+ description="Shows the uptime,kernel version, CPU load, user name and hostname (needs the Theme,CPU,FontSelector,External sensors)"/>
+
+- <sensor id="uptime" module="External,uptime|tr -s ' ' '\t' |cut -f 4|cut -d \, -f 1,60000"/>
+- <sensor id="kernel" module="External,cat /proc/version|cut -d ' ' -f 1-3,0"/>
++ <sensor id="uptime" module="External,uptime| sed -e 's@.*up @@'|cut -d \, -f 1,60000"/>
++ <sensor id="kernel" module="External,uname -r,0"/>
+ <sensor id="CPU" module="CPU,1000"/>
+ <sensor id="who" module="External,whoami,0"/>
+ <sensor id="hostname" module="External,hostname|cut -d . -f 1,0"/>
diff --git a/deskutils/gdesklets-psi_displaypackage/pkg-descr b/deskutils/gdesklets-psi_displaypackage/pkg-descr
new file mode 100644
index 000000000000..e8b3c1cd3bba
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/pkg-descr
@@ -0,0 +1,5 @@
+Displays :
+borders, clock, diskinfo, fortune, info, meminfo, memo,
+networkinfo, popmail, ping, variable-borders.
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/deskutils/gdesklets-psi_displaypackage/pkg-message b/deskutils/gdesklets-psi_displaypackage/pkg-message
new file mode 100644
index 000000000000..1a2a900720f7
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/pkg-message
@@ -0,0 +1,14 @@
+##
+To view all installed applets:
+
+ ls ${PREFIX}/share/gnome/gdesklets/Displays
+
+To use those applets:
+
+ gdesklets ${PREFIX}/share/gnome/gdesklets/Displays/psi-displays/${name}.display
+
+Replace ${name} with the correct name of the display you want to use.
+
+NOTE: Be sure to login as your user when you use the gdesklets command,
+ as some data will be stored in the ~/.gdesklets/ directory.
+##
diff --git a/deskutils/gdesklets-psi_displaypackage/pkg-plist b/deskutils/gdesklets-psi_displaypackage/pkg-plist
new file mode 100644
index 000000000000..55bcf0d1d972
--- /dev/null
+++ b/deskutils/gdesklets-psi_displaypackage/pkg-plist
@@ -0,0 +1,18 @@
+share/gnome/gdesklets/Displays/psi-displays/border-bottom-left.display
+share/gnome/gdesklets/Displays/psi-displays/border-bottom-right.display
+share/gnome/gdesklets/Displays/psi-displays/border-top-left.display
+share/gnome/gdesklets/Displays/psi-displays/border-top-right.display
+share/gnome/gdesklets/Displays/psi-displays/clock.display
+share/gnome/gdesklets/Displays/psi-displays/diskinfo.display
+share/gnome/gdesklets/Displays/psi-displays/fortune.display
+share/gnome/gdesklets/Displays/psi-displays/info.display
+share/gnome/gdesklets/Displays/psi-displays/meminfo.display
+share/gnome/gdesklets/Displays/psi-displays/memo.display
+share/gnome/gdesklets/Displays/psi-displays/memoover.display
+share/gnome/gdesklets/Displays/psi-displays/networkinfo.display
+share/gnome/gdesklets/Displays/psi-displays/ping.display
+share/gnome/gdesklets/Displays/psi-displays/popmail.display
+share/gnome/gdesklets/Displays/psi-displays/variable-border-left.display
+share/gnome/gdesklets/Displays/psi-displays/variable-border-right.display
+share/gnome/gdesklets/Displays/psi-displays/variable-space.display
+@dirrm share/gnome/gdesklets/Displays/psi-displays