aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-11-29 20:22:00 +0800
committerdinoex <dinoex@FreeBSD.org>2008-11-29 20:22:00 +0800
commited0063ec9d4da71b9de7c689fc3c0eb9da57f870 (patch)
treecb7f73ebd3502eec7cf86660dea04bd58bcaef66 /deskutils
parentdb146db8b2b49fb8496aa7e0f3ce9deb5c869e1b (diff)
downloadfreebsd-ports-gnome-ed0063ec9d4da71b9de7c689fc3c0eb9da57f870.tar.gz
freebsd-ports-gnome-ed0063ec9d4da71b9de7c689fc3c0eb9da57f870.tar.zst
freebsd-ports-gnome-ed0063ec9d4da71b9de7c689fc3c0eb9da57f870.zip
Corner is a simple 'hot-corners' implementation. It instantiates a
CornerDelegate object and sends it messages of the form -enterTopLeft and -exitTopLeftAfter: for each corner, where the exit message takes the number of seconds the mouse spent in that corner as an argument. The delegate simply ignores these messages by default. A category on this object, however, can be provided. If you store a Smalltalk script in the "CornerScript" default as a string object then this will be loaded automatically and compiled. If this contains a category on CornerDelegate then the Smalltalk implementation will be called instead. A trivial example might log a message when the corner was entered was called: $ defaults write Corner CornerScript \ "CornerDelegate extend [ enterTopLeft [ 'Script called' log. ] ]" WWW: http://www.etoile-project.org/
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/etoile-corner/Makefile34
-rw-r--r--deskutils/etoile-corner/distinfo3
-rw-r--r--deskutils/etoile-corner/pkg-descr16
4 files changed, 54 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 22606aff2fb3..42ebd4964809 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -40,6 +40,7 @@
SUBDIR += egroupware
SUBDIR += estickies
SUBDIR += etask
+ SUBDIR += etoile-corner
SUBDIR += etoile-dictionaryreader
SUBDIR += etoile-distributedview
SUBDIR += etoile-extendedworkspacekit
diff --git a/deskutils/etoile-corner/Makefile b/deskutils/etoile-corner/Makefile
new file mode 100644
index 000000000000..ab6f9e3fdb4d
--- /dev/null
+++ b/deskutils/etoile-corner/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: etoile-corner
+# Date created: 26 Nov 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= corner
+PORTVERSION= 0.4.0
+CATEGORIES= deskutils gnustep
+MASTER_SITES= http://download.gna.org/etoile/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project hot-corners
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LOCAL_LIBS+= SmalltalkKit:${SMALLTALKKIT_PORT}
+USE_GNUSTEP_LOCAL_LIBS+= ScriptKit:${SCRIPTKIT_PORT}
+
+WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
+USE_GNUSTEP_MAKE_DIRS+= Services/Private/Corner
+PLIST_FILES= System/Tools/Corner
+
+SMALLTALKKIT_PORT?= lang/etoile-smalltalkkit
+SCRIPTKIT_PORT?= lang/etoile-scriptkit
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-corner/distinfo b/deskutils/etoile-corner/distinfo
new file mode 100644
index 000000000000..2c1e8a612c54
--- /dev/null
+++ b/deskutils/etoile-corner/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile-0.4.0.tar.bz2) = 7c33baf8ec3a708d0d419b1e137452de
+SHA256 (etoile-0.4.0.tar.bz2) = 05b5f01932aaad2ae6251ae01a1ad5376d29c984ee83d9fb62688c8d4a20237a
+SIZE (etoile-0.4.0.tar.bz2) = 8225128
diff --git a/deskutils/etoile-corner/pkg-descr b/deskutils/etoile-corner/pkg-descr
new file mode 100644
index 000000000000..54c523eb5946
--- /dev/null
+++ b/deskutils/etoile-corner/pkg-descr
@@ -0,0 +1,16 @@
+Corner is a simple 'hot-corners' implementation. It instantiates a
+CornerDelegate object and sends it messages of the form -enterTopLeft and
+-exitTopLeftAfter: for each corner, where the exit message takes the number of
+seconds the mouse spent in that corner as an argument.
+
+The delegate simply ignores these messages by default. A category on this
+object, however, can be provided. If you store a Smalltalk script in the
+"CornerScript" default as a string object then this will be loaded
+automatically and compiled. If this contains a category on CornerDelegate then
+the Smalltalk implementation will be called instead. A trivial example might
+log a message when the corner was entered was called:
+
+$ defaults write Corner CornerScript \
+"CornerDelegate extend [ enterTopLeft [ 'Script called' log. ] ]"
+
+WWW: http://www.etoile-project.org/