aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-02-01 23:46:04 +0800
committermadpilot <madpilot@FreeBSD.org>2015-02-01 23:46:04 +0800
commit1dac41d16f904830d007607e400837f6e47ec72c (patch)
treefc71137acb6483ffa35e8fc0cc4eee46071236a9 /deskutils
parenta0769ed9cea231abe15f9f3ca349dbeddc274877 (diff)
downloadfreebsd-ports-gnome-1dac41d16f904830d007607e400837f6e47ec72c.tar.gz
freebsd-ports-gnome-1dac41d16f904830d007607e400837f6e47ec72c.tar.zst
freebsd-ports-gnome-1dac41d16f904830d007607e400837f6e47ec72c.zip
- Enable the qt_hack component. It requires private qt headers, so
add a depend on extracting those from the qt4-gui port [1] - While here, strip binaries PR: 197218 [1] Submitted by: yuri@rawbw.com
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calibre/Makefile14
-rw-r--r--deskutils/calibre/files/patch-calibre_constants.py10
-rw-r--r--deskutils/calibre/files/patch-setup_extensions.py14
-rw-r--r--deskutils/calibre/pkg-plist1
4 files changed, 12 insertions, 27 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index c8a9c9dfa6fd..9b67a36743b2 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= calibre
PORTVERSION= 1.48.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
@@ -25,7 +25,8 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=0:${PORTSDIR}/devel/py-sip \
${PYTHON_PKGNAMEPREFIX}qt4-webkit>=0:${PORTSDIR}/www/py-qt4-webkit \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pillow>=0:${PORTSDIR}/graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
+ ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/qt4-gui:patch
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.9:${PORTSDIR}/www/py-cssutils \
${PYTHON_PKGNAMEPREFIX}dnspython>=0:${PORTSDIR}/dns/py-dnspython \
@@ -70,8 +71,14 @@ MAKE_ENV+= FC_INC_DIR="${LOCALBASE}/include/fontconfig" \
XDG_DATA_DIRS=${STAGEDIR}${PREFIX}/share \
XDG_CONFIG_HOME=${WRKDIR}/xdg-config
+.include <bsd.port.pre.mk>
+
+QTGUI_WRKSRC!= cd ${PORTSDIR}/x11-toolkits/qt4-gui && ${MAKE} -V WRKSRC
+
post-patch:
@${FIND} ${WRKSRC}/resources/content_server -name "*.orig" -delete
+ @${REINPLACE_CMD} -e "/^qt_private_inc =/s|\[]|[ '${QTGUI_WRKSRC}/include/QtGui', '${QTGUI_WRKSRC}/include/QtCore' ]|" \
+ ${WRKSRC}/setup/build_environment.py
do-build:
@${MKDIR} ${WRKDIR}/calibre-config ${WRKDIR}/xdg-config
@@ -88,5 +95,6 @@ do-install:
${PYSETUP} install --prefix ${PREFIX} \
--staging-root ${STAGEDIR}${PREFIX})
@${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/calibre/calibre/plugins/*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/calibre/files/patch-calibre_constants.py b/deskutils/calibre/files/patch-calibre_constants.py
deleted file mode 100644
index 26d57e7fec1c..000000000000
--- a/deskutils/calibre/files/patch-calibre_constants.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/calibre/constants.py.orig 2014-01-24 05:56:21.000000000 +0100
-+++ src/calibre/constants.py 2014-01-29 00:21:48.318819375 +0100
-@@ -138,7 +138,6 @@
- 'freetype',
- 'woff',
- 'unrar',
-- 'qt_hack',
- '_regex',
- 'hunspell',
- '_patiencediff_c',
diff --git a/deskutils/calibre/files/patch-setup_extensions.py b/deskutils/calibre/files/patch-setup_extensions.py
index e8a7a1aea166..df33ed16529f 100644
--- a/deskutils/calibre/files/patch-setup_extensions.py
+++ b/deskutils/calibre/files/patch-setup_extensions.py
@@ -1,19 +1,5 @@
--- setup/extensions.py.orig 2013-11-22 10:29:37.000000000 -0600
+++ setup/extensions.py 2013-11-22 10:30:39.000000000 -0600
-@@ -187,13 +187,6 @@
- sip_files=['calibre/gui2/progress_indicator/QProgressIndicator.sip']
- ),
-
-- Extension('qt_hack',
-- ['calibre/ebooks/pdf/render/qt_hack.cpp'],
-- inc_dirs=qt_private_inc + ['calibre/ebooks/pdf/render', 'qt-harfbuzz/src'],
-- headers=['calibre/ebooks/pdf/render/qt_hack.h'],
-- sip_files=['calibre/ebooks/pdf/render/qt_hack.sip']
-- ),
--
- Extension('unrar',
- ['unrar/%s.cpp'%(x.partition('.')[0]) for x in '''
- rar.o strlist.o strfn.o pathfn.o savepos.o smallfn.o global.o file.o
@@ -496,8 +489,9 @@
pro = textwrap.dedent('''
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 22916e0746d5..1606774f9f6d 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -1126,6 +1126,7 @@ lib/calibre/calibre/plugins/msdes.so
lib/calibre/calibre/plugins/pictureflow.so
lib/calibre/calibre/plugins/podofo.so
lib/calibre/calibre/plugins/progress_indicator.so
+lib/calibre/calibre/plugins/qt_hack.so
lib/calibre/calibre/plugins/speedup.so
lib/calibre/calibre/plugins/sqlite_custom.so
lib/calibre/calibre/plugins/tokenizer.so