aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-02-04 19:11:47 +0800
committermadpilot <madpilot@FreeBSD.org>2018-02-04 19:11:47 +0800
commit431d173580c4722d1d33cb09755559b5c9f7c9e6 (patch)
tree39193b737587a96a610b7f5350111ba4ea93c2c5 /deskutils
parentd2a36676edf65b90ac83bf3f70686f9afc62ecf6 (diff)
downloadfreebsd-ports-gnome-431d173580c4722d1d33cb09755559b5c9f7c9e6.tar.gz
freebsd-ports-gnome-431d173580c4722d1d33cb09755559b5c9f7c9e6.tar.zst
freebsd-ports-gnome-431d173580c4722d1d33cb09755559b5c9f7c9e6.zip
- Update deskutils/owncloudclient to 2.4.0
- Regenerate patches PR: 225583 Submitted by: me Approved by: yonas@fizk.net (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/owncloudclient/Makefile11
-rw-r--r--deskutils/owncloudclient/distinfo6
-rw-r--r--deskutils/owncloudclient/files/patch-doc_CMakeLists.txt14
-rw-r--r--deskutils/owncloudclient/files/patch-man_CMakeLists.txt15
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp8
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp8
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp6
-rw-r--r--deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp10
-rw-r--r--deskutils/owncloudclient/files/patch-src_libsync_syncjournaldb.h11
-rw-r--r--deskutils/owncloudclient/files/patch-src_libsync_syncjournalfilerecord.h10
-rw-r--r--deskutils/owncloudclient/pkg-plist31
11 files changed, 69 insertions, 61 deletions
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index 5d5b07a7e076..36c46688470f 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= owncloudclient
-PORTVERSION= 2.3.4
-PORTREVISION= 1
+PORTVERSION= 2.4.0
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
@@ -39,11 +38,17 @@ DEBUG_CMAKE_ON= -DCMAKE_BUILD_TYPE:STRING=Debug
PLIST_SUB= VERSION=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e \
's|.lst |.lst.sample |' ${WRKSRC}/CMakeLists.txt
+.if ${OSVERSION} < 1100101
+ @${REINPLACE_CMD} -e 's/ -fstack-protector-strong//' \
+ ${WRKSRC}/src/CMakeLists.txt
+.endif
pre-configure:
@(cd ${WRKSRC} && ${CP} -f sync-exclude.lst sync-exclude.lst.sample)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/owncloudclient/distinfo b/deskutils/owncloudclient/distinfo
index f007313aee74..03801a1d7fd7 100644
--- a/deskutils/owncloudclient/distinfo
+++ b/deskutils/owncloudclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1512670982
-SHA256 (owncloud-client-v2.3.4_GH0.tar.gz) = 17dd5bb7afb996ee155b8fe68a4fd4b75a8d46563226da470c4e598d6f990bc6
-SIZE (owncloud-client-v2.3.4_GH0.tar.gz) = 14482919
+TIMESTAMP = 1517213252
+SHA256 (owncloud-client-v2.4.0_GH0.tar.gz) = e4abdd33f24e21f15df53f2e8de90d123f974c519259a8c9d86d22c8e4103b86
+SIZE (owncloud-client-v2.4.0_GH0.tar.gz) = 14732065
diff --git a/deskutils/owncloudclient/files/patch-doc_CMakeLists.txt b/deskutils/owncloudclient/files/patch-doc_CMakeLists.txt
index 2c908a10c9d8..7aa57c6e3cb2 100644
--- a/deskutils/owncloudclient/files/patch-doc_CMakeLists.txt
+++ b/deskutils/owncloudclient/files/patch-doc_CMakeLists.txt
@@ -1,11 +1,11 @@
---- doc/CMakeLists.txt.orig 2015-03-16 14:28:58 UTC
+--- doc/CMakeLists.txt.orig 2017-12-20 15:03:02 UTC
+++ doc/CMakeLists.txt
-@@ -12,6 +12,8 @@ if(SPHINX_FOUND)
+@@ -11,7 +11,7 @@ if(SPHINX_FOUND)
# assets
set(LATEX_LOGO "${CMAKE_CURRENT_SOURCE_DIR}/logo-blue.pdf")
-+ set(CMAKE_INSTALL_DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/owncloudclient")
-+
- install(DIRECTORY ${SPHINX_HTML_DIR} DESTINATION ${CMAKE_INSTALL_DOCDIR} OPTIONAL)
- install(DIRECTORY ${SPHINX_MAN_DIR} DESTINATION ${CMAKE_INSTALL_MANDIR} OPTIONAL)
- install(DIRECTORY ${SPHINX_PDF_DIR} DESTINATION ${CMAKE_INSTALL_DOCDIR} OPTIONAL)
+- set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DOCDIR}/${PACKAGE}")
++ set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/owncloudclient")
+ install(DIRECTORY ${SPHINX_HTML_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
+ install(DIRECTORY ${SPHINX_PDF_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
+ install(DIRECTORY ${SPHINX_QCH_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
diff --git a/deskutils/owncloudclient/files/patch-man_CMakeLists.txt b/deskutils/owncloudclient/files/patch-man_CMakeLists.txt
new file mode 100644
index 000000000000..c5412b20ae9f
--- /dev/null
+++ b/deskutils/owncloudclient/files/patch-man_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- man/CMakeLists.txt.orig 2017-12-20 15:03:02 UTC
++++ man/CMakeLists.txt
+@@ -3,6 +3,12 @@ if(SPHINX_FOUND)
+ # Sphinx cache with pickled ReST documents
+ set(SPHINX_CACHE_DIR "${CMAKE_CURRENT_BINARY_DIR}/_doctrees")
+
++ if(WITH_DOC)
++ add_custom_target(man ALL DEPENDS doc-man COMMENT "Building manual pages...")
++ else(WITH_DOC)
++ add_custom_target(man DEPENDS doc-maan COMMENT "Building manual pages...")
++ endif(WITH_DOC)
++
+ # HTML output directory
+ set(SPHINX_MAN_DIR "${CMAKE_CURRENT_BINARY_DIR}/man1")
+ install(DIRECTORY ${SPHINX_MAN_DIR} DESTINATION ${CMAKE_INSTALL_MANDIR} OPTIONAL)
diff --git a/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp b/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
index a279b76059e6..2f41eefd7126 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
@@ -1,12 +1,12 @@
---- src/gui/accountsettings.cpp.orig 2016-05-12 07:59:12 UTC
+--- src/gui/accountsettings.cpp.orig 2017-12-20 15:03:02 UTC
+++ src/gui/accountsettings.cpp
-@@ -31,7 +31,8 @@
- #include "creds/abstractcredentials.h"
+@@ -34,7 +34,8 @@
#include "tooltipupdater.h"
+ #include "filesystem.h"
-#include <math.h>
+#include <climits>
+#include <cmath>
- #include <QDebug>
#include <QDesktopServices>
+ #include <QDir>
diff --git a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
index 4704c6b28cd4..0b1683a51b39 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
@@ -1,14 +1,14 @@
---- src/gui/generalsettings.cpp.orig 2016-05-12 07:59:12 UTC
+--- src/gui/generalsettings.cpp.orig 2017-12-20 15:03:02 UTC
+++ src/gui/generalsettings.cpp
-@@ -124,6 +124,7 @@
+@@ -117,6 +117,7 @@ void GeneralSettings::loadMiscSettings()
void GeneralSettings::slotUpdateInfo()
{
+#if 0
// Note: the sparkle-updater is not an OCUpdater
- OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance());
+ OCUpdater *updater = qobject_cast<OCUpdater *>(Updater::instance());
if (ConfigFile().skipUpdateCheck()) {
-@@ -140,6 +141,7 @@
+@@ -133,6 +134,7 @@ void GeneralSettings::slotUpdateInfo()
// can't have those infos from sparkle currently
_ui->updatesGroupBox->setVisible(false);
}
diff --git a/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp b/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp
index 5c177ddf55d8..f9e0d7f0fd37 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp
@@ -1,7 +1,7 @@
---- src/gui/owncloudgui.cpp.orig 2016-05-12 07:59:12 UTC
+--- src/gui/owncloudgui.cpp.orig 2017-12-20 15:03:02 UTC
+++ src/gui/owncloudgui.cpp
-@@ -34,6 +34,8 @@
- #include "accountmanager.h"
+@@ -35,6 +35,8 @@
+ #include "common/syncjournalfilerecord.h"
#include "creds/abstractcredentials.h"
+#include <climits>
diff --git a/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp b/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp
index ff8edf05c12d..09f5dc7f7598 100644
--- a/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp
+++ b/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp
@@ -1,8 +1,8 @@
---- src/libsync/configfile.cpp.orig 2016-05-12 07:59:12 UTC
+--- src/libsync/configfile.cpp.orig 2017-12-20 15:03:02 UTC
+++ src/libsync/configfile.cpp
-@@ -415,11 +415,22 @@ bool ConfigFile::skipUpdateCheck( const
- QString con( connection );
- if( connection.isEmpty() ) con = defaultConnection();
+@@ -448,11 +448,22 @@ bool ConfigFile::skipUpdateCheck(const QString &connec
+ if (connection.isEmpty())
+ con = defaultConnection();
+#if 0
QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
@@ -22,4 +22,4 @@
+#endif
}
- void ConfigFile::setSkipUpdateCheck( bool skip, const QString& connection )
+ void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection)
diff --git a/deskutils/owncloudclient/files/patch-src_libsync_syncjournaldb.h b/deskutils/owncloudclient/files/patch-src_libsync_syncjournaldb.h
deleted file mode 100644
index f1c91c1b9a98..000000000000
--- a/deskutils/owncloudclient/files/patch-src_libsync_syncjournaldb.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/libsync/syncjournaldb.h.orig 2015-03-16 14:28:58 UTC
-+++ src/libsync/syncjournaldb.h
-@@ -19,6 +19,8 @@
- #include <QDateTime>
- #include <QHash>
-
-+#include <ctime>
-+
- #include "utility.h"
- #include "ownsql.h"
-
diff --git a/deskutils/owncloudclient/files/patch-src_libsync_syncjournalfilerecord.h b/deskutils/owncloudclient/files/patch-src_libsync_syncjournalfilerecord.h
deleted file mode 100644
index 8d88d3b0bdd4..000000000000
--- a/deskutils/owncloudclient/files/patch-src_libsync_syncjournalfilerecord.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libsync/syncjournalfilerecord.h.orig 2015-03-16 14:28:58 UTC
-+++ src/libsync/syncjournalfilerecord.h
-@@ -14,6 +14,7 @@
- #ifndef SYNCJOURNALFILERECORD_H
- #define SYNCJOURNALFILERECORD_H
-
-+#include <time.h>
- #include <QString>
- #include <QDateTime>
-
diff --git a/deskutils/owncloudclient/pkg-plist b/deskutils/owncloudclient/pkg-plist
index 169bf461f4c2..916279bca4c5 100644
--- a/deskutils/owncloudclient/pkg-plist
+++ b/deskutils/owncloudclient/pkg-plist
@@ -9,7 +9,6 @@ include/owncloudsync/mirall/networkjobs.h
include/owncloudsync/mirall/progressdispatcher.h
include/owncloudsync/mirall/syncengine.h
include/owncloudsync/mirall/syncfileitem.h
-include/owncloudsync/mirall/syncjournaldb.h
include/owncloudsync/mirall/syncresult.h
lib/libowncloudsync.so
lib/libowncloudsync.so.0
@@ -29,6 +28,7 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-7.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-8.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-9.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-activity.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client12.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client6.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_local.png
@@ -43,6 +43,9 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/log_output_window.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/mac-share.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/menu.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/ownCloud-remove_existing_connection.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/ownCloud-remove_existing_connection_confirmation_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/ownCloud-replacement_connection_wizard.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/save_log_file.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_account.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_activity.png
@@ -50,11 +53,13 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_network.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/share-1.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/share-2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/testing-checksums.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/advancedusage.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/architecture.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/autoupdate.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/building.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/conffile.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/envvars.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/faq.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/glossary.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/index.rst.txt
@@ -63,8 +68,6 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/lowdiskspace.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/navigating.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/options.rst.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloud.1.rst.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloudcmd.1.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloudcmd.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/troubleshooting.rst.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/visualtour.rst.txt
@@ -96,6 +99,7 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/autoupdate.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/building.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/conffile.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/envvars.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/glossary.html
@@ -106,8 +110,6 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/navigating.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/objects.inv
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/options.html
-%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/owncloud.1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/owncloudcmd.1.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/owncloudcmd.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/search.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/searchindex.js
@@ -121,8 +123,10 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/latex/client-7.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client-8.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client-9.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/client-activity.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client12.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client6.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/footnotehyper-sphinx.sty
%%PORTDOCS%%%%DOCSDIR%%/latex/icon-error.png
%%PORTDOCS%%%%DOCSDIR%%/latex/icon-information.png
%%PORTDOCS%%%%DOCSDIR%%/latex/icon-offline.png
@@ -130,18 +134,18 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/latex/icon-syncing.png
%%PORTDOCS%%%%DOCSDIR%%/latex/icon.png
%%PORTDOCS%%%%DOCSDIR%%/latex/ignored_files_editor.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/latexmkjarc
+%%PORTDOCS%%%%DOCSDIR%%/latex/latexmkrc
%%PORTDOCS%%%%DOCSDIR%%/latex/log_output_window.png
%%PORTDOCS%%%%DOCSDIR%%/latex/logo-blue.pdf
%%PORTDOCS%%%%DOCSDIR%%/latex/mac-share.png
%%PORTDOCS%%%%DOCSDIR%%/latex/menu.png
-%%PORTDOCS%%%%DOCSDIR%%/latex/footnotehyper-sphinx.sty
-%%PORTDOCS%%%%DOCSDIR%%/latex/latexmkjarc
-%%PORTDOCS%%%%DOCSDIR%%/latex/latexmkrc
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloud-remove_existing_connection.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloud-remove_existing_connection_confirmation_dialog.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloud-replacement_connection_wizard.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.aux
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.fdb_latexmk
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.fls
-%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxhighlight.sty
-%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxmulticell.sty
-%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.aux
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.idx
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.ilg
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.ind
@@ -156,8 +160,12 @@ share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/latex/share-1.png
%%PORTDOCS%%%%DOCSDIR%%/latex/share-2.png
%%PORTDOCS%%%%DOCSDIR%%/latex/sphinx.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxhighlight.sty
%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxhowto.cls
%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxmanual.cls
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxmulticell.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/testing-checksums.png
+share/icons/hicolor/1024x1024/apps/owncloud.png
share/icons/hicolor/128x128/apps/ownCloud_error.png
share/icons/hicolor/128x128/apps/ownCloud_error_shared.png
share/icons/hicolor/128x128/apps/ownCloud_ok.png
@@ -175,6 +183,7 @@ share/icons/hicolor/16x16/apps/ownCloud_sync.png
share/icons/hicolor/16x16/apps/ownCloud_sync_shared.png
share/icons/hicolor/16x16/apps/ownCloud_warn.png
share/icons/hicolor/16x16/apps/ownCloud_warn_shared.png
+share/icons/hicolor/16x16/apps/owncloud.png
share/icons/hicolor/22x22/apps/owncloud.png
share/icons/hicolor/256x256/apps/ownCloud_error.png
share/icons/hicolor/256x256/apps/ownCloud_error_shared.png