aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-29 23:27:17 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-29 23:27:17 +0800
commit492a3932462099afbd9ea2c95c231afb780fc91e (patch)
treef2afde96403293912ba3450de1e159ba824f51ea /deskutils
parentf1caa93ed8bc00f92aab2e365e6eb25d67474223 (diff)
downloadfreebsd-ports-gnome-492a3932462099afbd9ea2c95c231afb780fc91e.tar.gz
freebsd-ports-gnome-492a3932462099afbd9ea2c95c231afb780fc91e.tar.zst
freebsd-ports-gnome-492a3932462099afbd9ea2c95c231afb780fc91e.zip
- Change REINPLACE_CMD
- Add patches, fix build on FreeBSD 10 Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/q4wine/Makefile4
-rw-r--r--deskutils/q4wine/files/patch-src__q4wine-gui__process.h10
-rw-r--r--deskutils/q4wine/files/patch-src__q4wine-lib__q4wine-lib.h10
3 files changed, 22 insertions, 2 deletions
diff --git a/deskutils/q4wine/Makefile b/deskutils/q4wine/Makefile
index 07235914fd1c..aa2a73a1136d 100644
--- a/deskutils/q4wine/Makefile
+++ b/deskutils/q4wine/Makefile
@@ -26,8 +26,6 @@ USE_QT4= qmake_build rcc_build moc_build uic_build \
linguist_build corelib gui sql network
ONLY_FOR_ARCHS= i386 amd64
-#SUB_FILES= pkg-message
-
PORTDOCS= AUTHORS ChangeLog README TODO
OPTIONS_DEFINE= DOCS NLS DBUS
@@ -51,6 +49,8 @@ USE_QT4+= dbus
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|/share/man|/man|' \
+ ${WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e 's|^Categories=.*|Categories=Qt;System;Emulator;Utility;Game;|' \
${WRKSRC}/${PORTNAME}.desktop
diff --git a/deskutils/q4wine/files/patch-src__q4wine-gui__process.h b/deskutils/q4wine/files/patch-src__q4wine-gui__process.h
new file mode 100644
index 000000000000..8b937ff674fd
--- /dev/null
+++ b/deskutils/q4wine/files/patch-src__q4wine-gui__process.h
@@ -0,0 +1,10 @@
+--- ./src/q4wine-gui/process.h.orig 2013-05-02 22:38:39.000000000 +0200
++++ ./src/q4wine-gui/process.h 2013-10-29 00:24:57.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include <QLibrary>
+ #include <QTextCodec>
+ #include <QTextStream>
++#include <locale.h>
+
+ #ifdef DEBUG
+ #include <QDebug>
diff --git a/deskutils/q4wine/files/patch-src__q4wine-lib__q4wine-lib.h b/deskutils/q4wine/files/patch-src__q4wine-lib__q4wine-lib.h
new file mode 100644
index 000000000000..8afe5e6c352e
--- /dev/null
+++ b/deskutils/q4wine/files/patch-src__q4wine-lib__q4wine-lib.h
@@ -0,0 +1,10 @@
+--- ./src/q4wine-lib/q4wine-lib.h.orig 2013-05-02 22:38:39.000000000 +0200
++++ ./src/q4wine-lib/q4wine-lib.h 2013-10-29 00:21:12.000000000 +0100
+@@ -47,6 +47,7 @@
+ #include <QDesktopServices>
+ #include <QUrl>
+ #include <QTranslator>
++#include <locale.h>
+
+ #include "process.h"
+