aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-08-28 10:49:31 +0800
committervanilla <vanilla@FreeBSD.org>2014-08-28 10:49:31 +0800
commit75e5fac4cd909419f750d820f2da00c365af9ba7 (patch)
tree62f22138002fe9b0156fbf2b34f641edea4f7ac4 /deskutils
parent17e51f09671b297ff374540176c0400d61af16d7 (diff)
downloadfreebsd-ports-gnome-75e5fac4cd909419f750d820f2da00c365af9ba7.tar.gz
freebsd-ports-gnome-75e5fac4cd909419f750d820f2da00c365af9ba7.tar.zst
freebsd-ports-gnome-75e5fac4cd909419f750d820f2da00c365af9ba7.zip
Support STAGEDIR
PR: ports/193029 Submitted by: Ports Fury.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/tel/Makefile30
1 files changed, 22 insertions, 8 deletions
diff --git a/deskutils/tel/Makefile b/deskutils/tel/Makefile
index 36f1562cecec..5e007b502e76 100644
--- a/deskutils/tel/Makefile
+++ b/deskutils/tel/Makefile
@@ -3,21 +3,35 @@
PORTNAME= tel
PORTVERSION= 0.1.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
-MASTER_SITES= CENKES BERLIOS
+MASTER_SITES= SF/${PORTNAME}.berlios
MAINTAINER= ports@FreeBSD.org
COMMENT= Little console-based phone book manager
-USES= gettext tar:bzip2
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-NO_STAGE= yes
+LICENSE= MIT
+
+NO_ARCH= yes
+
+USES= gettext python shebangfix tar:bzip2
+SHEBANG_FILES= src/tel.py
+python_OLD_CMD= /usr/bin/env python
+python_CMD= ${PYTHON_CMD}
+USE_PYTHON= distutils
post-patch:
- @${REINPLACE_CMD} \
- -e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
+ @${REINPLACE_CMD} -e \
+ 's|distutils\.command\.install |setuptools\.command\.install |' \
${WRKSRC}/appdistutils.py
+ @${REINPLACE_CMD} -e \
+ 's|$${install_messages}|${PREFIX}/share/locale| ; \
+ s|$${install_app_modules}|${PREFIX}/lib/tel| ; \
+ s|$${install_app_data}|${DATADIR}|' \
+ ${WRKSRC}/src/tel.py
+
+post-install:
+ @${FIND} ${STAGEDIR}${PREFIX}/bin -type l -delete
+ @${LN} -sf ${PREFIX}/lib/tel/tel.py ${STAGEDIR}${PREFIX}/bin/tel
.include <bsd.port.mk>