aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-01 06:24:30 +0800
committerbapt <bapt@FreeBSD.org>2014-10-01 06:24:30 +0800
commit86e4bf670f00a0430c73abcdc2d0f718f1eecf93 (patch)
tree1456d7554996655ed30ce158958b16375e47c979 /deskutils
parentea75169b58ac21daeeb8fb1d50ac2432ce6dada2 (diff)
downloadfreebsd-ports-gnome-86e4bf670f00a0430c73abcdc2d0f718f1eecf93.tar.gz
freebsd-ports-gnome-86e4bf670f00a0430c73abcdc2d0f718f1eecf93.tar.zst
freebsd-ports-gnome-86e4bf670f00a0430c73abcdc2d0f718f1eecf93.zip
Convert to USES=horde
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/horde-groupware/Makefile7
-rw-r--r--deskutils/horde-kronolith/Makefile21
-rw-r--r--deskutils/horde-mnemo/Makefile12
-rw-r--r--deskutils/horde-nag/Makefile7
4 files changed, 12 insertions, 35 deletions
diff --git a/deskutils/horde-groupware/Makefile b/deskutils/horde-groupware/Makefile
index 14ab22ca4126..636e29fbd549 100644
--- a/deskutils/horde-groupware/Makefile
+++ b/deskutils/horde-groupware/Makefile
@@ -10,8 +10,7 @@ COMMENT= Horde Groupware
CONFLICTS= horde-webmail-[456]*
-LATEST_LINK= horde-${PORTNAME}
-
+USES= horde
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
content \
@@ -24,6 +23,4 @@ USE_HORDE_RUN= Horde_Role \
trean \
turba
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/horde-kronolith/Makefile b/deskutils/horde-kronolith/Makefile
index f2279707cf7a..3d774126d007 100644
--- a/deskutils/horde-kronolith/Makefile
+++ b/deskutils/horde-kronolith/Makefile
@@ -12,14 +12,13 @@ COMMENT= Horde web based calendar
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LATEST_LINK= horde-${PORTNAME}
-
OPTIONS_DEFAULT= DATE_HOLIDAYS TIMEOBJECTS
OPTIONS_DEFINE= DATE_HOLIDAYS TIMEOBJECTS XMLWRITER
DATE_HOLIDAYS_DESC= Depend on PEAR Date_Holidays
TIMEOBJECTS_DESC= Depenbd on Horde timeobjects
XMLWRITER_DESC= Depend on PHP xmlwriter extension
+USES= horde
USE_PHP= gettext json simplexml
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
@@ -55,19 +54,9 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_View
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDATE_HOLIDAYS}
-RUN_DEPENDS+= ${PEARDIR}/Date/Holidays.php:${PORTSDIR}/devel/pear-Date_Holidays
-.endif
-
-.if ${PORT_OPTIONS:MTIMEOBJECTS}
-USE_HORDE_RUN+= timeobjects
-.endif
+HOLIDAYS_RUN_DEPENDS= ${PEARDIR}/Date/Holidays.php:${PORTSDIR}/devel/pear-Date_Holidays
-.if ${PORT_OPTIONS:MXMLWRITER}
-USE_PHP+= xmlwriter
-.endif
+TIMEOBJECTS_USE= HORDE_RUN=timeobjects
+XMLWRITER_USE= PHP=xmlwriter
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/horde-mnemo/Makefile b/deskutils/horde-mnemo/Makefile
index 19d4712452bc..591573a8babd 100644
--- a/deskutils/horde-mnemo/Makefile
+++ b/deskutils/horde-mnemo/Makefile
@@ -11,8 +11,7 @@ COMMENT= Horde web based notes manager
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-LATEST_LINK= horde-${PORTNAME}
-
+USES= horde
USE_PHP= gettext
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
@@ -37,11 +36,6 @@ OPTIONS_DEFAULT= PDF
OPTIONS_DEFINE= PDF
PDF_DESC= Support PDF generation
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPDF}
-USE_HORDE_RUN+= Horde_Pdf
-.endif
+PDF_USE= HORDE_RUN=Horde_Pdf
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/horde-nag/Makefile b/deskutils/horde-nag/Makefile
index dda0dd6228ed..609f41683740 100644
--- a/deskutils/horde-nag/Makefile
+++ b/deskutils/horde-nag/Makefile
@@ -11,8 +11,7 @@ COMMENT= Horde web based task list manager
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LATEST_LINK= horde-${PORTNAME}
-
+USES= horde
USE_PHP= gettext
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
@@ -39,6 +38,4 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_View
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>