aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-11-12 07:23:40 +0800
committerjbeich <jbeich@FreeBSD.org>2018-11-12 07:23:40 +0800
commita6d52b91b5d5ccbbd39860d3dd969426f56b7144 (patch)
tree56ce7481f2f4962c6b1701394dafae7eb0b3db4f /deskutils
parent6e2af9dd405dd0e59bd2b264ed6eb0447a5c9779 (diff)
downloadfreebsd-ports-gnome-a6d52b91b5d5ccbbd39860d3dd969426f56b7144.tar.gz
freebsd-ports-gnome-a6d52b91b5d5ccbbd39860d3dd969426f56b7144.tar.zst
freebsd-ports-gnome-a6d52b91b5d5ccbbd39860d3dd969426f56b7144.zip
deskutils/cairo-dock: track more dependencies
====> Running Q/A tests (stage-qa) Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libdbus-1.so.3 from devel/dbus but it is not declared as a dependency Warning: you need LIB_DEPENDS+=libdbus-1.so:devel/dbus Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libGLU.so.1 from graphics/libGLU but it is not declared as a dependency Warning: you need USE_GL+=glu Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libGL.so.1 from graphics/mesa-libs but it is not declared as a dependency Warning: you need USE_GL+=gl Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libwayland-client.so.0 from graphics/wayland but it is not declared as a dependency Warning: you need LIB_DEPENDS+=libwayland-client.so:graphics/wayland Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libXcomposite.so.1 from x11/libXcomposite but it is not declared as a dependency Warning: you need USE_XORG+=xcomposite Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libXrandr.so.2 from x11/libXrandr but it is not declared as a dependency Warning: you need USE_XORG+=xrandr Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libX11.so.6 from x11/libX11 but it is not declared as a dependency Warning: you need USE_XORG+=x11 Error: /usr/local/bin/cairo-dock is linked to /usr/local/lib/libXinerama.so.1 from x11/libXinerama but it is not declared as a dependency Warning: you need USE_XORG+=xinerama PR: 227509 Reported by: antoine (via exp-run)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/cairo-dock/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/deskutils/cairo-dock/Makefile b/deskutils/cairo-dock/Makefile
index dbc63b57de80..186510f2d7e4 100644
--- a/deskutils/cairo-dock/Makefile
+++ b/deskutils/cairo-dock/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cairo-dock
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= deskutils
MAINTAINER= ports@FreeBSD.org
@@ -12,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcairo.so:graphics/cairo \
libcurl.so:ftp/curl \
+ libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
RUN_DEPENDS= bash:shells/bash \
@@ -22,15 +24,35 @@ GH_ACCOUNT= Cairo-Dock
GH_PROJECT= ${PORTNAME}-core
GNU_CONFIGURE= yes
-USES= cmake compiler:c++11-lang gettext gnome localbase:ldflags \
+USES= cmake compiler:c++11-lang gettext gl gnome localbase:ldflags \
pkgconfig
+USE_GL= glu
USE_GNOME= glib20 gtk30 librsvg2 libxml2
USE_LDCONFIG= yes
-USE_XORG= xrender xtst
CMAKE_ARGS= -Dinstall-pc-path:STRING="${LOCALBASE}/libdata/pkgconfig" \
-DROOT_PREFIX:PATH=${STAGEDIR} \
-DCMAKE_INSTALL_MANDIR:PATH=man \
+OPTIONS_DEFINE= X11 WAYLAND
+OPTIONS_DEFAULT=GLX X11
+OPTIONS_RADIO= GL
+OPTIONS_RADIO_GL= GLX EGL
+
+EGL_DESC= ${GLX_DESC:S/X11/Native/}
+EGL_CMAKE_BOOL= enable-egl-support
+EGL_USE= GL=egl
+
+GLX_USE= GL=gl
+GLX_IMPLIES= X11
+
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland
+WAYLAND_USE= GL=egl
+WAYLAND_CMAKE_BOOL= enable-wayland-support
+WAYLAND_IMPLIES= EGL
+
+X11_USE= XORG=x11,xcomposite,xinerama,xrandr,xrender,xtst
+X11_CMAKE_BOOL= enable-x11-support
+
post-patch:
@${FIND} ${WRKSRC} -type f -name "*" | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr/share/pixmaps/|${LOCALBASE}/share/pixmaps/|g; \